aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages forth)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system trivial)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages vim))

(define-public gforth
  (package
    (name "gforth")
    (version "0.7.3")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gforth/gforth-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "1c1bahc9ypmca8rv2dijiqbangm1d9av286904yw48ph7ciz4qig"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f             ; XXX: parallel build fails
       #:phases
       (modify-phases %standard-phases
         (add-after 'install 'install-gforth.el
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out           (assoc-ref outputs "out"))
                    (emacs-sitedir (string-append
                                    out "/share/emacs/site-lisp")))
               ;; TODO: compile and autoload it.
               (install-file "gforth.el" emacs-sitedir)
               #t))))))
    (native-inputs
     (list m4))
    (synopsis "Forth interpreter")
    (description
     "Gforth is a fast and portable implementation of the ANSI Forth language.
It includes an editing mode for Emacs and an interpreter featuring completion
and history.  A generic virtual machine environment, vmgen, is also
included.")
    (home-page "https://www.gnu.org/software/gforth/")
    (license license:gpl3+)))

(define-public smithforth
  (package
    (name "smithforth")
    (version "220711")
    (source
      (origin
        (method url-fetch)
        (uri (string-append "https://dacvs.neocities.org/SF/SForth"
                            version "dmp.txt"))
        (sha256
          (base32 "0a39pv7529llsa3f48fmvwvlcp3f9v8qkn5ziw2l6kxf0qvli3lm"))))
    (build-system trivial-build-system)
    (native-inputs (list xxd
                         (origin
                           (method url-fetch)
                           (uri (string-append
                                 "https://dacvs.neocities.org/SF/system"
                                 version "fs.txt"))
                           (sha256
                            (base32
                             "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m")))))
    (arguments
      (list
        #:modules '((guix build utils))
        #:builder
        #~(begin
            (use-modules (guix build utils)
                         (ice-9 textual-ports))
            (let* ((sforth.dmp #$(package-source this-package))
                   (system.fs  #$(this-package-native-input
                                  (string-append "system" version "fs.txt")))
                   (xxd        (string-append (assoc-ref %build-inputs "xxd")
                                              "/bin/xxd"))
                   (bin        (string-append (assoc-ref %outputs "out") "/bin")))
              (copy-file sforth.dmp "sforth.dmp")
              (substitute* "sforth.dmp" (("#.*$") "\n"))
              (with-output-to-file "sforth"
                (lambda _
                  (invoke xxd "-p" "-r" "sforth.dmp")
                  (call-with-input-file system.fs
                    (lambda (port) (display (get-string-all port)))))
                #:binary #t)
              (chmod "sforth" #o755)
              (install-file "sforth" bin)))))
    (home-page "https://dacvs.neocities.org/SF/")
    (synopsis "Forth programming language for x86-64 desktop computers")
    (description "SmithForth is an implementation of the Forth programming
language for x86-64 desktop computers. SmithForth is a text interpreter that
runs in a Linux text console.")
    (supported-systems '("x86_64-linux"))
    (license license:expat-0)))
x/commit/gnu/packages/llvm.scm?id=a72bebf8f578931d042a3527906169a3b554441b'>gnu: clang-toolchain-10: Use libomp-10....* gnu/packages/llvm.scm (clang-toolchain-10): Switch dependency from the default libomp-13 to libomp-10. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: Add libomp-10....* gnu/packages/llvm.scm (libomp-10): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: clang-toolchain-11: Use libomp-11....* gnu/packages/llvm.scm (clang-toolchain-11): Switch dependency from the default libomp-13 to libomp-11. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: Add libomp-11....* gnu/packages/llvm.scm (libomp-11): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: clang-toolchain-12: Use libomp-12....* gnu/packages/llvm.scm (clang-toolchain-12): Switch dependency from the default libomp-13 to libomp-12. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: Add libomp-12....* gnu/packages/llvm.scm (libomp-12): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: libomp-13: Reference llvm-13 version string....* gnu/packages/llvm.scm (libomp-13): Reference llvm-13 version string. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: libomp-14: Reference llvm-14 version string....* gnu/packages/llvm.scm (libomp-14): Reference llvm-14 version string. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-08-04gnu: lldb: Update to 14.0.6....* gnu/packages/llvm.scm (lldb): Update to 14.0.6. [source]: Fetch using LLVM-MONOREPO. [phases]: Add phase to change to source subdirectory. [inputs]: Change from LLVM-13 and CLANG-13 to LLVM-14 and CLANG-14. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Greg Hogan 2022-07-12gnu: clang-toolchain-14: Build with libomp-14....* gnu/packages/llvm.scm (libomp-14): New variable. (libomp-13): Inherit from libomp-14. (libomp): Define as libomp-13. (make-clang-toolchain): Parameterize libomp. (clang-toolchain-14): Use libomp-14. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-07-12gnu: LLVM, Clang, LLD: Update to 14.0.6....* gnu/packages/llvm.scm (llvm-14, clang-14, lld-14): Update to 14.0.6. (%llvm-monorepo-hashes, %llvm-patches): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-07-12gnu: llvm-3.7, llvm-3.8: Fix build with gcc....* gnu/packages/patches/clang-runtime-3.7-fix-build-with-python3.patch, gnu/packages/patches/llvm-3.x.1-fix-build-with-gcc.patch: New files. * gnu/packages/llvm.scm (clang-runtime-3.7, llvm-3.7, llvm-3.8): Use patches. * gnu/local.mk: Register patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-07-12gnu: llvm-8: Fix build with gcc-10....* gnu/packages/patches/llvm-8-fix-build-with-gcc-10.patch: New file. * gnu/packages/llvm.scm (clang-8, clang-runtime-8): Update to 8.0.1. * gnu/packages/llvm.scm (llvm-8): Use patch and update to 8.0.1. * gnu/local.mk: Register patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-06-28gnu: llvm-for-rocm: Inherit from llvm-14...* gnu/packages/llvm.scm (llvm-for-rocm)[arguments]: Inherit from llvm-14 instead of llvm-12 and use g-exp for #:configure-flags. Lars-Dominik Braun 2022-06-22gnu: llvm-9: Fix building on riscv64-linux....* gnu/packages/llvm.scm (llvm-9)[arguments]: When building for riscv64-linux add a phase to fix building one of the binaries. Efraim Flashner 2022-06-16gnu: llvm-9: Fix building on riscv64-linux....* gnu/packages/llvm.scm (llvm-12)[arguments]: Add a phase to update config.guess when config is one of the native-inputs. (llvm-10)[native-inputs]: Add config when building for riscv64-linux and the llvm version is less than 11. Efraim Flashner 2022-06-16gnu: Update llvm-for-rocm: Update to 5.1.3....* gnu/packages/llvm.scm (llvm-for-rocm): Update to 5.1.3, now based on llvm-14. [source]{patches}: Remove unneeded patches (add_Object and add_libraries) and add new one (linkdl). * gnu/packages/patches/llvm-roc-3.0.0-add_libraries.patch, gnu/packages/patches/llvm-roc-4.2.0-add_Object.patch: Delete files. * gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch: New file. * gnu/local.mk (dist_patch_DATA): Update to match current patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org> John Kehayias 2022-06-13gnu: LLVM, Clang, LLD: Update to 14.0.5....* gnu/packages/llvm.scm (llvm-14, clang-14, lld-14): Update to 14.0.5. (%llvm-monorepo-hashes, %llvm-patches): Adjust accordingly. Marius Bakke 2022-06-12gnu: llvm-14: Fix configure-flags for cross-compiling....* gnu/packages/llvm.scm (llvm-14)[arguments]: Fix syntax error in configure-flags when cross-compiling llvm. Efraim Flashner 2022-06-01gnu: LLVM, Clang, LLD: Update to 14.0.4....* gnu/packages/llvm.scm (%llvm-monorepo-hashes): Adjust for 14.0.4. (%llvm-patches): Likewise. (llvm-14, clang-14, lld-14): Update to 14.0.4. * gnu/packages/patches/clang-14.0-libc-search-path.patch: Adjust for upstream changes. Marius Bakke 2022-05-29gnu: clang-from-llvm: Fix building on riscv64-linux....* gnu/packages/llvm.scm (clang-from-llvm)[arguments]: When building for riscv64-linux add configure-flags and make-flags to ensure linking with '-latomic'. Efraim Flashner 2022-05-28gnu: clang-from-llvm: Fix build on some architectures....* gnu/packages/llvm.scm (clang-from-llvm)[arguments]: Adjust custom 'symlink-cfi_ignorelist phase to only symlink when the file exists. Efraim Flashner 2022-05-22gnu: clang@14: Include the extras....* gnu/packages/llvm.scm (clang-14): Add a matching #:tools-extra origin. Reported by foobarxyz on #guix. Tobias Geerinckx-Rice 2022-05-20gnu: clang: Add OBJC_INCLUDE_PATH to native-search-paths....Clang is also a compiler for Objective-C. * gnu/packages/llvm.scm (clang-for-llvm): Add OBJC_INCLUDE_PATH to native-search-paths. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zhu Zihao 2022-05-12gnu: python-llvmlite: Update to 0.38.0....* gnu/packages/llvm.scm (python-llvmlite): Update to 0.38.0. Maxim Cournoyer 2022-05-09gnu: LLVM, Clang: Update to 14.0.3....* gnu/packages/llvm.scm (%llvm-monorepo-hashes, %llvm-patches, llvm-14, lld-14): Update to 14.0.3. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2022-04-10gnu: llvm-3: Fix build....* gnu/packages/llvm.scm (llvm-3.9)[arguments]: Use gexp. Add 'shared-lib-workaround' phase. Co-authored-by: Maxime Devos <maximedevos@telenet.be> Guillaume Le Vaillant 2022-04-07gnu: LLVM, Clang: Add 14.0.0....* gnu/packages/llvm.scm (%llvm-monorepo-hashes, %llvm-patches, llvm-monorepo): New variables. (clang-runtime-from-llvm): Make HASH optional; use monorepo when not present. (clang-from-llvm): Likewise. (llvm-14, clang-runtime-14, clang-14, clang-toolchain-14, lld-14): New variables. (llvm-13): Inherit from LLVM-14. (lld-13): Inherit from LLD-14. (lld): Turn into alias for LLD-14. * gnu/packages/patches/clang-14.0-libc-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/zig.scm (zig): Change from LLD to LLD-13. Marius Bakke 2022-02-16gnu: clang: Build and link as shared libraries....Fixes <https://issues.guix.gnu.org/52054>. * gnu/packages/llvm.scm (clang)[arguments]<#:phases>: Remove the separate "extra" output and build the main package and clang-tools-extras with shared library linkage. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan