aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages forth)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system trivial)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages vim))

(define-public gforth
  (package
    (name "gforth")
    (version "0.7.3")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gforth/gforth-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "1c1bahc9ypmca8rv2dijiqbangm1d9av286904yw48ph7ciz4qig"))))
    (build-system gnu-build-system)
    (arguments
     '(#:parallel-build? #f             ; XXX: parallel build fails
       #:phases
       (modify-phases %standard-phases
         (add-after 'install 'install-gforth.el
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out           (assoc-ref outputs "out"))
                    (emacs-sitedir (string-append
                                    out "/share/emacs/site-lisp")))
               ;; TODO: compile and autoload it.
               (install-file "gforth.el" emacs-sitedir)
               #t))))))
    (native-inputs
     (list m4))
    (synopsis "Forth interpreter")
    (description
     "Gforth is a fast and portable implementation of the ANSI Forth language.
It includes an editing mode for Emacs and an interpreter featuring completion
and history.  A generic virtual machine environment, vmgen, is also
included.")
    (home-page "https://www.gnu.org/software/gforth/")
    (license license:gpl3+)))

(define-public smithforth
  (package
    (name "smithforth")
    (version "220711")
    (source
      (origin
        (method url-fetch)
        (uri (string-append "https://dacvs.neocities.org/SF/SForth"
                            version "dmp.txt"))
        (sha256
          (base32 "0a39pv7529llsa3f48fmvwvlcp3f9v8qkn5ziw2l6kxf0qvli3lm"))))
    (build-system trivial-build-system)
    (native-inputs (list xxd))
    (arguments
      (list
        #:modules '((guix build utils))
        #:builder
        #~(begin
            (use-modules (guix build utils)
                         (ice-9 textual-ports))
            (let* ((sforth.dmp #$(package-source this-package))
                   (system.fs  #$(origin
                                   (method url-fetch)
                                   (uri (string-append
                                          "https://dacvs.neocities.org/SF/system"
                                          version "fs.txt"))
                                   (sha256
                                    (base32
                                     "17v1pp64s6n8q8w3kg48nd7zdcx2208y4svr5fpfms5lkyzg7z1m"))))
                   (xxd        (string-append (assoc-ref %build-inputs "xxd")
                                              "/bin/xxd"))
                   (bin        (string-append (assoc-ref %outputs "out") "/bin")))
              (copy-file sforth.dmp "sforth.dmp")
              (substitute* "sforth.dmp" (("#.*$") "\n"))
              (with-output-to-file "sforth"
                (lambda _
                  (invoke xxd "-p" "-r" "sforth.dmp")
                  (call-with-input-file system.fs
                    (lambda (port) (display (get-string-all port)))))
                #:binary #t)
              (chmod "sforth" #o755)
              (install-file "sforth" bin)))))
    (home-page "https://dacvs.neocities.org/SF/")
    (synopsis "Forth programming language for x86-64 desktop computers")
    (description "SmithForth is an implementation of the Forth programming
language for x86-64 desktop computers. SmithForth is a text interpreter that
runs in a Linux text console.")
    (supported-systems '("x86_64-linux"))
    (license license:expat-0)))
sg-tooltip'>* gnu/packages/ssh.scm (libssh): Update to 0.7.5. [source](patches): New field. Ludovic Courtès 2017-05-20gnu: libssh, guile-ssh: Add a "debug" output....* gnu/packages/ssh.scm (libssh)[outputs]: New field. (guile-ssh)[outputs]: New field. Ludovic Courtès 2017-05-19gnu: dropbear: Update to 2017.75 [fixes CVE-2017-{9078,9079}]....* gnu/packages/ssh.scm (dropbear): Update to 2017.75. Leo Famulari 2017-05-19gnu: guile-ssh: Fix potential double-free/use-after-free issue....Fixes <http://bugs.gnu.org/26976>. Reported by Mark H Weaver <mhw@netris.org>. * gnu/packages/patches/guile-ssh-double-free.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (guile-ssh)[source](patches): Add it. Ludovic Courtès 2017-05-16gnu: guile-ssh: Fix bug in 'node-guile-version'....* gnu/packages/patches/guile-ssh-rexec-bug.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (guile-ssh)[source](patches): New field. Ludovic Courtès 2017-05-13gnu: guile-ssh: Rename "guile2.2-ssh" to "guile-ssh"....* gnu/packages/ssh.scm (guile-ssh)[inputs]: Change GUILE-2.0 to GUILE-2.2. (guile2.2-ssh): Define using 'deprecated-package'. (guile2.0-ssh): New variable. * gnu/packages/package-management.scm (guix)[propagated-inputs]: Adjust accordingly. Ludovic Courtès 2017-05-09gnu: guile-ssh: Update to 0.11.0....* gnu/packages/ssh.scm (guile-ssh): Update to 0.11.0. [source]: Add 'modules' and 'snippet'. (guile2.2-ssh)[version, source]: Remove. Ludovic Courtès 2017-05-09gnu: guile2.2-ssh: Update snapshot....* gnu/packages/ssh.scm (guile2.2-ssh): Update to commit ca717e9. [source]: Change URL to upstream's. Ludovic Courtès 2017-05-04gnu: openssh: groff is a native-input....* gnu/packages/ssh.scm (openssh)[inputs]: Move groff ... [native-inputs]: ... here. Leo Famulari 2017-04-22gnu: Add guile2.2-ssh....* gnu/packages/ssh.scm (guile2.2-ssh): New variable. Ludovic Courtès 2017-03-27Merge branch 'master' into core-updatesLeo Famulari 2017-03-27gnu: corkscrew: Install the README file....* gnu/packages/ssh.scm (corkscrew)[arguments]: Add a very basic ‘install-documentation’ phase. Tobias Geerinckx-Rice 2017-03-27gnu: corkscrew: Improve descriptions....* gnu/packages/ssh.scm (corkscrew)[synopsis, description]: Fix typos and condense. Remove scary warning (the tunnel is always encrypted through SSH) and speculation. Tobias Geerinckx-Rice 2017-03-27gnu: corkscrew: Download source from a mirror....* gnu/packages/ssh.scm (corkscrew)[source]: Use ‘https://downloads.openwrt.org’. Tobias Geerinckx-Rice 2017-03-27gnu: mosh: Update to 1.3.0....* gnu/packages/ssh.scm (mosh): Update to 1.3.0. Tobias Geerinckx-Rice 2017-03-22Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2017-03-22gnu: openssh: Update to 7.5p1....* gnu/packages/ssh.scm (openssh): Update to 7.5p1. Leo Famulari 2017-03-19gnu: lsh: Use libc's argp instead of the bundled one....* gnu/packages/ssh.scm (lsh)[arguments] <#:configure-flags>: Add --with-system-argp and CPPFLAGS=-DHAVE_ARGP_PARSE. <#:phases>: In 'pre-configure' phase, modify src/Makefile.in. Ludovic Courtès 2017-03-09Merge branch 'master' into core-updatesLudovic Courtès 2017-02-26gnu: libssh2: Fix build failure after 1.8.0 upgrade....* gnu/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (libssh2)[source]: Use it. [arguments]: Add 'autoreconf' phase. [native-inputs]: Add AUTOCONF and AUTOMAKE. Marius Bakke 2017-02-26gnu: libssh: Update to 0.7.4....* gnu/packages/ssh.scm (libssh): Update to 0.7.4. [home-page]: Use HTTPS. Marius Bakke 2017-01-23Merge branch 'master' into core-updatesLudovic Courtès 2017-01-19gnu: Move Kerberos implemetations to (gnu packages kerberos)....* gnu/packages/mit-krb5.scm: Remove. * gnu/packages/shishi.scm: Remove. * gnu/packages/kerberos.scm: New file, from the concatenation of these two. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/packages/admin.scm, gnu/packages/cyrus-sasl.scm, gnu/packages/gnome.scm, gnu/packages/gnuzilla.scm, gnu/packages/gsasl.scm, gnu/packages/java.scm, gnu/packages/networking.scm, gnu/packages/nfs.scm, gnu/packages/onc-rpc.scm, gnu/packages/ssh.scm, gnu/packages/web.scm: Adjust accordingly. Ludovic Courtès 2017-01-06Merge branch 'master' into core-updatesLeo Famulari 2016-12-22gnu: libssh2: Update to 1.8.0....* gnu/packages/ssh.scm (libssh2): Update to 1.8.0. Leo Famulari 2016-12-19gnu: openssh: Update to 7.4p1....* gnu/packages/ssh.scm (openssh): Update to 7.4p1. [source]: Remove 'openssh-memory-exhaustion.patch'. * gnu/packages/patches/openssh-memory-exhaustion.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Leo Famulari 2016-11-25gnu: guile-ssh: Update to 0.10.2....* gnu/packages/ssh.scm (guile-ssh): Update to 0.10.2. [home-page]: Update. [source]: Use the 'url-fetch' method and a GitHub generated tarball. [arguments] <autoreconf>: Remove now unneeded 'chmod' call. Ludovic Courtès 2016-10-26gnu: Add autossh....* gnu/packages/ssh.scm (autossh): New variable. Christopher Allan Webber 2016-10-19gnu: openssh: Fix CVE-2016-8858....* gnu/packages/patches/openssh-memory-exhaustion.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (openssh)[source]: Use it. Leo Famulari 2016-10-17gnu: openssh: Enable kerberos features....* gnu/packages/ssh.scm (openssh) [arguments]: Add flag --with-kerberos5. [inputs]: Add mit-krb5. John Darrington 2016-10-09gnu: guile-ssh: Update to 0.10.1....* gnu/packages/ssh.scm (libssh-0.6): Remove. (guile-ssh): Update to 0.10.1. [inputs]: Use LIBSSH instead of LIBSSH-0.7.3. [arguments]: Remove #:configure-flags. Ludovic Courtès 2016-10-09gnu: guile-ssh: Compile .scm files after patching them....Before this commit, the .go files were obtained by compiling the unpatched .scm files, so they would refer to libguile-ssh without its absolute file name. * gnu/packages/ssh.scm (guile-ssh)[arguments]: Move 'fix-libguile-ssh-file-name' before 'build'. Have it run "make install -C libguile-ssh" first. Ludovic Courtès 2016-10-09gnu: guile-ssh: Use 'modify-phases'....* gnu/packages/ssh.scm (guile-ssh)[arguments]: Use 'modify-phases'. Ludovic Courtès 2016-09-29services: Add 'openssh-service'....* gnu/packages/ssh.scm (openssh)[arguments]: Set sysconfdir to /etc/ssh. * gnu/services/ssh.scm (<openssh-configuration>): New record type. (%openssh-accounts): New variable. (openssh-activation, openssh-config-file, openssh-shepherd-service) (openssh-service): New procedures. (openssh-service-type): New variable. * doc/guix.texi (Networking Services): Document 'openssh-services'. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Julien Lepiller 2016-08-22gnu: openssh: Set the default sshd user PATH to something sensible....* gnu/packages/ssh.scm (openssh)[arguments]: Pass "--with-default-path". Ludovic Courtès 2016-08-22gnu: openssh: Add PAM support in sshd....* gnu/packages/ssh.scm (openssh)[inputs]: Add LINUX-PAM. [arguments]: Add "--with-pam" to #:configure-flags. Ludovic Courtès 2016-08-19gnu: openssh: Use /etc as the sysconfdir....* gnu/packages/ssh.scm (openssh)[arguments]: Add --sysconfdir. Ludovic Courtès 2016-08-14gnu: dropbear: Update to 2016.74 [security fixes]....* gnu/packages/ssh.scm (dropbear): Update to 2016.74. Leo Famulari 2016-08-11gnu: corkscrew: Use 'modify-phases'....* gnu/packages/ssh.scm (corkscrew)[arguments]: Use 'modify-phases'. Efraim Flashner 2016-08-11gnu: mosh: Update to 1.2.6....* gnu/packages/ssh.scm (mosh): Update to 1.2.6. Efraim Flashner