aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages flex)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages man)
  #:use-module (gnu packages bison)
  #:use-module (srfi srfi-1))

(define-public flex
  (package
    (name "flex")
    (version "2.6.4")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/westes/flex"
                    "/releases/download/v" version "/"
                    "flex-" version ".tar.gz"))
              (sha256
               (base32
                "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
    (build-system gnu-build-system)
    (inputs
     (let ((bison-for-tests
            (package
              (inherit bison)
              (arguments
               ;; Disable tests, since they require flex.
               (substitute-keyword-arguments (package-arguments bison)
                 ((#:tests? _ #f) #f)))
              (inputs (alist-delete "flex" (package-inputs bison))))))
       `(("bison" ,bison-for-tests))))
    (arguments
     (if (or (target-hurd64?) (%current-target-system))
         (list #:configure-flags
               #~'(#$(string-append "CFLAGS=-Wno-int-conversion"
                                    " -Wno-implicit-function-declaration")))
         '()))
    ;; m4 is not present in PATH when cross-building
    (native-inputs
     (list help2man m4))
    (propagated-inputs (list m4))
    (home-page "https://github.com/westes/flex")
    (synopsis "Fast lexical analyser generator")
    (description
     "Flex is a tool for generating scanners.  A scanner, sometimes
called a tokenizer, is a program which recognizes lexical patterns in
text.  The flex program reads user-specified input files, or its standard
input if no file names are given, for a description of a scanner to
generate.  The description is in the form of pairs of regular expressions
and C code, called rules.  Flex generates a C source file named,
\"lex.yy.c\", which defines the function yylex().  The file \"lex.yy.c\"
can be compiled and linked to produce an executable.  When the executable
is run, it analyzes its input for occurrences of text matching the
regular expressions for each rule.  Whenever it finds a match, it
executes the corresponding C code.")
    (license (non-copyleft "file://COPYING"
                           "See COPYING in the distribution."))))
d>2024-06-29gnu: docker: Apply "-trimpath" flag....* gnu/packages/docker.scm (docker) [arguments]: <#:phases>: Remove 'remove-go-references phase. Set BUILDFLAGS=-trimpath to replace 'remove-go-references phase in 'build phase. Change-Id: Iada1a8764808d26e476ca8ca87a23061834f78be Sharlatan Hellseher 2024-04-02gnu: cqfd: Update to 5.5.0....* gnu/packages/docker.scm (cqfd): Update to 5.5.0. Change-Id: Ib8ba9ee06744869efc1489beb4e2d56fe0cc06e0 Maxim Cournoyer 2024-03-16Revert "gnu: python-docker: Update to 7.0.0."...This reverts commit d084fb4b04a1cebb59959633660013fff495cd0d. This breaks docker-compose. Until we can update to docker-compose 2.x, we continue with an older python-docker. Change-Id: I4954d1f072735b1e99de192b7df31b1be8179243 Arun Isaac 2024-03-10gnu: python-docker: Update to 7.0.0....* gnu/packages/docker.scm (python-docker): Update to 7.0.0. [native-inputs]: Add python-setuptools-scm. [propagated-inputs]: Add python-packaging. Change-Id: I1c23575836689e9bcdbcea22ea9d84520b0353a0 Arun Isaac 2024-02-13gnu: go-golang-org-x-sys: Move to golang-build....* gnu/packages/golang.scm (go-golang-org-x-sys): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/curl.scm: Add (gnu packages golang-build) module. * gnu/packages/databases.scm: As above. * gnu/packages/docker.scm: As above. * gnu/packages/golang-build.scm: As above. * gnu/packages/golang.scm: As above. * gnu/packages/irc.scm: As above. * gnu/packages/linux.scm: As above. * gnu/packages/password-utils.scm: As above. * gnu/packages/syncthing.scm: As above. * gnu/packages/textutils.scm: As above. * gnu/packages/vpn.scm: As above. * gnu/packages/weather.scm: As above. * gnu/packages/web.scm: As above. Change-Id: I161e89cacb9aa87b4fbb643ecd9ad32cfe49c9d7 Sharlatan Hellseher 2024-01-13gnu: docker: Update to 20.10.27....Fixes <https://issues.guix.gnu.org/68053>. * gnu/packages/docker.scm (%docker-version): Update to 20.10.27. (docker-libnetwork): Update to 20.10-3.3797618. (docker)[native-inputs]: Replace go-1.19 with go-1.20. Change-Id: Ie4cc54f62c89f3a6c83969d1e7e425189c370482 Signed-off-by: Hilton Chain <hako@ultrarare.space> Christian Miller 2023-11-29gnu: docker-libnetwork-cmd-proxy: Skip tests on most architectures....* gnu/packages/docker.scm (docker-libnetwork-cmd-proxy)[arguments]: Skip the tests unless building on x86_64-linux and not cross-building. Change-Id: I35028bd728920840370fe641240053baa3a4585f Efraim Flashner 2023-08-29gnu: docker: Update to 20.10.25....* gnu/packages/docker.scm (%docker-version): Update to 20.10.25. (docker-libnetwork): Update to 20.10-2.3f00484. (docker)[native-inputs]: Replace go with go-1.19. Hilton Chain 2023-08-29gnu: containerd: Update to 1.6.22....* gnu/packages/docker.scm (containerd): Update to 1.6.22. [#:phases]<patch-paths>: Patch Runtime name. Hilton Chain 2023-06-10gnu: cqfd: Update to 5.4.0....* gnu/packages/docker.scm (cqfd): Update to 5.4.0. [arguments]: Use gexps. Add #:make-flags. Remove install phase override. Maxim Cournoyer 2023-04-24gnu: docker-compose: Use python-jsonschema-3 to fix build....* gnu/packages/docker.scm (docker-compose) [inputs]: Replace python-jsonschema with python-jsonschema-3. Maxim Cournoyer 2023-02-17gnu: Add docker-registry....* gnu/packages/docker.scm (docker-registry): New variable. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> Signed-off-by: Christopher Baines <mail@cbaines.net> Denis 'GNUtoo' Carikli 2022-11-25gnu: docker: Fix tests....Fixes <https://issues.guix.gnu.org/59551>. Reported by Edison Ibáñez <arkhan@riseup.net> * gnu/packages/linux.scm (xfsprogs-5.9): New variable. * gnu/packages/docker.scm (docker)[inputs]: Replace xfsprogs by xfsprogs-5.9. Danny Milosavljevic 2022-07-13services: docker: Fix race condition....Fixes <https://issues.guix.gnu.org/38432>. * gnu/packages/patches/containerd-create-pid-file.patch: New file. * gnu/local.mk (dist_patch_DATA): Add this. * gnu/packages/docker.scm (containerd)[source]: Add this patch. * gnu/services/docker.scm (containerd-shepherd-service): Add #:pid-file and #:pid-file-timeout. * gnu/services/docker.scm (docker-shepherd-service): Add --containerd flag. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Oleg Pykhalov 2022-06-23gnu: docker: Honor TESTS? and please guix lint....* gnu/packages/docker.scm (docker)[phases]{patch-paths}: Split long lines. {check}: Honor TESTS?. [synopsis]: Do not start synopsis with package name. Maxim Cournoyer 2022-06-23gnu: docker: Switch to gexp and new input style....* gnu/packages/docker.scm (docker)[arguments]: Rewrite as gexps. Switch to using search-input-file. [inputs]: Use new style inputs. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Pierre Langlois 2022-06-23gnu: docker: Update to 20.10.17....* gnu/packages/docker.scm (%docker-version): Update to 20.10.17. (docker-libnetwork)[source]: Update commit according to vendor.conf. Reset revision to 1. Simplify snippet. (docker)[origin]: Remove docker-fix-tests.patch. [arguments]: Adapt 'patch-paths phase, substitute "ip6tables" and buildkit-qemu. Remove trailing #t. [native-inputs]: Replace go-1.14 by go. (docker-cli)[source]: Update hash. [arguments]: Set GO_LINKMODE to "dynamic". Remove trailing #t. [phases]{check}: Replace 'if' with 'when'. * gnu/packages/networking.scm (go-sctp): Update commit according to docker-libnetwork's vendor.conf. * gnu/packages/patches/docker-fix-tests.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove patch. Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Pierre Langlois 2022-06-23gnu: docker: Fix mkfs.xfs reference....* gnu/packages/docker.scm (docker)[arguments]: Refer to sbin/mkfs.xfs instead of bin/mkfs.xfs. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Pierre Langlois 2022-06-23gnu: containerd: Switch to gexp arguments....* gnu/packages/docker.scm (containerd)[arguments]: Rewrite as gexps. Pass all flags via make-flags variable. Switch to using search-input-file. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Pierre Langlois 2022-06-23gnu: containerd: Update to 1.6.6....* gnu/packages/docker.scm (containerd): Update to 1.6.6. [arguments]: Substitute runc binary for "pkg/cri/config/config_unix.go". Set PREFIX to empty string, as the install directory is $DESTDIR/$PREFIX. Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Pierre Langlois 2022-06-23gnu: containerd: Fix patch-paths build phase....* gnu/packages/docker.scm (containerd)[arguments]: Add 'patch-paths phases after 'unpack because 'chdir doesn't exist. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Pierre Langlois