aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages flex)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages man)
  #:use-module (gnu packages bison)
  #:use-module (srfi srfi-1))

(define-public flex
  (package
    (name "flex")
    (version "2.6.4")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/westes/flex"
                    "/releases/download/v" version "/"
                    "flex-" version ".tar.gz"))
              (sha256
               (base32
                "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
    (build-system gnu-build-system)
    (inputs
     (let ((bison-for-tests
            (package
              (inherit bison)
              (arguments
               ;; Disable tests, since they require flex.
               (substitute-keyword-arguments (package-arguments bison)
                 ((#:tests? _ #f) #f)))
              (inputs (alist-delete "flex" (package-inputs bison))))))
       `(("bison" ,bison-for-tests))))
    (arguments
     (if (or (target-hurd64?) (%current-target-system))
         (list #:configure-flags
               #~'(#$(string-append "CFLAGS=-Wno-int-conversion"
                                    " -Wno-implicit-function-declaration")))
         '()))
    ;; m4 is not present in PATH when cross-building
    (native-inputs
     (list help2man m4))
    (propagated-inputs (list m4))
    (home-page "https://github.com/westes/flex")
    (synopsis "Fast lexical analyser generator")
    (description
     "Flex is a tool for generating scanners.  A scanner, sometimes
called a tokenizer, is a program which recognizes lexical patterns in
text.  The flex program reads user-specified input files, or its standard
input if no file names are given, for a description of a scanner to
generate.  The description is in the form of pairs of regular expressions
and C code, called rules.  Flex generates a C source file named,
\"lex.yy.c\", which defines the function yylex().  The file \"lex.yy.c\"
can be compiled and linked to produce an executable.  When the executable
is run, it analyzes its input for occurrences of text matching the
regular expressions for each rule.  Whenever it finds a match, it
executes the corresponding C code.")
    (license (non-copyleft "file://COPYING"
                           "See COPYING in the distribution."))))
f14396e1b017cc939264e30ade625cb7017 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomas Volf 2023-12-06gnu: qbittorrent-enhanced: Update to 4.6.1.10.... * gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.6.1.10. Change-Id: Ic164ee27ea54018acfcba0e9db8db11f119800a4 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomas Volf 2023-12-06gnu: deluge: Update to 2.1.1....Dependency on nss-certs was added. Most torrents do require SSL in some shape or form, so it seems appropriate to add it by default. * gnu/packages/bittorrent.scm (deluge)[version]: Update to 2.1.1. [propagated-inputs]: Add nss-certs. [native-search-paths]: Set to allow locating the certificates. Change-Id: Ic6c79f24851d6917dc4e5b22b3bcb2f6b99e187a Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomas Volf 2023-12-06gnu: libtorrent-rasterbar: Update to 1.2.19....With the update, the execution of the test suite was overhauled a lot. Parallel tests were disabled, since the do not work well. Since faketime does cause some tests to hang, test_ssl was moved into a separate run. * gnu/packages/bittorrent.scm (libtorrent-rasterbar)[version]: Update to 1.2.19. [arguments]<#:parallel-tests?>: Disable. [arguments]<#:phases>: Move test_ssl into separate run under faketime. Do not run under tests under faketime. Anchor the regex for test exclusion. Set timeout of 600 seconds for each test. Change-Id: I7392cb3ce1a8815b26b3257498082761255535ee Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tomas Volf 2023-11-22gnu: aria2: Unbundle wslay....* gnu/packages/bittorrent.scm (aria2)[source]: Add snippet to delete configure script and remove bundled dependency. Add a patch. [native-inputs]: Add autoconf, automake, gettext-minimal, libtool. [inputs]: Add wslay. * gnu/packages/patches/aria2-unbundle-wslay.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I92390a872454726ff9587518bb535d2105c44ef3 Efraim Flashner 2023-11-22gnu: aria2: Update to 1.37.0....* gnu/packages/bittorrent.scm (aria2): Update to 1.37.0. Change-Id: Iddaeabb59b774b61610722f485c8c773aaf60434 Efraim Flashner 2023-10-30gnu: transmission: Update to 4.0.4....* gnu/packages/bittorrent.scm (transmission): Update to 4.0.4. [synopsis]: Remove "marketing phrases". Change-Id: Ibecdf14198ba926eea66ff5ba29ec05fbd27fde2 Signed-off-by: Christopher Baines <mail@cbaines.net> Leo Famulari 2023-09-24gnu: qbittorrent-enhanced: Update to 4.5.5.10....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.5.5.10. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Hilton Chain via Guix-patches via 2023-09-24gnu: qbittorrent-nox: Rename to qbittorrent-no-x....* gnu/packages/bittorrent.scm (qbittorrent-no-x): New variable, renamed from… (qbittorrent-nox): …this package, now redefined as a DEPRECATED-PACKAGE. Tobias Geerinckx-Rice 2023-09-24gnu: qbittorrent: Update to 4.5.5....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.5.5. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Hilton Chain 2023-09-27gnu: transmission: Fix loading icons in pure environments....* gnu/packages/bittorrent.scm (transmission)[arguments]: Add a 'wrap-program' phase that sets GDK_PIXBUF_MODULE_FILE. Clément Lassieur 2023-09-26gnu: transmission: Restore HTML files in the default output....This fixes transmission-daemon. * gnu/packages/bittorrent.scm (transmission)[arguments]: remove "transmission" directory from the 'move-gui' procedure. Clément Lassieur 2023-07-18gnu: qbittorrent-enhanced: Update to 4.5.4.10....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): Update to 4.5.4.10. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Hilton Chain 2023-07-11gnu: qbittorrent{,-nox}: Use qt-build-system....CMake is now upstream’s preferred build system. * gnu/packages/bittorrent.scm (qbittorrent)[build-system]: Use qt-build-system. [arguments]: Drop custom wrap phase. (Re-)enable tests. [inputs]: Remove input labels. Drop qtbase-5. [native-inputs]: Drop pkg-config. (qbittorrent-nox)[arguments]: Adjust configure-flags. Keep the wrap-qt phase since the non-GUI version is also a QT program. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-07-11gnu: qbittorrent: Update to 4.5.4....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.5.4. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Timotej Lazar 2023-07-01gnu: Add qbittorrent-enhanced-nox....* gnu/packages/bittorrent.scm (qbittorrent-enhanced-nox): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Hilton Chain 2023-07-01gnu: Add qbittorrent-enhanced....* gnu/packages/bittorrent.scm (qbittorrent-enhanced): New variable. Hilton Chain via Guix-patches via 2023-05-22gnu: tremc: Fix compatibility with Transmission 4.0....This version is not released upstream, but it does fix compatibility with Transmission 4.0 and works for me. * gnu/packages/bittorrent.scm: Update to 0.9.3-0.6c15e3f. Leo Famulari 2023-05-17gnu: Add qbittorrent-nox....* gnu/packages/bittorrent.scm (qbittorrent-nox): New variable. Signed-off-by: Josselin Poiret <dev@jpoiret.xyz> Hilton Chain 2023-05-01gnu: Transmission: Update to 4.0.3....* gnu/packages/bittorrent.scm: Update to 4.0.3. [build-system]: Use cmake-build-system. [source]: Remove obsolete patch. [inputs]: Add gtkmm, glib:bin, and python. [arguments]: Run the test suite. Import the glib-or-gtk-build-system and wrap the 'gui' build output. Remove #:configure-flags. Adjust the 'move-gui' phase to upstream changes. * gnu/packages/patches/transmission-honor-localedir.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Leo Famulari 2023-04-30gnu: deluge: Use librsvg-for-system....* gnu/packages/bittorent.scm (deluge)[native-inputs]: Replace librsvg input logic with librsvg-for-system. Efraim Flashner 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-05gnu: qbittorrent: Update to 4.5.2....* gnu/packages/bittorrent.scm (qbittorrent): Update to 4.5.2. Signed-off-by: Leo Famulari <leo@famulari.name> Hilton Chain 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-11gnu: libtorrent-rasterbar: Update to 1.2.18....* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.2.18. Signed-off-by: Christopher Baines <mail@cbaines.net> Hilton Chain