aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages flex)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages man)
  #:use-module (gnu packages bison)
  #:use-module (srfi srfi-1))

(define-public flex
  (package
    (name "flex")
    (version "2.6.4")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/westes/flex"
                    "/releases/download/v" version "/"
                    "flex-" version ".tar.gz"))
              (sha256
               (base32
                "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
    (build-system gnu-build-system)
    (inputs
     (let ((bison-for-tests
            (package
              (inherit bison)
              (arguments
               ;; Disable tests, since they require flex.
               (substitute-keyword-arguments (package-arguments bison)
                 ((#:tests? _ #f) #f)))
              (inputs (alist-delete "flex" (package-inputs bison))))))
       `(("bison" ,bison-for-tests))))
    (arguments
     (if (or (target-hurd64?) (%current-target-system))
         (list #:configure-flags
               #~'(#$(string-append "CFLAGS=-Wno-int-conversion"
                                    " -Wno-implicit-function-declaration")))
         '()))
    ;; m4 is not present in PATH when cross-building
    (native-inputs
     (list help2man m4))
    (propagated-inputs (list m4))
    (home-page "https://github.com/westes/flex")
    (synopsis "Fast lexical analyser generator")
    (description
     "Flex is a tool for generating scanners.  A scanner, sometimes
called a tokenizer, is a program which recognizes lexical patterns in
text.  The flex program reads user-specified input files, or its standard
input if no file names are given, for a description of a scanner to
generate.  The description is in the form of pairs of regular expressions
and C code, called rules.  Flex generates a C source file named,
\"lex.yy.c\", which defines the function yylex().  The file \"lex.yy.c\"
can be compiled and linked to produce an executable.  When the executable
is run, it analyzes its input for occurrences of text matching the
regular expressions for each rule.  Whenever it finds a match, it
executes the corresponding C code.")
    (license (non-copyleft "file://COPYING"
                           "See COPYING in the distribution."))))
an class='msg-tooltip'>* gnu/packages/lisp.scm (sbcl): Update to 2.1.2. Pierre Neidhardt 2021-03-12gnu: lisp-repl-core-dumper: Update to 0.7.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.7.0. Pierre Neidhardt 2021-03-08gnu: lisp-repl-core-dumper: Update to 0.6.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.6.0. Pierre Neidhardt 2021-02-03gnu: ecl: Update to 21.2.1....* gnu/packages/lisp.scm (ecl): Update to 21.2.1. Pierre Neidhardt 2021-02-02gnu: ecl: Propagate some dependencies used in header files....* gnu/packages/lisp.scm(ecl)[inputs]: Move gmp, libatomic-ops, libgc and libffi to... [propagated-inputs]: ... here. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Zhu Zihao 2021-01-20gnu: lisp-repl-core-dumper: Patch path to `cat'....* gnu/packages/lisp.scm (lisp-repl-core-dumper)[arguments]: Substitute calls to `cat' with full store path. Pierre Neidhardt 2021-01-20gnu: lisp-repl-core-dumper: Update to 0.5.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.5.0. Pierre Neidhardt 2021-01-17gnu: Add buildapp....* gnu/packages/lisp.scm (buildapp): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-01-12gnu: lisp-repl-core-dumper: Update to 0.4.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.4.0. Pierre Neidhardt 2021-01-02gnu: txr: Update to 246....* gnu/packages/lisp.scm (txr): Update to 246. Guillaume Le Vaillant 2020-12-30gnu: sbcl: Update to 2.1.0....* gnu/packages/lisp.scm (sbcl): Update to 2.1.0. Pierre Neidhardt 2020-12-28gnu: txr: Update to 245....* gnu/packages/lisp.scm (txr): Update to 245. Guillaume Le Vaillant 2020-12-14gnu: ecl: Remove build-stamp to improve reproducibility....* gnu/packages/lisp.scm (ecl)[arguments]<phases>: Add "remove-build-stamp" phase. Move "wrap" phase after "remove-build-stamp" phase. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Zhu Zihao 2020-12-14gnu: ecl: Return #t in wrap phase....* gnu/packages/lisp.scm (ecl)[arguments]<phases>: In phase "wrap", return #t. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Zhu Zihao 2020-12-05gnu: sbcl: Simplify 'replace-asdf' phase....* gnu/packages/lisp.scm (sbcl)[arguments]: Remove unused 'out' variable in 'replace-asdf' phase. Guillaume Le Vaillant 2020-12-05gnu: ecl: Simplify 'replace-asdf' phase....* gnu/packages/lisp.scm (ecl)[arguments]: Remove unused 'out' variable in 'replace-asdf' phase. Guillaume Le Vaillant 2020-12-05gnu: clisp: Use system ASDF instead of bundled one....* gnu/packages/lisp.scm (clisp)[native-inputs]: Add cl-asdf. [arguments]: Add 'replace-asdf' phase. [native-search-paths]: Add XDG_CONFIG_DIRS and XDG_DATA_DIRS. Guillaume Le Vaillant 2020-12-05gnu: ccl: Use system ASDF instead of bundled one....* gnu/packages/lisp.scm (ccl)[native-inputs]: Add cl-asdf. [arguments]: Add 'replace-asdf' phase. [native-search-paths]: Add XDG_CONFIG_DIRS and XDG_DATA_DIRS. Guillaume Le Vaillant 2020-12-05gnu: cl-asdf: Improve priorities of configuration file search....* gnu/packages/patches/cl-asdf-config-directories.patch: New file. * gnu/local.mk (dist_PATCH_DATA): Add it. * gnu/packages/lisp.scm (cl-asdf)[native-inputs]: Add it. [arguments]: Apply the new patch. Co-authored-by: Pierre Neidhardt <mail@ambrevar.xyz> Guillaume Le Vaillant 2020-12-03gnu: lisp-repl-core-dumper: Update to 0.3.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.3.0. Pierre Neidhardt 2020-12-02gnu: lisp-repl-core-dumper: Update to 0.2.0....* gnu/packages/lisp.scm (lisp-repl-core-dumper): Update to 0.2.0. Pierre Neidhardt 2020-12-01gnu: Add lisp-repl-core-dumper....* gnu/packages/lisp.scm (lisp-repl-core-dumper): New variable. Pierre Neidhardt 2020-12-01gnu: sbcl: Increase default maximum heap size....* gnu/packages/lisp.scm (sbcl)[arguments]: Build with a max heap size of 3 GiB. Guillaume Le Vaillant 2020-11-30gnu: sbcl: Update to 2.0.11....* gnu/packages/lisp.scm (sbcl): Update to 2.0.11. Pierre Neidhardt 2020-11-30gnu: clisp: Enable ASDF module and parallel build, remove old patch....* gnu/packages/lisp.scm (clisp)[source]: Remove patch that does not seem to be needed anymore. [arguments]: Remove (obsolete?) #:build keyword. Enable ASDF and explicitly enable ffcall, readline, sigsegv. Enable parallel-build since they seem to work now. Pierre Neidhardt 2020-11-22Merge branch 'master' into stagingMarius Bakke 2020-11-20gnu: Add janet....* gnu/packages/lisp.scm (janet): New variable. Pierre Neidhardt 2020-11-07Merge branch 'master' into staging... Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm Marius Bakke 2020-11-02gnu: sbcl: Update to 2.0.10....* gnu/packages/lisp.scm (sbcl): Update to 2.0.10. Pierre Neidhardt 2020-10-20gnu: sbcl: Update to 2.0.9....* gnu/packages/lisp.scm (sbcl): Update to 2.0.9. Pierre Neidhardt 2020-10-13Merge branch 'master' into stagingMarius Bakke 2020-10-13gnu: txr: Update to 244....* gnu/packages/lisp.scm (txr): Update to 244. [native-inputs]: Remove bison and flex. Guillaume Le Vaillant