aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages flex)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages man)
  #:use-module (gnu packages bison)
  #:use-module (srfi srfi-1))

(define-public flex
  (package
    (name "flex")
    (version "2.6.4")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/westes/flex"
                    "/releases/download/v" version "/"
                    "flex-" version ".tar.gz"))
              (sha256
               (base32
                "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
    (build-system gnu-build-system)
    (inputs
     (let ((bison-for-tests
            (package
              (inherit bison)
              (arguments
               ;; Disable tests, since they require flex.
               (substitute-keyword-arguments (package-arguments bison)
                 ((#:tests? _ #f) #f)))
              (inputs (alist-delete "flex" (package-inputs bison))))))
       `(("bison" ,bison-for-tests))))
    (arguments
     (if (or (target-hurd64?) (%current-target-system))
         (list #:configure-flags
               #~'(#$(string-append "CFLAGS=-Wno-int-conversion"
                                    " -Wno-implicit-function-declaration")))
         '()))
    ;; m4 is not present in PATH when cross-building
    (native-inputs
     (list help2man m4))
    (propagated-inputs (list m4))
    (home-page "https://github.com/westes/flex")
    (synopsis "Fast lexical analyser generator")
    (description
     "Flex is a tool for generating scanners.  A scanner, sometimes
called a tokenizer, is a program which recognizes lexical patterns in
text.  The flex program reads user-specified input files, or its standard
input if no file names are given, for a description of a scanner to
generate.  The description is in the form of pairs of regular expressions
and C code, called rules.  Flex generates a C source file named,
\"lex.yy.c\", which defines the function yylex().  The file \"lex.yy.c\"
can be compiled and linked to produce an executable.  When the executable
is run, it analyzes its input for occurrences of text matching the
regular expressions for each rule.  Whenever it finds a match, it
executes the corresponding C code.")
    (license (non-copyleft "file://COPYING"
                           "See COPYING in the distribution."))))
sg-tooltip'>* gnu/packages/wm.scm (waybar): Update to 0.9.5. [inputs]: Replace fmt-6 with fmt, spdlog-1.7 with spdlog. * gnu/packages/logging.scm (spdlog-1.7): Remove variable. * gnu/packages/pretty-print.scm (fmt-6): Same. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> pricly_yellow 2021-03-30gnu: hikari: Update to 2.2.3....* gnu/packages/wm.scm (hikari): Update to 2.2.3. Tobias Geerinckx-Rice 2021-03-26gnu: hikari: Improve package....* gnu/packages/wm.scm (hikari)[inputs]: Sort alphabetically. [synopsis]: Shorten a bit. [description]: Use full sentences. Nicolas Goaziou 2021-03-26gnu: Add hikari....* gnu/packages/wm.scm (hikari): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> qblade 2021-03-17gnu: Add libucl....* gnu/packages/wm.scm (libucl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> qblade 2021-03-13gnu: cagebreak: Update to 1.6.0....* gnu/packages/wm.scm (cagebreak): Update to 1.6.0. Nicolas Goaziou 2021-03-12gnu: Add sbcl-stumpwm-disk....* gnu/packages/wm.scm: (sbcl-stumpwm-disk): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-03-12gnu: stumpwm-contrib: Update to 0.0.1-3.a7dc1c....* gnu/packages/wm.scm (stumpwm-contrib): Update to 0.0.1-3.a7dc1c. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Sharlatan Hellseher 2021-03-06gnu: polybar: Update to 3.5.5....* gnu/packages/wm.scm (polybar): Update to 3.5.5. Tobias Geerinckx-Rice 2021-03-02gnu: dwl: Update to 0.2....* gnu/packages/wm.scm (dwl): Update to 0.2. [arguments]: Remove the install phase. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Z572 2021-03-01gnu: i3-wm: Use asciidoc-py3....* gnu/packages/wm.scm (i3-wm)[inputs]: Remove asciidoc. [native-inputs]: Add asciidoc-py3. Björn Höfling 2021-02-21gnu: herbstluftwm: Update to 0.9.2....* gnu/packages/wm.scm (herbstluftwm): Update to 0.9.2. [inputs]: Add libxft. [native-inputs]: Add python. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Boris A. Dekshteyn 2021-02-12gnu: dwl: Fix command name in description....* gnu/packages/wm.scm (dwl)[description]: Fix typo. 宋文武 2021-02-12gnu: Add dwl....* gnu/packages/wm.scm (dwl): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Zheng Junjie 2021-01-10gnu: polybar: Update to 3.5.4....* gnu/packages/wm.scm (polybar): Update to 3.5.4. Tobias Geerinckx-Rice 2021-01-07gnu: Add cagebreak....* gnu/packages/wm.scm (cagebreak): New variable. 宋文武 2021-01-07gnu: wlroots: Propagate wayland-protocols....It's listed in the 'Requires.private' field of wlroots.pc. * gnu/packages/wm.scm (wlroots) [native-inputs]: Move wayland-protocols ... [propagated-inputs]: ... to here. 宋文武 2021-01-01gnu: polybar: Update to 3.5.3....* gnu/packages/wm.scm (polybar): Update to 3.5.3. [source]: Update URI. Signed-off-by: Leo Famulari <leo@famulari.name> Tanguy Le Carrour 2020-12-22gnu: waybar: Fix build....* gnu/packages/wm.scm (waybar)[inputs]: Replace spdlog with spdlog-1.7. Jonathan Brielmaier 2020-12-15gnu: Add kanshi....* gnu/packages/wm.scm (kanshi): New variable. Signed-off-by: Leo Famulari <leo@famulari.name> Robert Smith 2020-12-12gnu: Add wlr-randr...* gnu/packages/wm.scm (wlr-randr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Robert Smith 2020-12-10gnu: stumpwm-with-slynk: Fix build error....* gnu/packages/wm.scm (stumpwm-with-slynk)[arguments]: Provide a writable directory to use as $HOME during building. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Niklas Eklund 2020-12-09gnu: Add lemonbar-xft....* gnu/packages/wm.scm (lemonbar-xft): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> elaexuotee@wilsonb.com