aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016-2018, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages file)
  #:use-module (gnu packages)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public file
  (package
    (name "file")
    (version "5.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://ftp.astron.com/pub/file/file-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "10jdg2fd19h2q3jrsaw7xqwy1w3qyvdfzzrv9sgjq3mv548gb5zw"))
              (patches (search-patches "file-32bit-time.patch"))))
   (build-system gnu-build-system)

   ;; When cross-compiling, this package depends upon a native install of
   ;; itself.
   (native-inputs (if (%current-target-system)
                      `(("self" ,this-package))
                      '()))
   (synopsis "File type guesser")
   (description
    "The file command is a file type guesser, a command-line tool that tells
you in words what kind of data a file contains.  It does not rely on filename
extensions to tell you the type of a file, but looks at the actual contents
of the file.  This package provides the libmagic library.")
   (license bsd-2)
   (home-page "https://www.darwinsys.com/file/")))
08 +0800'>2024-06-27gnu: mold: Update to 2.32.1....* gnu/packages/mold.scm (mold): Update to 2.32.1. Change-Id: Iaf5b3b4ba09e19a35f471c08b7b130a4fee4d4fb Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Ashish SHUKLA 2024-06-24gnu: mold: Update to 2.32.0...* gnu/packages/mold.scm (mold): Update to 2.32.0. Change-Id: Ia99d57c92e9e9d75d80880376687b8a0b5fde184 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Ashish SHUKLA 2024-02-21gnu: mold: Update to 2.4.0....* gnu/packages/mold.scm (mold): Update to 2.4.0. [source]: Streamline snippet. [inputs]: Remove unused openssl input. Change-Id: Iba4e7c1053459c5e765eb7089428149b49151e29 Maxim Cournoyer 2023-11-15gnu: mold: Update to 2.3.2....* gnu/packages/mold.scm (mold): Update to 2.3.2. [source]: Add snippet to fix i686-linux detection. [arguments]: Add a phase to skip a test requiring a newer version of tbb. Add a configure-flag to enable tests. Change-Id: I9bc06b13c41b236844df3074206bb035ecd2bd06 Efraim Flashner