aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016-2018, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages file)
  #:use-module (gnu packages)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public file
  (package
    (name "file")
    (version "5.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://ftp.astron.com/pub/file/file-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "10jdg2fd19h2q3jrsaw7xqwy1w3qyvdfzzrv9sgjq3mv548gb5zw"))
              (patches (search-patches "file-32bit-time.patch"))))
   (build-system gnu-build-system)

   ;; When cross-compiling, this package depends upon a native install of
   ;; itself.
   (native-inputs (if (%current-target-system)
                      `(("self" ,this-package))
                      '()))
   (synopsis "File type guesser")
   (description
    "The file command is a file type guesser, a command-line tool that tells
you in words what kind of data a file contains.  It does not rely on filename
extensions to tell you the type of a file, but looks at the actual contents
of the file.  This package provides the libmagic library.")
   (license bsd-2)
   (home-page "https://www.darwinsys.com/file/")))
/packages/python-science.scm (python-msgpack-numpy): New variable. Ricardo Wurmus 2020-06-23gnu: python-scikit-image: Update to 0.17.2....* gnu/packages/python-science.scm (python-scikit-image): Update to 0.17.2. Ricardo Wurmus 2020-06-22gnu: Add python-xarray....From 27ec21904f769c1e8114f767972d9037e1e9f68a Mon Sep 17 00:00:00 2001 From: Pierre Langlois <pierre.langlois@gmx.com> Date: Thu, 18 Jun 2020 00:58:02 +0200 Subject: [PATCH 4/5] gnu: Add python-xarray. * gnu/package/python-science.scm (python-xarray): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2020-06-22gnu: python-pandas: Update to 1.0.5....But also keep version 0.25.3 around for packages requiring an earlier versions, as well as version 0.24.2 for a version with python2. * gnu/packages/python-science.scm (python-pandas): Update to 1.0.5. [arguments]: Adapt 'patch-which phase. Add new 'prepare-x phase. Do not delete tests that depend on "moto", they are skipped automatically. [propagated-inputs]: Add python-jinja2. [inputs]: Add xsel and xclip. [native-inputs]: Add xorg-server-for-tests so we can test clipboard support. (python-pandas-0.24): New variable. (python2-pandas): Inherit from python-pandas-0.25. * gnu/packages/bioinformatics.scm (python-biom-format)[propagated-inputs]: Switch to python-pandas-0.25. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre Langlois 2020-04-30gnu: Add python2-weave....* gnu/packages/python-science.scm (python2-weave): New variable. Ricardo Wurmus 2020-04-09gnu: Remove python2-scikit-image....Some of the packages that this depends upon no longer supports Python 2. * gnu/packages/python-science.scm (python2-scikit-image): Remove variable. Marius Bakke 2020-03-15gnu: python2-pandas: Fix build with Python 2.7.17....While at it, fix the inheritance. * gnu/packages/python-science.scm (python2-pandas): Use INHERIT instead of PACKAGE/INHERIT. [source](modules, snippet): New fields. Marius Bakke 2020-02-19gnu: python-scikit-image: Use HTTPS home page....* gnu/packages/python-science.scm (python-scikit-image)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-01-15gnu: python-lxml: Move to (gnu packages xml)....* gnu/packages/python-xyz.scm (python-lxml): Move from here ... * gnu/packages/xml.scm (python-lxml): ... to here. * gnu/packages/django.scm, gnu/packages/drones.scm, gnu/packages/libreoffice.scm, gnu/packages/nutrition.scm, gnu/packages/openstack.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-science.scm, gnu/packages/tryton.scm, gnu/packages/wireservice.scm: Adjust module imports. Marius Bakke