aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016-2018, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages file)
  #:use-module (gnu packages)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public file
  (package
    (name "file")
    (version "5.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://ftp.astron.com/pub/file/file-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "10jdg2fd19h2q3jrsaw7xqwy1w3qyvdfzzrv9sgjq3mv548gb5zw"))
              (patches (search-patches "file-32bit-time.patch"))))
   (build-system gnu-build-system)

   ;; When cross-compiling, this package depends upon a native install of
   ;; itself.
   (native-inputs (if (%current-target-system)
                      `(("self" ,this-package))
                      '()))
   (synopsis "File type guesser")
   (description
    "The file command is a file type guesser, a command-line tool that tells
you in words what kind of data a file contains.  It does not rely on filename
extensions to tell you the type of a file, but looks at the actual contents
of the file.  This package provides the libmagic library.")
   (license bsd-2)
   (home-page "https://www.darwinsys.com/file/")))
le ignores GUILE_LOAD_PATH during startup....Ludovic Courtès 2020-10-31pack: Relocatable wrapper leaves root available to child processes....Ludovic Courtès 2020-10-30gnu: linux-libre: Update to 5.9.2....Leo Famulari 2020-10-30guix: pack: Fix offset calculation for store directory mount point....Eric Bavier 2020-10-24gnu: linux-libre: Update to 5.9.1....Leo Famulari 2020-10-15gnu: linux-libre: Enable XDP sockets and their monitoring....Tobias Geerinckx-Rice via Guix-patches via 2020-10-05self: Use a 'guile' that doesn't complain about locales....Ludovic Courtès 2020-08-30gnu: Remove linux-libre 5.7....Leo Famulari 2020-08-27pack: fakechroot: Honor $LD_LIBRARY_PATH....Ludovic Courtès 2020-08-27linux-libre: Enable module compression for all versions....Mathieu Othacehe 2020-08-25linux-libre: Enable module compression....Mathieu Othacehe 2020-08-21gnu: linux-libre: Update to 5.8.2....Leo Famulari 2020-08-10gnu: linux-libre: Fix typo in the configuration for 5.7 on x86_64....Leo Famulari 2020-08-05gnu: linux-libre: Update to 5.7.12....Leo Famulari 2020-07-28pack: "fakechroot" engine always creates its store....Ludovic Courtès 2020-07-28pack: "fakechroot" execution engine can load its audit module....Ludovic Courtès 2020-05-14pack: Add relocation via ld.so and fakechroot....Ludovic Courtès 2020-05-14pack: Factorize store references in wrapper....Ludovic Courtès 2020-05-14pack: Wrapper honors 'GUIX_EXECUTION_ENGINE' environment variable....Ludovic Courtès 2020-05-07pack: Factorize 'exec_in_user_namespace' wrapper....Ludovic Courtès 2020-05-07pack: Add 'xmalloc' in wrapper....Ludovic Courtès 2020-05-07pack: Fix off-by-one in PRoot handling in the wrapper....Ludovic Courtès