aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016-2018, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages file)
  #:use-module (gnu packages)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public file
  (package
    (name "file")
    (version "5.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://ftp.astron.com/pub/file/file-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "10jdg2fd19h2q3jrsaw7xqwy1w3qyvdfzzrv9sgjq3mv548gb5zw"))
              (patches (search-patches "file-32bit-time.patch"))))
   (build-system gnu-build-system)

   ;; When cross-compiling, this package depends upon a native install of
   ;; itself.
   (native-inputs (if (%current-target-system)
                      `(("self" ,this-package))
                      '()))
   (synopsis "File type guesser")
   (description
    "The file command is a file type guesser, a command-line tool that tells
you in words what kind of data a file contains.  It does not rely on filename
extensions to tell you the type of a file, but looks at the actual contents
of the file.  This package provides the libmagic library.")
   (license bsd-2)
   (home-page "https://www.darwinsys.com/file/")))
Update to 3.11.1....Brendan Tildesley 2017-09-06gnu: Update calibre to 3.6.0....Roel Janssen 2017-08-17gnu: Add fbreader....Danny Milosavljevic 2017-08-17gnu: Add liblinebreak....Danny Milosavljevic 2017-08-02gnu: calibre: Add python2-msgpack as an input....Manolis Ragkousis 2017-06-22gnu: Update calibre to 3.0.0....Roel Janssen 2017-05-19gnu: calibre: Don't create uninstaller....Brendan Tildesley 2017-05-19gnu: calibre: Add exhaustive license list....Brendan Tildesley 2017-05-19gnu: calibre: Add missing dependencies....Brendan Tildesley 2017-05-19gnu: calibre: Unbundle chardet....Brendan Tildesley 2017-05-19gnu: calibre: Unbundle liberation fonts....Brendan Tildesley 2017-05-19gnu: calibre: Unbundle python2-markdown....Brendan Tildesley 2017-05-19gnu: calibre: Import unbundle feedparser patch from debian....Brendan Tildesley 2017-05-19gnu: calibre: Import dont-load-icons patch from debian....Brendan Tildesley 2017-05-19gnu: calibre: Update to 2.85.1....Brendan Tildesley 2017-01-04gnu: calibre: Update to 2.76.0....Alex Griffin 2016-12-12gnu: calibre: Update to 2.74.0....Efraim Flashner 2016-12-12gnu: calibre: Update qt dependancies....Efraim Flashner 2016-12-02gnu: calibre: Do not use python setuptools for building....Hartmut Goebel