aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016-2018, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages file)
  #:use-module (gnu packages)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public file
  (package
    (name "file")
    (version "5.45")
    (source (origin
              (method url-fetch)
              (uri (string-append "http://ftp.astron.com/pub/file/file-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "10jdg2fd19h2q3jrsaw7xqwy1w3qyvdfzzrv9sgjq3mv548gb5zw"))
              (patches (search-patches "file-32bit-time.patch"))))
   (build-system gnu-build-system)

   ;; When cross-compiling, this package depends upon a native install of
   ;; itself.
   (native-inputs (if (%current-target-system)
                      `(("self" ,this-package))
                      '()))
   (synopsis "File type guesser")
   (description
    "The file command is a file type guesser, a command-line tool that tells
you in words what kind of data a file contains.  It does not rely on filename
extensions to tell you the type of a file, but looks at the actual contents
of the file.  This package provides the libmagic library.")
   (license bsd-2)
   (home-page "https://www.darwinsys.com/file/")))
href='/guix/commit/gnu/machine?id=61d8bd56a4644a72b964b680456da4332eb1ef6d'>machine: ssh: Do not import the host (guix config), really....Ludovic Courtès 2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas 2020-11-09machine: ssh: Do not import the host (guix config)....Ludovic Courtès 2020-11-01system: Add store-directory-prefix to boot-parameters....Miguel Ángel Arruga Vivas 2020-10-18system: Provide locale information to the bootloader....Miguel Ángel Arruga Vivas 2020-09-07linux-boot: Handle nfs-root device strings....Stefan 2020-08-25Remove "guile-zlib" extension when unused....Mathieu Othacehe 2020-08-25linux-libre: Support module compression....Mathieu Othacehe 2020-07-27machine: ssh: Check for potential system downgrades....Ludovic Courtès 2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès 2020-06-28Add more missing (ice-9 format) imports....Marius Bakke 2020-06-18machine: ssh: Fix guix deploy hang when using non-DCE UUIDs....Maxim Cournoyer 2020-03-23machine: ssh: Better report missing initrd modules....Ludovic Courtès 2020-03-23machine: ssh: Make sanity checks in a single round trip....Ludovic Courtès 2020-02-09Update e-mail address for Jakob L. Kreuze....Tobias Geerinckx-Rice 2019-12-08machine: Remove unnecessary record self-referencing bindings....Ludovic Courtès 2019-12-07machine: ssh: Deprecate missing 'host-key' field....Ludovic Courtès 2019-12-04machine: ssh: <machine-ssh-configuration> can include the host key....Ludovic Courtès