aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages figlet)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public figlet
  (package
    (name "figlet")
    (version "2.2.5")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "ftp://ftp.figlet.org/pub/figlet/program"
                           "/unix/figlet-" version ".tar.gz"))
       (sha256
        (base32 "0za1ax15x7myjl8jz271ybly8ln9kb9zhm1gf6rdlxzhs07w925z"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases (delete 'configure))
       #:make-flags
       (list (string-append "prefix=" %output))))
    (home-page "http://www.figlet.org/")
    (synopsis "Make large letterforms out of ordinary screen characters")
    (description "FIGlet is a program for making large ASCII art letterforms
out of ordinary screen characters.")
    (license license:bsd-3)))
AME....Tobias Geerinckx-Rice 2019-01-31gnu: i3-wm: Update to 4.16.1....Marius Bakke 2019-01-25gnu: awesome: Use INVOKE....Ricardo Wurmus 2018-12-25gnu: Add polybar....Meiyo Peng 2018-12-13gnu: Fix misplaced commas (unquotes)....Mark H Weaver 2018-11-05gnu: i3-wm: Update to 4.16....Marius Bakke 2018-10-19gnu: Add i3blocks....Meiyo Peng 2018-10-01gnu: ghc-xmonad-contrib: Fix build....宋文武 2018-10-01gnu: xmobar: Update to 0.28....Timothy Sample 2018-10-01gnu: xmonad: Update to 0.14.2....Timothy Sample 2018-10-01gnu: ghc-mtl: Remove built-in Haskell package....Timothy Sample 2018-09-10gnu: spectrwm: Update to 3.2.0....Tobias Geerinckx-Rice 2018-08-19gnu: libconfuse: Update to 3.2.2 [fixes CVE-2018-14447]....Marius Bakke 2018-08-12gnu: xmobar: Update to 0.27....Tobias Geerinckx-Rice 2018-08-11Migrate search.cpan.org home pages to metacpan.org....Tobias Geerinckx-Rice 2018-08-10gnu: xmonad: Update to 0.14....Tobias Geerinckx-Rice 2018-08-10gnu: ghc-xmonad-contrib: Update to 0.14....Tobias Geerinckx-Rice 2018-08-10gnu: Use HTTPS for xmonad.org home pages....Tobias Geerinckx-Rice 2018-06-20Fix some more lonely unquotes....Tobias Geerinckx-Rice 2018-06-20gnu: bspwm: Update to 0.9.5....Tobias Geerinckx-Rice 2018-05-21Merge branch 'master' into core-updatesMark H Weaver 2018-05-18gnu: cwm: Update to 6.3....Tobias Geerinckx-Rice 2018-05-17Merge branch 'master' into core-updatesMark H Weaver 2018-05-17gnu: i3status: Update to 2.12....Tobias Geerinckx-Rice 2018-05-06Merge branch 'master' into core-updatesMarius Bakke 2018-05-04gnu: Add nitrogen....Pierre-Antoine Rouby 2018-04-21Merge branch 'master' into core-updatesMark H Weaver 2018-04-17gnu: i3lock-color: Update to 2.11-c....Tobias Geerinckx-Rice 2018-04-17gnu: i3lock-color: Stylistic fixes....Tobias Geerinckx-Rice 2018-04-17gnu: xmobar: Update to 0.26....Tobias Geerinckx-Rice 2018-04-10Merge branch 'master' into core-updatesMark H Weaver 2018-03-29gnu: awesome: Remove obsolete snippet....Marius Bakke 2018-03-29gnu: bspwm: Update to 0.9.4....Tobias Geerinckx-Rice 2018-03-29Merge branch 'master' into core-updatesMarius Bakke 2018-03-27gnu: Remove Haskell packages provided by GHC....Timothy Sample 2018-03-20Merge branch 'master' into core-updatesMark H Weaver 2018-03-20Correct name and Email for ng0....ng0 2018-03-20Merge branch 'master' into core-updatesMark H Weaver 2018-03-17gnu: Fix common unquote typos....Tobias Geerinckx-Rice 2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver 2018-03-14Merge branch 'master' into core-updatesRicardo Wurmus 2018-03-12gnu: i3-wm: Update to 4.15....Marius Bakke 2018-03-11build-system/gnu: Add 'bootstrap' phase....Ludovic Courtès