aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 nee <nee.git@cock.li>
;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Nikita <nikita@n0.is>
;;; Copyright © 2021 Oskar Köök <oskar@maatriks.ee>
;;; Copyright © 2021 Cees de Groot <cg@evrl.com>
;;; Copyright © 2024 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2024 Ivan Sokolov <ivan-p-sokolov@ya.ru>
;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages elixir)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (guix git-download)
  #:use-module (guix packages)
  #:use-module (gnu packages)
  #:use-module (gnu packages bash)
  #:use-module (gnu packages erlang)
  #:use-module (gnu packages version-control))

(define-public elixir
  (package
    (name "elixir")
    (version "1.17.3")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/elixir-lang/elixir")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "171l6g304044yk6i0827hgl64vp122ygn1wa1xqdjhw08b5kl2pd"))
       (patches (search-patches "elixir-path-length.patch"))))
    (build-system gnu-build-system)
    (arguments
     (list
      #:test-target "test"
      #:parallel-tests? #f ;see <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32171#23>
      #:make-flags #~(list (string-append "PREFIX=" #$output))
      #:phases
      #~(let* ((compiler-path "lib/elixir/src/elixir_erl_compiler.erl")
               (compiler-path-orig (string-append compiler-path ".orig")))
          (modify-phases %standard-phases
            (add-after 'unpack 'make-git-checkout-writable
              (lambda _
                (for-each make-file-writable (find-files "."))))
            (add-after 'make-git-checkout-writable 'replace-paths
              (lambda* (#:key inputs #:allow-other-keys)
                ;; Note: references end up obfuscated in binary BEAM files
                ;; where they may be invisible to the GC and graft code:
                ;; <https://issues.guix.gnu.org/54304#11>.
                (substitute* '("lib/mix/lib/mix/release.ex"
                               "lib/mix/lib/mix/tasks/release.init.ex")
                  (("#!/bin/sh")
                   (string-append "#!" (search-input-file inputs "/bin/sh"))))
                (substitute* "bin/elixir"
                  (("ERTS_BIN=\n")
                   (string-append
                    "ERTS_BIN="
                    ;; Elixir Releases will prepend to ERTS_BIN the path of
                    ;; a copy of erl.  We detect if a release is being
                    ;; generated by checking the initial ERTS_BIN value: if
                    ;; it's empty, we are not in release mode and can point
                    ;; to the actual erl binary in Guix store.
                    "\nif [ -z \"$ERTS_BIN\" ]; then ERTS_BIN="
                    (string-drop-right
                     (search-input-file inputs "/bin/erl") 3)
                    "; fi\n")))
                (substitute* "bin/mix"
                  (("#!/usr/bin/env elixir")
                   (string-append "#!" #$output "/bin/elixir")))))
            (add-after 'replace-paths 'pre-install-source
              (lambda* (#:key outputs #:allow-other-keys)
                (copy-recursively
                 "lib"
                 (string-append (assoc-ref outputs "src") "/source/lib"))))
            ;; Temporarily patch the compiler to place correct source
            ;; locations into module info instead of build directory.
            (add-after 'pre-install-source 'patch-elixir-compiler
              (lambda* (#:key outputs #:allow-other-keys)
                (copy-recursively compiler-path compiler-path-orig)
                (let ((source (string-append "/tmp/guix-build-" #$name "-"
                                             #$version ".drv-0"))
                      (destination (assoc-ref outputs "src")))
                  (substitute* compiler-path
                    (("source, Source")
                     (string-append "source, string:replace(Source, \""
                                    source "\", \"" destination "\")"))))))
            (add-before 'build 'make-current
              ;; The Elixir compiler checks whether or not to compile files
              ;; by inspecting their timestamps.  When the timestamp is
              ;; equal to the epoch no compilation will be performed.  Some
              ;; tests fail when files are older than Jan 1, 2000.
              (lambda _
                (for-each (lambda (file)
                            (let ((recent 1400000000))
                              (utime file recent recent 0 0)))
                          (find-files "." ".*"))))
            ;; Unpatch the compiler and recompile it.
            (add-after 'build 'restore-and-recompile
              (lambda _
                (copy-recursively compiler-path-orig compiler-path)
                (delete-file compiler-path-orig)
                (invoke "make")))
            (add-before 'check 'set-home
              (lambda* (#:key inputs #:allow-other-keys)
                ;; Some tests require access to a home directory.
                (setenv "HOME" "/tmp")))
            ;; Temporarily skip several tests related to logger to pass
            ;; under Erlang 27.1. For more info see:
            ;; https://elixirforum.com/t/elixir-v1-17-3-released/66156/2
            (add-before 'check 'disable-some-logger-tests-for-erlang-27.1+
              (lambda _
                (substitute* "lib/logger/test/logger/translator_test.exs"
                  (("test \"translates Supervisor progress")
                   "@tag :skip\n  test \"translates Supervisor progress"))))
            (delete 'configure)
            (add-after 'install 'wrap-programs
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
                       (programs '("elixir" "elixirc" "iex")))
                  ;; mix can be sourced as an elixir script by other elixir
                  ;; program, for example `iex -S mix`, so we should not wrap
                  ;; mix into shell script.
                  (substitute* (string-append out "/bin/mix")
                    (("Mix.CLI.main\\(\\)")
                     (format #f "\
~~w[GUIX_ELIXIR_LIBS ERL_LIBS]
|> Enum.map(&System.get_env/1)
|> Enum.reject(&is_nil/1)
|> Enum.join(\":\")
|> case do \"\" -> :ok; erl_libs -> System.put_env(\"ERL_LIBS\", erl_libs) end
System.put_env(\"MIX_REBAR3\", System.get_env(\"MIX_REBAR3\", \"~a\"))
Mix.CLI.main()"
                             (search-input-file inputs "/bin/rebar3"))))
                  (for-each
                   (lambda (program)
                     (wrap-program (string-append out "/bin/" program)
                       '("ERL_LIBS" prefix ("${GUIX_ELIXIR_LIBS}"))))
                   programs))))))))
    (outputs '("out" "src"))
    (inputs (list bash-minimal erlang rebar3 git))
    (native-search-paths
     (list (search-path-specification
            (variable "GUIX_ELIXIR_LIBS")
            (files (list (string-append "lib/elixir/" (version-major+minor
                                                       version)))))))
    (home-page "https://elixir-lang.org/")
    (synopsis "Functional meta-programming aware language")
    (description "Elixir is a dynamic, functional language used to build
scalable and maintainable applications.  Elixir leverages the Erlang VM, known
for running low-latency, distributed and fault-tolerant systems, while also
being successfully used in web development and the embedded software domain.")
    (license license:asl2.0)))

(define-public elixir-hex
  (package
    (name "elixir-hex")
    (version "2.1.1")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/hexpm/hex")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32
         "0fmrbl7dj8ndq1z7h13qgx3cv7vw3b1zf6krdrahcmx43bcdsix4"))))
    ;; The mix-build-system assumes that Hex exists.
    ;; We build Hex using the gnu-build-system.
    ;; Other Elixir packages use the mix-build-system.
    (build-system gnu-build-system)
    (inputs (list elixir))
    (arguments
     (list
      ;; Hex is needed to build packages used to test Hex.
      ;; To avoid this circularity, we disable tests.
      #:tests? #f
      #:phases
      #~(modify-phases %standard-phases
          (delete 'bootstrap)
          (delete 'configure)
          (replace 'build
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "MIX_ENV" "prod")
              (invoke "mix" "compile")))
          (replace 'install
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (define X.Y #$(version-major+minor (package-version elixir)))
              (define out (string-append (assoc-ref outputs "out")
                                         "/lib/elixir/" X.Y "/hex"))
              (mkdir-p out)
              (let* ((prod-dir "_build/prod/lib/hex")
                     (prod-dir-mix (string-append prod-dir "/.mix")))
                (and (directory-exists? prod-dir-mix)
                     (delete-file-recursively prod-dir-mix))
              (copy-recursively "_build/prod/lib/hex" out)))))))
    (synopsis "Package manager for the Erlang VM")
    (description
     "This project provides tasks that integrate with Mix, Elixir's build
tool.")
    (home-page "https://hexdocs.pm/makeup_elixir/")
    (license license:bsd-2)))
¨s 2021-11-14gnu: waybar: Update to 0.9.8....* gnu/packages/wm.scm (waybar): Update to 0.9.8. [inputs]: Add libxml2. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-31gnu: polybar: Update to 3.5.7....* gnu/packages/wm.scm (polybar): Update to 3.5.7. Tobias Geerinckx-Rice 2021-10-24gnu: Move Common Lisp testing frameworks to lisp-check module....* gnu/packages/lisp-xyz.scm (sbcl-1am, cl-1am, ecl-1am, sbcl-check-it, cl-check-it, ecl-check-it, sbcl-checkl, cl-checkl, ecl-checkl, sbcl-cl-mock, cl-mock, ecl-cl-mock, sbcl-cl-quickcheck, cl-quickcheck, ecl-cl-quickcheck, sbcl-clunit, cl-clunit, ecl-clunit, sbcl-clunit2, cl-clunit2, ecl-clunit2, sbcl-eos, cl-eos, ecl-eos, sbcl-fiasco, cl-fiasco, ecl-fiasco, sbcl-fiveam, cl-fiveam, ecl-fiveam, sbcl-hu.dwim.stefil, cl-hu.dwim.stefil, ecl-hu.dwim.stefil, sbcl-lift, cl-lift, ecl-lift, sbcl-lisp-unit, cl-lisp-unit, ecl-lisp-unit, sbcl-lisp-unit2, cl-lisp-unit2, ecl-lisp-unit2, sbcl-parachute, cl-parachute, ecl-parachute, sbcl-prove, cl-prove, ecl-prove, sbcl-ptester, cl-ptester, ecl-ptester, sbcl-rove, cl-rove, ecl-rove, sbcl-rt, cl-rt, ecl-rt, sbcl-stefil, cl-stefil, ecl-stefil, sbcl-unit-test, cl-unit-test, ecl-unit-test, sbcl-xlunit, cl-xlunit, ecl-xlunit): Move to ... * gnu/packages/lisp-check.scm: ... here. * gnu/packages/web-browsers.scm: Import lisp-check module. * gnu/packages/wm.scm: Import lisp-check module. Guillaume Le Vaillant 2021-10-23gnu: Use 'search-input-file' some more....This patch replaces occurrences of: (string-append (assoc-ref %build-inputs "…") "/…") by: (search-input-file %build-inputs "/…") * doc/guix.texi (Miscellaneous Services): Use 'search-input-file' in R Shiny example. * gnu/packages/admin.scm (screenfetch): Use 'search-input-file'. (ufetch): Likewise. (hosts): Likewise. * gnu/packages/backup.scm (dirvish): Likewise. * gnu/packages/code.scm (colormake): Likewise. * gnu/packages/compression.scm (makeself-safeextract): Likewise. * gnu/packages/debug.scm (scanmem): Likewise. * gnu/packages/education.scm (snap): Likewise. (omnitux): Likewise. * gnu/packages/emacs-xyz.scm (epipe): Likewise. * gnu/packages/games.scm (openttd-opensfx): Likewise. (openttd-openmsx): Likewise. (openrct2-title-sequences): Likewise. (openrct2-objects): Likewise. (mrrescue): Likewise. (0ad-data): Likewise. (xonotic-data): Likewise. (drascula): Likewise. (make-lure-package): Likewise. (make-queen-package): Likewise. (sky): Likewise. * gnu/packages/gnome.scm (network-manager): Likewise. * gnu/packages/gnuzilla.scm (icedove): Likewise. * gnu/packages/guile-xyz.scm (guile-shapefile): Likewise. * gnu/packages/hurd.scm (netdde): Likewise. * gnu/packages/javascript.scm (js-context-menu): Likewise. (js-commander): Likewise. (js-xmldom-sre): Likewise. * gnu/packages/kde-frameworks.scm (krunner): Likewise. * gnu/packages/kodi.scm (kodi-cli): Likewise. * gnu/packages/libreoffice.scm (hunspell-dict-pl): Likewise. * gnu/packages/linux.scm (e2fsck/static): Likewise. * gnu/packages/markup.scm (markdown): Likewise. * gnu/packages/maths.scm (hdf-java): Likewise. * gnu/packages/multiprecision.scm (libtomcrypt): Likewise. * gnu/packages/networking.scm (batctl): Likewise. * gnu/packages/python-xyz.scm (python-pymediainfo): Likewise. * gnu/packages/shells.scm (fish-foreign-env): Likewise. * gnu/packages/tex.scm (texlive-fonts-iwona): Likewise. * gnu/packages/upnp.scm (miniupnpc): Likewise. * gnu/packages/version-control.scm (git-annex-remote-rclone): Likewise. * gnu/packages/virtualization.scm (qemu): Likewise. * gnu/packages/web.scm (icedtea-web): Likewise. * gnu/packages/wm.scm (stumpish): Likewise. Ludovic Courtès 2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-10-16gnu: fnott: Update to 1.1.2....* gnu/packages/wm.scm (fnott): Update to 1.1.2. Tobias Geerinckx-Rice 2021-10-13gnu: cagebreak: Update to 1.8.0....* gnu/packages/wm.scm (cagebreak): Update to 1.8.0. [inputs]: Add LIBEVDEV. Marius Bakke 2021-10-13gnu: dwl: Update to 0.2.1....* gnu/packages/wm.scm (dwl): Update to 0.2.1. Marius Bakke 2021-10-13gnu: hikari: Update to 2.3.2....* gnu/packages/wm.scm (hikari): Update to 2.3.2. Marius Bakke 2021-10-13gnu: sway: Update to 1.6.1....* gnu/packages/wm.scm (sway): Update to 1.6.1. Marius Bakke 2021-10-13gnu: wlroots: Update to 0.14.1....* gnu/packages/wm.scm (wlroots): Update to 0.14.1. [inputs]: Add SEATD. Marius Bakke 2021-10-12gnu: Remove references to meson-0.55....This is a follow-up to 1eca979fb8da842e73c42f4f53be29b169810f2. * gnu/packages/datastructures.scm, gnu/packages/fontutils.scm, gnu/packages/terminals.scm: Don't import (gnu packages build-tools). * gnu/packages/wm.scm: Remove comment. * gnu/packages/emulators.scm (dosbox-staging)[arguments]: Remove meson field. * gnu/packages/package-management.scm (conan)[native-inputs]: Use meson. Efraim Flashner 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-08gnu: Update Haskell ecosystem....Bump packages’ versions to the lastest Stackage or Hackage release. Since packages are interdependent, do so in a single commit. 525 packages have been updated. These packages have been removed, because they fail to build, have no newer version available and no dependencies: corrode ghc-easytest ghc-edisonapi ghc-edisoncore ghc-pandoc-types ghc-regex-tdfa-text These have been removed, because they are no longer required: ghc-happy-1.19.9 ghc-prettyprinter-1.6 ghc-protolude-0.3 ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc does not use them any more. Co-authored-by: Xinglu Chen <public@yoctocell.xyz> Lars-Dominik Braun 2021-10-05gnu: menumaker: Update to 0.99.13....* gnu/packages/wm.scm (menumaker): Update to 0.99.13. Tobias Geerinckx-Rice 2021-10-02gnu: Update gtkmm to 4.2.0, add gtkmm@3, and adjust gtkmm@2....* gnu/packages/gtk.scm (gtkmm)[version]: Update to 4.2.0. [arguments](meson): New argument. [native-inputs]: Add glib:bin. [propagated-inputs]: Replace gtk+ with gtk. (gtkmm-3): New variable. (gtkmm-2)[arguments]: Strip certain inherited arguments. * gnu/packages/animation.scm (synfigstudio)[inputs]: Switch to gtkmm-3. * gnu/packages/astronomy.scm (stackistry)[inputs]: Ditto. * gnu/packages/audio.scm (guitarix)[inputs]: Ditto. * gnu/packages/disk.scm (parted)[inputs]: Ditto. * gnu/packages/gnome.scm (gnome-system-monitor)[inputs]: Ditto. (workrave)[inputs]: Ditto. (gnote)[inputs]: Ditto. * gnu/packages/gobby.scm (gobby)[inputs]: Ditto. * gnu/packages/inkscape.scm (inkscape)[inputs]: Ditto. * gnu/packages/mail.scm (astroid)[inputs]: Ditto. * gnu/packages/mate.scm (mate-system-monitor)[inputs]: Ditto. * gnu/packages/music.scm (tascam-gtk)[inputs]: Ditto. * gnu/packages/photo.scm (rawtherapee)[inputs]: Ditto. * gnu/packages/pulseaudio.scm (pavucontrol)[inputs]: Ditto. (paprefs)[inputs]: Ditto. * gnu/packages/text-editors.scm (jucipp)[inputs]: Ditto. * gnu/packages/wm.scm (waybar)[inputs]: Ditto. Raghav Gururajan 2021-09-18gnu: Add swaylock-effects....* gnu/packages/wm.scm (swaylock-effects): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> phodina 2021-09-17Merge branch 'master' into core-updates-frozen... Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm Marius Bakke 2021-09-13gnu: Add i3lock-blur....* gnu/packages/wm.scm (i3lock-blur): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> phodina 2021-09-13gnu: i3lock-fancy: Add input....* gnu/packages/wm.scm (i3lock-fancy)[inputs]: Add i3lock. Signed-off-by: Ludovic Courtès <ludo@gnu.org> phodina 2021-09-13gnu: i3lock: Update to 2.13....* gnu/packages/wm.scm (i3lock): Update to 2.13. Signed-off-by: Ludovic Courtès <ludo@gnu.org> phodina 2021-07-24gnu: Use 'search-input-file' when looking for executables....* gnu/packages/admin.scm (isc-dhcp): Use 'search-input-file' when looking for executables. * gnu/packages/audio.scm (ableton-link): Likewise. * gnu/packages/benchmark.scm (fio): Likewise. * gnu/packages/bioinformatics.scm (roary): Likewise. (ngless): Likewise. * gnu/packages/boost.scm (boost-for-irods): Likewise. * gnu/packages/bootloaders.scm (grub): Likewise. (grub-efi): Likewise. * gnu/packages/chemistry.scm (inchi): Likewise. * gnu/packages/dictionaries.scm (ding): Likewise. * gnu/packages/dlang.scm (ldc): Likewise. * gnu/packages/education.scm (childsplay): Likewise. * gnu/packages/emacs-xyz.scm (emacs-hyperbole): Likewise. (emacs-haskell-mode): Likewise. (emacs-auctex): Likewise. (emacs-ggtags): Likewise. (emacs-graphviz-dot-mode): Likewise. (emacs-flycheck-grammalecte): Likewise. (emacs-counsel-notmuch): Likewise. (emacspeak): Likewise. (emacs-exwm): Likewise. (emacs-exwm-x): Likewise. (emacs-treemacs): Likewise. (emacs-telega): Likewise. (emacs-exiftool): Likewise. * gnu/packages/emulators.scm (higan): Likewise. * gnu/packages/engineering.scm (freehdl): Likewise. (librepcb): Likewise. * gnu/packages/entr.scm (entr): Likewise. * gnu/packages/file-systems.scm (libeatmydata): Likewise. (xfstests): Likewise. (mergerfs): Likewise. (mergerfs-tools): Likewise. * gnu/packages/finance.scm (monero-gui): Likewise. * gnu/packages/flashing-tools.scm (flashrom): Likewise. * gnu/packages/fontutils.scm (fontforge): Likewise. * gnu/packages/game-development.scm (python2-renpy): Likewise. * gnu/packages/games.scm (opensurge): Likewise. (xboard): Likewise. (hyperrogue): Likewise. (flare-game): Likewise. (chessx): Likewise. * gnu/packages/geo.scm (grass): Likewise. * gnu/packages/glib.scm (glib): Likewise. * gnu/packages/gnome.scm (mm-common): Likewise. (network-manager-openvpn): Likewise. (network-manager-vpnc): Likewise. (network-manager-openconnect): Likewise. (apostrophe): Likewise. * gnu/packages/gnupg.scm (pius): Likewise. (jetring): Likewise. * gnu/packages/gnuzilla.scm (icedove): Likewise. * gnu/packages/golang.scm (go-1.4): Likewise. * gnu/packages/graphviz.scm (xdot): Likewise. * gnu/packages/guile-xyz.scm (jupyter-guile-kernel): Likewise. * gnu/packages/haskell-xyz.scm (ghc-hindent): Likewise. * gnu/packages/ibus.scm (ibus): Likewise. * gnu/packages/image.scm (phockup): Likewise. * gnu/packages/irc.scm (quassel): Likewise. * gnu/packages/java.scm (drip): Likewise. (ant-bootstrap): Likewise. (tla2tools): Likewise. * gnu/packages/julia.scm (julia): Likewise. * gnu/packages/less.scm (lesspipe): Likewise. * gnu/packages/libreoffice.scm (libreoffice): Likewise. * gnu/packages/linux.scm (fuse): Likewise. (lm-sensors): Likewise. (bluez): Likewise. (fakeroot): Likewise. (inputattach): Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-diskspace): Likewise. * gnu/packages/lisp.scm (lisp-repl-core-dumper): Likewise. * gnu/packages/lua.scm (fennel): Likewise. * gnu/packages/lxde.scm (spacefm): Likewise. * gnu/packages/mail.scm (public-inbox): Likewise. * gnu/packages/maths.scm (hdf-java): Likewise. (maxima): Likewise. (frama-c): Likewise. * gnu/packages/messaging.scm (libgadu): Likewise. * gnu/packages/music.scm (denemo): Likewise. (curseradio): Likewise. * gnu/packages/netpbm.scm (netpbm): Likewise. * gnu/packages/networking.scm (blueman): Likewise. (squid): Likewise. (aircrack-ng): Likewise. * gnu/packages/node.scm (node): Likewise. (node-llparse-frontend-bootstrap): Likewise. (node-llparse-bootstrap): Likewise. (llhttp-bootstrap): Likewise. (node-lts): Likewise. * gnu/packages/ocaml.scm (ocaml-4.11): Likewise. (opam): Likewise. (ocaml-graph): Likewise. * gnu/packages/orpheus.scm (orpheus): Likewise. * gnu/packages/password-utils.scm (password-store): Likewise. * gnu/packages/python.scm (pypy3): Likewise. * gnu/packages/qt.scm (qt5ct): Likewise. * gnu/packages/radio.scm (libosmo-dsp): Likewise. * gnu/packages/ruby.scm (ruby-pandoc-ruby): Likewise. * gnu/packages/rust.scm (rust-1.30): Likewise. * gnu/packages/screen.scm (byobu): Likewise. * gnu/packages/statistics.scm (r-with-tests): Likewise. * gnu/packages/suckless.scm (surf): Likewise. * gnu/packages/syndication.scm (gfeeds): Likewise. * gnu/packages/telephony.scm (mumble): Likewise. * gnu/packages/terminals.scm (alacritty): Likewise. * gnu/packages/tex.scm (texlive-bin): Likewise. * gnu/packages/uml.scm (plantuml): Likewise. * gnu/packages/version-control.scm (python-git-multimail): Likewise. (gitolite): Likewise. (hg-commitsigs): Likewise. (git-when-merged): Likewise. (git-imerge): Likewise. (gita): Likewise. * gnu/packages/video.scm (you-get): Likewise. * gnu/packages/vim.scm (eovim): Likewise. * gnu/packages/virtualization.scm (qemu): Likewise. (virt-manager): Likewise. (criu): Likewise. * gnu/packages/vpn.scm (strongswan): Likewise. (xl2tpd): Likewise. * gnu/packages/wm.scm (i3lock-fancy): Likewise. * gnu/packages/wxwidgets.scm (python-wxpython): Likewise. (python2-wxpython): Likewise. * gnu/packages/xdisorg.scm (autorandr): Likewise. * gnu/packages/xorg.scm (hackneyed-x11-cursors): Likewise. (v86d): Likewise. (mkfontdir): Likewise. (xpra): Likewise. Ludovic Courtès 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-01gnu: fnott: Update to 1.1.0....* gnu/packages/wm.scm (fnott): Update to 1.1.0. Tobias Geerinckx-Rice 2021-06-23gnu: Add fnott....* gnu/packages/wm.scm (fnott): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zheng junjie