aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dvtm)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages ncurses))

(define-public dvtm
  (package
   (name "dvtm")
   (version "0.15")
   (source (origin
            (method url-fetch)
            (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-"
                                 version ".tar.gz"))
            (sha256
             (base32
              "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list "CC=gcc"
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check))))  ; no test suite
   (inputs (list ncurses))
   (synopsis "Tiling window management for the console")
   (description "dvtm brings the concept of tiling window management,
popularized by X11-window managers like dwm, to the console.  As a console
window manager it tries to make it easy to work with multiple console based
programs.")
   (home-page "https://www.brain-dump.org/projects/dvtm/")
   ;; "dvtm reuses some code of dwm and is released under the same MIT/X11
   ;; license. The terminal emulation part is licensed under the ISC license."
   ;; source: http://www.brain-dump.org/projects/dvtm/#license
   (license (list expat isc))))
id=01224157b7714ff5a7931475943f9479d09c62a3'>gnu: Add ocproxy....Pierre Langlois 2018-04-10Merge branch 'master' into core-updatesMark H Weaver 2018-04-05gnu: sshuttle: Update to 0.78.4....Tobias Geerinckx-Rice 2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver 2018-03-13gnu: vpnc-scripts: Declare a source file-name....Efraim Flashner 2018-03-05gnu: openvpn: Mark up description....Tobias Geerinckx-Rice 2018-03-05gnu: openvpn: Update to 2.4.5....Tobias Geerinckx-Rice 2018-02-26gnu: tinc: Update to 1.0.33....Tobias Geerinckx-Rice 2018-02-18gnu: gvpe: Fix compilation against glibc 2.26....Ludovic Courtès 2017-11-29gnu: openconnect: Use only vpnc-scripts....Tobias Geerinckx-Rice 2017-11-29gnu: vpnc: Use newer vpnc-scripts....Tobias Geerinckx-Rice 2017-11-29gnu: Add vpnc-scripts....Tobias Geerinckx-Rice 2017-11-17gnu: Move testing packages from python.scm to check.scm....Ricardo Wurmus 2017-09-29gnu: openvpn: Update to 2.4.4....Efraim Flashner 2017-08-04gnu: sshoot: Update to 1.2.6....Tobias Geerinckx-Rice 2017-07-10gnu: sshuttle: Move python-pytest-runner....Tobias Geerinckx-Rice 2017-07-09gnu: sshuttle: Update to 0.78.3....Tobias Geerinckx-Rice 2017-06-22gnu: openvpn: Update to 2.4.3 [fixes CVE-2017-{7508,7512,7520,7521,7522}]....Leo Famulari 2017-05-12gnu: openvpn: Update to 2.4.2 [fixes CVE-2017-7478, CVE-2017-7479]....Marius Bakke 2017-02-13Merge branch 'master' into python-testsMarius Bakke 2017-01-13gnu: openvpn: Update to 2.4.0....Julien Lepiller 2017-01-13Merge branch 'master' into python-testsLeo Famulari 2017-01-02gnu: openvpn: Update to 2.3.14....Efraim Flashner 2016-12-19gnu: sshoot: Fix tests....Marius Bakke 2016-12-15gnu: openconnect: Update to 7.08....Tobias Geerinckx-Rice 2016-12-11gnu: Add sshoot....Tobias Geerinckx-Rice 2016-12-11gnu: Add sshuttle....Tobias Geerinckx-Rice