aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dvtm)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages ncurses))

(define-public dvtm
  (package
   (name "dvtm")
   (version "0.15")
   (source (origin
            (method url-fetch)
            (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-"
                                 version ".tar.gz"))
            (sha256
             (base32
              "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list "CC=gcc"
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check))))  ; no test suite
   (inputs (list ncurses))
   (synopsis "Tiling window management for the console")
   (description "dvtm brings the concept of tiling window management,
popularized by X11-window managers like dwm, to the console.  As a console
window manager it tries to make it easy to work with multiple console based
programs.")
   (home-page "https://www.brain-dump.org/projects/dvtm/")
   ;; "dvtm reuses some code of dwm and is released under the same MIT/X11
   ;; license. The terminal emulation part is licensed under the ISC license."
   ;; source: http://www.brain-dump.org/projects/dvtm/#license
   (license (list expat isc))))
pan class='msg-avail'>...Ludovic Courtès 2018-05-23linux-initrd: Enable "virtio-rng"....Ludovic Courtès 2018-03-15linux-initrd: Move 'check-device-initrd-modules' elsewhere....Ludovic Courtès 2018-03-10linux-initrd: Autoload known-module-aliases....Danny Milosavljevic 2018-03-10linux-initrd: Skip initrd module check when 'modules.alias' can't be found....Ludovic Courtès 2018-03-07linux-initrd: Add a hint for the missing module error....Ludovic Courtès 2018-03-07linux-initrd: Factorize 'check-device-initrd-modules'....Ludovic Courtès 2018-03-03linux-initrd: Add virtio modules to '%base-initrd-modules'....Ludovic Courtès 2018-03-03linux-initrd: 'file-system-modules' returns the right module list....Ludovic Courtès 2018-03-02system: Add 'initrd-modules' field....Ludovic Courtès 2018-03-02linux-initrd: Separate file system module logic....Ludovic Courtès 2018-01-30gnu: linux-libre: NVME core support is now built-in....Mark H Weaver 2018-01-08linux-boot: Add #:on-error for initrd error handling....Ludovic Courtès 2017-11-08build: Use overlayfs instead of unionfs....Hartmut Goebel 2017-10-11file-systems: 'mount-file-system' now takes a <file-system> object....Ludovic Courtès 2017-10-08linux-initrd: Ensure that the guile used in the initrd is referenced....Christopher Baines 2017-07-04linux-initrd: Avoid monadic style a bit....Ludovic Courtès 2017-07-02linux-initrd: Add isofs if necessary....Danny Milosavljevic 2017-05-19vm: Support creating FAT partitions....Marius Bakke 2017-03-21file-systems: Do not use (gnu packages …)....Ludovic Courtès 2017-03-18file-systems: Factorize file-system-packages....Danny Milosavljevic 2017-03-11linux-initrd: Add a raw-initrd and use it to define base-initrd....Mathieu Othacehe 2017-01-10system: Add btrfs file system support....David Craven 2016-12-18linux-initrd: Support FAT filesystems....Marius Bakke