aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dvtm)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages ncurses))

(define-public dvtm
  (package
   (name "dvtm")
   (version "0.15")
   (source (origin
            (method url-fetch)
            (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-"
                                 version ".tar.gz"))
            (sha256
             (base32
              "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list "CC=gcc"
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check))))  ; no test suite
   (inputs (list ncurses))
   (synopsis "Tiling window management for the console")
   (description "dvtm brings the concept of tiling window management,
popularized by X11-window managers like dwm, to the console.  As a console
window manager it tries to make it easy to work with multiple console based
programs.")
   (home-page "https://www.brain-dump.org/projects/dvtm/")
   ;; "dvtm reuses some code of dwm and is released under the same MIT/X11
   ;; license. The terminal emulation part is licensed under the ISC license."
   ;; source: http://www.brain-dump.org/projects/dvtm/#license
   (license (list expat isc))))
r> 2021-02-23services: cuirass: Fix services requirements....Mathieu Othacehe 2021-02-23services: cuirass: Improve simple-cuirass-services....Mathieu Othacehe 2021-02-22services: cuirass: Instantiate postgresql service....Mathieu Othacehe 2021-02-22services: cuirass: Add parameters support....Mathieu Othacehe 2021-02-19services: cuirass: Add "simple-cuirass-services"....Mathieu Othacehe 2021-02-12services: cuirass: Add server argument for the remote-worker....Mathieu Othacehe 2021-02-09services: cuirass: Move zabbix argument to the web process....Mathieu Othacehe 2021-02-08services: cuirass: Add Zabbix support....Mathieu Othacehe 2021-01-28services: cuirass: Create remote-server cache directory....Mathieu Othacehe 2021-01-28services: cuirass: Fix syntax error....Mathieu Othacehe 2021-01-28services: cuirass: Add log-file support....Mathieu Othacehe 2021-01-28services: cuirass: Fix workers argument....Mathieu Othacehe 2021-01-28services: cuirass: Add systems argument....Mathieu Othacehe 2021-01-28services: cuirass: Add remote build support.Mathieu Othacehe 2021-01-28service: cuirass: Update it.Mathieu Othacehe 2020-12-08services: cuirass: Add queue-size option....Mathieu Othacehe 2020-10-02services: cuirass: Fix activation....Mathieu Othacehe 2020-09-24services: cuirass: Create queries log files at activation....Mathieu Othacehe 2020-09-24services: cuirass: Add web SQL queries logging support....Mathieu Othacehe 2020-09-24services: cuirass: Add SQL queries logging support....Mathieu Othacehe