aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dvtm)
  #:use-module (guix build-system gnu)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (gnu packages ncurses))

(define-public dvtm
  (package
   (name "dvtm")
   (version "0.15")
   (source (origin
            (method url-fetch)
            (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-"
                                 version ".tar.gz"))
            (sha256
             (base32
              "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list "CC=gcc"
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check))))  ; no test suite
   (inputs (list ncurses))
   (synopsis "Tiling window management for the console")
   (description "dvtm brings the concept of tiling window management,
popularized by X11-window managers like dwm, to the console.  As a console
window manager it tries to make it easy to work with multiple console based
programs.")
   (home-page "https://www.brain-dump.org/projects/dvtm/")
   ;; "dvtm reuses some code of dwm and is released under the same MIT/X11
   ;; license. The terminal emulation part is licensed under the ISC license."
   ;; source: http://www.brain-dump.org/projects/dvtm/#license
   (license (list expat isc))))
phen vs. underscore....Ludovic Courtès 2018-03-15linux-initrd: Autoload known-module-aliases, again....Mark H Weaver 2018-03-15linux-initrd: Move 'check-device-initrd-modules' elsewhere....Ludovic Courtès 2018-03-07linux-initrd: Factorize 'check-device-initrd-modules'....Ludovic Courtès 2018-03-02guix system: Check for the lack of modules in the initrd....Ludovic Courtès 2017-12-22mapped-devices: 'luks-device-mapping' checks its source device....Ludovic Courtès 2017-12-22mapped-devices: Add 'location' and 'check' fields....Ludovic Courtès 2017-09-11system: Introduce a disjoint UUID type....Ludovic Courtès 2017-06-07mapped-devices: Cope with delayed appearance of LUKS source....Mark H Weaver 2017-01-24mapped-devices: 'source' can be a list of strings....Ludovic Courtès 2016-11-23mapped-devices: Use 'cryptsetup-static' in 'luks-device-mapping'....Ludovic Courtès 2016-10-27mapped-devices: Use 'mdadm-static' in 'raid-device-mapping'....Ludovic Courtès 2016-10-04mapped-devices: Properly open RAID devices....Ludovic Courtès 2016-09-05system: Use 'source-module-closure' where needed....Ludovic Courtès 2016-08-03mapped-devices: raid-device-mapping: Avoid non-top-level 'use-modules'....Ludovic Courtès 2016-08-02mapped-devices: Bail out when RAID sources don't show up....Ludovic Courtès 2016-08-02mapped-devices: Make RAID device opening message clearer....Ludovic Courtès 2016-08-02mapped-devices: Do not always use (gnu build file-systems)....Ludovic Courtès 2016-07-25system: Add mapped devices for RAID....Andreas Enge 2016-07-12services: <shepherd-service> no longer has an 'imported-modules' field....Ludovic Courtès 2016-04-18mapped-devices: LUKS partitions can be designated by their UUID....Ludovic Courtès 2016-04-18mapped-devices: 'mapped-device-service' takes a <mapped-device>....Ludovic Courtès 2016-04-18services: Move 'device-mapping-service' to (gnu system mapped-devices)....Ludovic Courtès 2016-04-18system: Move 'luks-device-mapping' to (gnu system mapped-devices)....Ludovic Courtès 2016-04-18system: Add (gnu system mapped-devices)....Ludovic Courtès