aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages digest)
  #:use-module (guix gexp)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system pyproject)
  #:use-module (guix build-system python)
  #:use-module (guix build-system trivial)
  #:use-module (guix utils)
  #:use-module (gnu packages python-build)
  #:use-module (ice-9 match))

(define-public wyhash
  (package
    (name "wyhash")
    (version "5")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url "https://github.com/wangyi-fudan/wyhash")
                    (commit (string-append "wyhash_v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32 "03ljs5iw9zrm3bydwggjvpwrcwmsd75h3dv1j4am4hw3h22cjdjc"))))
    (build-system trivial-build-system) ;; source-only package
    (arguments
     `(#:modules ((guix build utils))
       #:builder
       (begin
         (use-modules (guix build utils))
         (let* ((out (string-append (assoc-ref %outputs "out")))
                (include (string-append out "/include"))
                (doc (string-append out "/share/doc/" ,name "-" ,version))
                (source (assoc-ref %build-inputs "source")))
           (with-directory-excursion source
             (install-file "wyhash.h" include)
             (install-file "LICENSE" doc)
             (install-file "README.md" doc))
           #t))))
    (home-page "https://github.com/wangyi-fudan/wyhash")
    (synopsis "Embeddable hash function and random number generator")
    (description "This package provides a portable hash function and random
number generator suitable for use in data structures.  Provided by default in
Zig, V, and Nim programming language standard libraries.")
    (license license:unlicense)))

(define-public xxhash
  (package
    (name "xxhash")
    (version "0.8.2")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/Cyan4973/xxHash")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1ljsmxcxfyxzxzk435qnjiyy441bgrxirn285lymyvv39nrwz1wj"))))
    (build-system gnu-build-system)
    (arguments
     (list #:make-flags
           #~(list #$(string-append "CC=" (cc-for-target))
                   #$(match (or (%current-target-system)
                                (%current-system))
                       ;; Detect vector instruction set at run time.
                       ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
                       (_ "DISPATCH=0"))
                   "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
                   (string-append "prefix=" (assoc-ref %outputs "out")))
           #:phases
           #~(modify-phases %standard-phases
               (delete 'configure))))         ; no configure script
    (home-page "https://cyan4973.github.io/xxHash/")
    (synopsis "Extremely fast hash algorithm")
    (description
     "xxHash is an extremely fast non-cryptographic hash algorithm.  It works
at speeds close to RAM limits, and comes in both 32- and 64-bit flavours.
The code is highly portable, and hashes of the same length are identical on all
platforms (both big and little endian).")
    (license (list license:bsd-2        ; xxhash library (xxhash.[ch])
                   license:gpl2+))))    ; xxhsum.c

(define-public python-xxhash
  (package
    (name "python-xxhash")
    (version "3.1.0")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "xxhash" version))
       (sha256
        (base32
         "1hdxcscry59gh0znlm71ya23mm9rfmvz8lvvlplzxzf63pib28dc"))))
    (build-system pyproject-build-system)
    ;; Needed to embed the correct version string
    (native-inputs
     (list python-setuptools-scm
           python-setuptools
           python-wheel))
    (home-page "https://github.com/ifduyue/python-xxhash")
    (synopsis "Python binding for xxHash")
    (description "This package provides Python bindings for the xxHash hash
algorithm.")
    (license license:bsd-3)))
istics.scm, gnu/packages/stenography.scm, gnu/packages/sync.scm, gnu/packages/syncthing.scm, gnu/packages/synergy.scm, gnu/packages/telephony.scm, gnu/packages/terminals.scm, gnu/packages/tex.scm, gnu/packages/texinfo.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tmux.scm, gnu/packages/tor.scm, gnu/packages/toys.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. Ludovic Courtès 2020-07-08gnu: ibus-rime: Fix license....* gnu/packages/ibus.scm (ibus-rime)[license]: Change license to GPLv3. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Peng Mei Yu 2020-07-08gnu: rime-data: Fix license....* gnu/packages/ibus.scm (rime-data)[license]: Change license to LGPLv3. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Peng Mei Yu 2020-07-08gnu: rime-data: Disable git operations and update comments....* gnu/packages/ibus.scm (rime-data)[arguments]: Disable git operations and update comments. Suppress warnings during build. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Peng Mei Yu 2020-07-08gnu: rime-data: Iterate over inputs to find Rime schemas....* gnu/packages/ibus.scm (rime-data)[arguments]: Iterate over inputs to find Rime schemas rather than using a pre-loaded list. [native-inputs]: Move to ... [inputs]: ... here. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Peng Mei Yu 2020-07-08gnu: rime-data: Update to 0.38.20200623....* gnu/packages/ibus.scm (rime-data): Update to 0.38.20200623. [native-inputs]: Add rime-cantonese. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Peng Mei Yu 2020-04-04gnu: IBus: Build with 'gettext-minimal'....* gnu/packages/ibus.scm (ibus)[native-inputs]: Change from GNU-GETTEXT to GETTEXT-MINIMAL. Marius Bakke 2020-04-04gnu: ibus: Make some inputs native....* gnu/packages/ibus.scm (ibus)[inputs]: Move gettext from here... [native-inputs]: ...to here. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com> Vincent Legoll 2020-03-04gnu: ibus: Update to 1.5.22....* gnu/packages/ibus.scm (ibus): Update to 1.5.22. Marius Bakke 2020-02-03gnu: ibus: Use new ucd package....* gnu/packages/ibus.scm (ibus)[native-inputs]: Add ucd; remove unicode-nameslist and unicode-blocks. [arguments]: Update configure flags and remove prepare-ucd-dir phase. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Leo Prikler 2020-02-03gnu: ibus: Disable parallel build....* gnu/packages/ibus.scm (ibus)[arguments]: Disable parallel build. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Leo Prikler 2020-02-03gnu: ibus: Build with emoji support....* gnu/packages/ibus.scm (ibus)[native-inputs]: Add unicode-emoji and unicode-cldr-common. [arguments]<configure-flags>: Use list instead of quote. Add flags for unicode-emoji-dir and emoji-annotation-dir. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Leo Prikler 2020-01-06gnu: ibus-rime: Record the right file name in "rime.xml"....* gnu/packages/ibus.scm (ibus-rime)[arguments]: Add 'fix-file-names' phase. Co-authored-by: Ludovic Courtès <ludo@gnu.org> kanichos@yandex.ru 2020-01-03gnu: Add ibus-libhangul....* gnu/packages/ibus.scm (ibus-libhangul): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> kanichos@yandex.ru 2020-01-03gnu: Add libhangul....* gnu/packages/ibus.scm (libhangul): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> kanichos@yandex.ru 2020-01-02gnu: ibus: Update to 1.5.21....* gnu/packages/ibus.scm (ibus): Update to 1.5.21. Ricardo Wurmus 2020-01-01gnu: ibus: Fix substitution....* gnu/packages/ibus.scm (ibus)[arguments]: Fix command substitution. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> kanichos@yandex.ru