aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015-2016, 2018, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dico)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:select (gpl3+))
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages crypto)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages python)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages gsasl)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages wordnet))

(define-public dico
  (package
    (name "dico")
    (version "2.11")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/dico/dico-"
                                  version ".tar.xz"))
              (sha256
               (base32
                "0nic4mggc0yhms130k7x4qp5k9c42fwg6n8hmk5cmynh6gi9h7xc"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
                                              "/share/guile/site/2.0")
                               "--disable-static")
       #:make-flags '("V=1")
       #:phases (modify-phases %standard-phases
                  (add-before 'check 'silence-guile
                    (lambda _
                      ;; Guile is too talkative, which disturbs the test
                      ;; infrastructure.  Gag it.
                      (setenv "GUILE_AUTO_COMPILE" "0")
                      (setenv "GUILE_WARN_DEPRECATED" "no")))
                  (replace 'check
                    (lambda _
                      ;; Test '71: append + dooffs + env' fails if $V is not 2.
                      (invoke "make" "check" "V=2"))))))
    (native-inputs (list groff))
    (inputs
     (list m4                           ;used at run time
           pcre
           python-wrapper
           guile-2.2
           gsasl
           readline
           zlib
           wordnet
           libxcrypt                              ;for 'crypt'
           libltdl))
    (home-page "https://www.gnu.org/software/dico/")
    (synopsis "Implementation of DICT server (RFC 2229)")
    (description
     "GNU Dico implements a flexible dictionary server and client according to
RFC 2229 (DICT Server).  It is able to access any database available,
regardless of format, thanks to its modular structure.  New modules may be
written in C, Guile or Python.  Dico also includes a command-line client,
which may be used to query remote dictionary databases.")
    (license gpl3+)))
ons: Remove leungbk. Leo Famulari 2022-01-03.guix-authorizations: Remove Ivan Petkov due to inactivity....* .guix-authorizations: Remove ipetkov. Leo Famulari 2022-01-03.guix-authorizations: Remove David Wilson due to inactivity....* .guix-authorizations: Remove daviwil. Leo Famulari 2022-01-03.guix-authorizations: Remove Brett Gilio due to inactivity....* .guix-authorizations: Remove brettgilio. Leo Famulari 2022-01-03.guix-authorizations: Remove Amin Bandali due to inactivity....* .guix-authorizations: Remove bandali. Leo Famulari 2022-01-03.guix-authorizations: Remove Alex Sassmannshausen due to inactivity....* .guix-authorizations: Remove atheia. Leo Famulari 2022-01-03.guix-authorizations: Remove Alex Griffin due to inactivity....* .guix-authorizations: Remove ajgrf. Leo Famulari 2022-01-03.guix-authorizations: Remove Gábor Boskovits due to inactivity....* .guix-authorizations: Remove boskovits. Leo Famulari 2021-09-06.guix-authorizations: Rename leoprikler to lilyp....* .guix-authorizations: Rename leoprikler to lilyp. Liliana Marie Prikler 2021-06-30.guix-authorizations: Remove kkebreau....* .guix-authorizations: Remove kkebreau from the committers. Kei Kebreau 2021-06-23.guix-authorizations: Update bavier's key....As requested at <https://lists.gnu.org/archive/html/guix-devel/2021-06/msg00123.html>. * .guix-authorizations: Update bavier's signing key fingerprint. Ludovic Courtès 2021-04-28.guix-authorizations: Remove lle_bout....* .guix-authorizations: Remove lle_bout from the committers. Marius Bakke 2021-04-11.guix-authorizations: Add raghavgururajan....* .guix-authorizations: Add raghavgururajan to the committers. Tobias Geerinckx-Rice 2021-04-09Revert ".guix-authorizations: Remove biscuolo due to inactivity."...The original commit was made mistakenly; I forgot to look at all of our Git repos, including maintenance.git, when checking for recent activity. This reverts commit 94521669ed23096f930be68efc691ccb793cc76f. Leo Famulari 2021-04-07.guix-authorizations: Remove biscuolo due to inactivity....* .guix-authorizations: Remove biscuolo. Leo Famulari 2021-04-07.guix-authorizations: Remove wingo due to inactivity....* .guix-authorizations: Remove wingo. Leo Famulari 2021-04-07.guix-authorizations: Remove sleep_walker due to inactivity....* .guix-authorizations: Remove sleep_walker. Leo Famulari 2021-04-07.guix-authorizations: Remove rhelling due to inactivity....* .guix-authorizations: Remove rhelling. Leo Famulari 2021-04-07.guix-authorizations: Remove lsl88 due to inactivity....* .guix-authorizations: Remove lsl88. Leo Famulari 2021-04-07.guix-authorizations: Remove benwoodcroft due to inactivity....* .guix-authorizations: Remove benwoodcroft. Leo Famulari 2021-04-07.guix-authorizations: Remove alexvong1995 due to inactivity....* .guix-authorizations: Remove alexvong1995. Leo Famulari 2021-04-06.guix-authorizations: Remove taylanub....This is a followup to the events discussed here: https://lists.gnu.org/archive/html/guix-devel/2021-03/msg00195.html Taylan was already removed from the Guix project on Savannah on March 10, 2021. * .guix-authorizations: Remove taylanub from the committers. Leo Famulari 2021-04-06.guix-authorizations: Remove thomasd....* .guix-authorizations: Remove thomasd from the committers. Leo Famulari 2021-03-08.guix-authorizations: Add lbraun....* .guix-authorizations: Add lbraun and "lbraun (professional)" to the committers. Leo Famulari 2021-02-18.guix-authorizations: Add lle_bout....* .guix-authorizations: Add lle_bout to the committers. Tobias Geerinckx-Rice 2020-12-28.guix-authorizations: Add leoprikler....* .guix-authorizations: Add leoprikler to the committers. Ludovic Courtès 2020-11-15.guix-authorizations: Add jonsger....* .guix-authorizations: Add jonsger to the committers. Marius Bakke 2020-10-16.guix-authorizations: Add m1gu3l....* .guix-authorizations: Add m1gu3l to the committers. Ludovic Courtès 2020-09-04.guix-authorizations: Add planglois to the committers....* .guix-authorizations: Add planglois. Ludovic Courtès 2020-07-18.guix-authorizations: Add brettgilio (back) to the committers....* .guix-authorizations: Add fingerprint for brettgilio. Tobias Geerinckx-Rice 2020-07-01.guix-authorizations: Remove keys of two former contributors....* .guix-authorizations: Remove key of David Craven, who left the project in 2017, and Federico Beffa, whose last commit was in Feb. 2017. Ludovic Courtès 2020-07-01.guix-authorizations: Remove former keys that are no longer used....* .guix-authorizations: Remove old keys of dvc, efraim, and janneke. Ludovic Courtès 2020-07-01.guix-authorizations: Remove brettgilio's old key....* .guix-authorizations: Remove key "DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE" (Brett Gilio). See <https://lists.gnu.org/archive/html/guix-devel/2020-06/msg00323.html>. Ludovic Courtès 2020-05-04.guix-authorizations: Add bricewge to the committers....* .guix-authorizations: Add fingerprint for bricewge. Ludovic Courtès 2020-05-04.guix-authorizations: Augment....* .guix-authorizations: Add all the currently authorized committers. Ludovic Courtès 2020-05-04Add '.guix-authorizations'....* .guix-authorizations: New file. Ludovic Courtès