aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015-2016, 2018, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dico)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:select (gpl3+))
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages crypto)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages guile)
  #:use-module (gnu packages python)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages gsasl)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages wordnet))

(define-public dico
  (package
    (name "dico")
    (version "2.11")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/dico/dico-"
                                  version ".tar.xz"))
              (sha256
               (base32
                "0nic4mggc0yhms130k7x4qp5k9c42fwg6n8hmk5cmynh6gi9h7xc"))))
    (build-system gnu-build-system)
    (arguments
     '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
                                              "/share/guile/site/2.0")
                               "--disable-static")
       #:make-flags '("V=1")
       #:phases (modify-phases %standard-phases
                  (add-before 'check 'silence-guile
                    (lambda _
                      ;; Guile is too talkative, which disturbs the test
                      ;; infrastructure.  Gag it.
                      (setenv "GUILE_AUTO_COMPILE" "0")
                      (setenv "GUILE_WARN_DEPRECATED" "no")))
                  (replace 'check
                    (lambda _
                      ;; Test '71: append + dooffs + env' fails if $V is not 2.
                      (invoke "make" "check" "V=2"))))))
    (native-inputs (list groff))
    (inputs
     (list m4                           ;used at run time
           pcre
           python-wrapper
           guile-2.2
           gsasl
           readline
           zlib
           wordnet
           libxcrypt                              ;for 'crypt'
           libltdl))
    (home-page "https://www.gnu.org/software/dico/")
    (synopsis "Implementation of DICT server (RFC 2229)")
    (description
     "GNU Dico implements a flexible dictionary server and client according to
RFC 2229 (DICT Server).  It is able to access any database available,
regardless of format, thanks to its modular structure.  New modules may be
written in C, Guile or Python.  Dico also includes a command-line client,
which may be used to query remote dictionary databases.")
    (license gpl3+)))
td>Ludovic Courtès 2014-12-09Add Tomáš to 'AUTHORS'.Ludovic Courtès 2014-11-18Add Julien to 'AUTHORS'.Ludovic Courtès 2014-11-14Add the name of Sou Bunnbu in its original script to 'AUTHORS'.Ludovic Courtès 2014-11-12Add Sun Bunnbu to 'AUTHORS'.Ludovic Courtès 2014-10-26Update name and email address for Joshua Grant.Joshua Grant 2014-10-08Add Federico to 'AUTHORS'.Ludovic Courtès 2014-09-10Add Marek to 'AUTHORS'.Ludovic Courtès 2014-08-15Update AUTHORS and THANKS.Ludovic Courtès 2014-07-18Update 'AUTHORS'.John Darrington * AUTHORS: Correct the email address I use for Guix work. 2014-07-15Add Jason to 'AUTHORS'.Ludovic Courtès 2014-06-29Add Cyrill to AUTHORS.Ludovic Courtès 2014-04-06Add Alírio to 'AUTHORS'.Ludovic Courtès 2014-02-16Add Manolis to 'AUTHORS'.Ludovic Courtès 2014-02-06Add Raimon to 'AUTHORS'.Ludovic Courtès 2014-01-24Add Sree to 'AUTHORS'.Ludovic Courtès 2013-11-29Update references from Guy's old namegzg 2013-11-26Add Guy to 'AUTHORS'.Ludovic Courtès 2013-11-24Add John to 'AUTHORS'.Ludovic Courtès 2013-10-16Update 'AUTHORS'.Ludovic Courtès 2013-10-14Thank Jeffrin and David.Ludovic Courtès 2013-10-06Update 'AUTHORS'.Ludovic Courtès * AUTHORS: Add Alex, Joshua, and Aljosha. 2013-02-17Add Mark to `AUTHORS'.Ludovic Courtès 2013-01-27Update `AUTHORS' and `THANKS'.Ludovic Courtès 2013-01-18Move Andreas to `AUTHORS'.Ludovic Courtès 2012-12-09Change email address in `AUTHORS'.Ludovic Courtès 2012-12-08Update `AUTHORS'.Ludovic Courtès 2012-06-03Add the usual top-level files.Ludovic Courtès