aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dhall)
  #:use-module (gnu packages)
  #:use-module (gnu packages haskell-xyz)
  #:use-module (gnu packages haskell-check)
  #:use-module (gnu packages haskell-crypto)
  #:use-module (gnu packages haskell-web)
  #:use-module (guix download)
  #:use-module (guix build-system haskell)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages))

(define-public dhall
  (package
    (name "dhall")
    (version "1.41.2")
    (source (origin
              (method url-fetch)
              (uri (hackage-uri "dhall" version))
              (sha256
               (base32
                "14m5rrvkid76qnvg0l14xw1mnqclhip3gjrz20g1lp4fd5p056ka"))))
    (build-system haskell-build-system)
    (properties '((upstream-name . "dhall")))
    (inputs (list ghc-aeson
                  ghc-aeson-pretty
                  ghc-ansi-terminal
                  ghc-atomic-write
                  ghc-base16-bytestring
                  ghc-case-insensitive
                  ghc-cborg
                  ghc-cborg-json
                  ghc-contravariant
                  ghc-data-fix
                  ghc-diff
                  ghc-dotgen
                  ghc-either
                  ghc-half
                  ghc-hashable
                  ghc-indexed-traversable
                  ghc-lens-family-core
                  ghc-megaparsec
                  ghc-mmorph
                  ghc-network-uri
                  ghc-optparse-applicative
                  ghc-parsers
                  ghc-parser-combinators
                  ghc-prettyprinter
                  ghc-prettyprinter-ansi-terminal
                  ghc-pretty-simple
                  ghc-profunctors
                  ghc-repline
                  ghc-serialise
                  ghc-scientific
                  ghc-text-manipulate
                  ghc-text-short
                  ghc-th-lift-instances
                  ghc-unordered-containers
                  ghc-uri-encode
                  ghc-vector
                  ghc-cryptohash-sha256
                  ghc-http-types
                  ghc-http-client
                  ghc-http-client-tls))
    (native-inputs (list ghc-foldl
                         ghc-generic-random
                         ghc-quickcheck
                         ghc-quickcheck-instances
                         ghc-special-values
                         ghc-spoon
                         ghc-system-filepath
                         ghc-tasty
                         ghc-tasty-expected-failure
                         ghc-tasty-hunit
                         ghc-tasty-quickcheck
                         ghc-tasty-silver
                         ghc-temporary
                         ghc-turtle
                         ghc-mockery
                         ghc-doctest))
    (arguments
     `(#:tests? #f ; Tries to access httpbin.org
       #:cabal-revision ("4"
                         "0innb3cn98ynb8bd83jdyrm64ij7wcvajg5qcwzdwbyzpr62anfx")))
    (home-page "http://hackage.haskell.org/package/dhall")
    (synopsis "Configuration language guaranteed to terminate")
    (description
     "Dhall is an explicitly typed configuration language that is not Turing
complete.  Despite being Turing incomplete, Dhall is a real programming
language with a type-checker and evaluator.

Use this library to parse, type-check, evaluate, and pretty-print the Dhall
configuration language.  This package also includes an executable which
type-checks a Dhall file and reduces the file to a fully evaluated normal
form.")
    (license license:bsd-3)))
ecgh-go-spew): Move from here ... * gnu/packages/golang-check.scm: ... to here. * gnu/packages/high-availability.scm: Add (gnu packages golang-check) module. Change-Id: I935006c3656b7bf18b91e529296778672338f094 Sharlatan Hellseher 2024-02-13gnu: go-github-com-golang-snappy: Mmove to golang-compression....* gnu/packages/syncthing.scm (go-github-com-golang-snappy): Move from here ... * gnu/packages/golang-compression.scm: ... to here. * gnu/packages/golang.scm: Add (gnu packages golang-compression) module. * gnu/packages/high-availability.scm: As above. * gnu/packages/ipfs.scm: As above. * gnu/packages/syncthing.scm: As above. Change-Id: I936c82c127e1aa25dde20693bee70e5a871249fe Sharlatan Hellseher 2024-02-08gnu: nats-server: Update to 2.10.10....* gnu/packages/high-availability.scm (nats-server): Update to 2.10.10. Change-Id: Ic34d8a4672b188c8d3d10141f9227cab4075fd5b Sharlatan Hellseher 2024-02-08gnu: Add nats-server....* gnu/packages/messaging.scm (nats-server): New variable. Change-Id: Idb05684fae798b37d396279f136f11fce85e2e02 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Benjamin 2024-01-19gnu: nsq: Fix build on i686-linux....As seen in https://ci.guix.gnu.org/build/3329277/details * gnu/packages/high-availability.scm (nsq)[arguments]<#:phases>{check}: Skip '-race' option during tests on i686-linux. Change-Id: I952d7187443835d5fbcb74f0ae09b923bd6bdb29 Sharlatan Hellseher 2024-01-18gnu: pacemaker: Update to 2.1.7....* gnu/packages/high-availability.scm (pacemaker): Update to 2.1.7. Change-Id: I5df38ef3c937e6ab3c902afae3525df61d358bb7 Sharlatan Hellseher 2024-01-18gnu: corosync: Update to 3.1.8....* gnu/packages/high-availability.scm (corosync): Update to 3.1.8. Change-Id: Iaf623ccf3a75cd8aac007a5425d245f9c238789c Sharlatan Hellseher 2024-01-18gnu: nsq: Update to 1.3.0....* gnu/packages/high-availability.scm (nsq): Update to 1.3.0. Change-Id: If092367dbb7413ba177edeac494924b2e170120f Sharlatan Hellseher 2024-01-18gnu: kronosnet: Update to 1.28....* gnu/packages/high-availability.scm (kronosnet): Update to 1.28. Change-Id: Id2974609b7cc8429b6ee8faf8752eed0ddfa1f00 Sharlatan Hellseher 2024-01-18gnu: libqb: Update to 2.0.8....* gnu/packages/high-availability.scm (libqb): Update to 2.0.8. Change-Id: I602a3c3d3b792bc316e699632af6b5dda75fd394 Sharlatan Hellseher 2024-01-18gnu: haproxy: Update to 2.9.0....* gnu/packages/high-availability.scm (haproxy): Update to 2.9.0. Change-Id: I430c0694ba682b3be5332fdafb20ba7ac5996402 Sharlatan Hellseher 2024-01-03gnu: go-github-com-julienschmidt-httprouter: Move to (gnu packages golang-web)....* gnu/packages/golang.scm (go-github-com-julienschmidt-httprouter): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/high-availability.scm: Add (gnu packages golang-web) module. Change-Id: I277e4a7ed835b0dc00f08e102e982e0cd019b828 Sharlatan Hellseher 2023-09-04gnu: Add nsq....* gnu/packages/high-availability.scm (nsq): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-07-16gnu: libqb: Tweak description....* gnu/packages/high-availability.scm (libqb)[synopsis]: Fix spelling. [description]: Use @acronym{}. Tobias Geerinckx-Rice 2023-07-16gnu: libqb: Update to 2.0.7....* gnu/packages/high-availability.scm (libqb): Update to 2.0.7. Tobias Geerinckx-Rice 2023-07-16gnu: libqb: Fix cross-compilation....* gnu/packages/high-availability.scm (libqb)[native-inputs]: Move libxml2 from here… [inputs]: …to here. Tobias Geerinckx-Rice 2023-07-16gnu: libqb: Remove obsolete bootstrapping inputs....* gnu/packages/high-availability.scm (libqb)[native-inputs]: Remove autoconf, automake, and libtool. Tobias Geerinckx-Rice 2023-04-09gnu: haproxy: Update to 2.7.6....* gnu/packages/high-availability.scm (haproxy): Update to 2.7.6. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Yovan Naumovski 2023-03-26gnu: haproxy: Move to (gnu packages high-availability)....Copyright records were synchronized based on commit history. * gnu/packages/networking.scm (haproxy): Move this variable from here... * gnu/packages/high-availability.scm (haproxy): ...to here. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Add pacemaker....* gnu/pacemaker/high-availability.scm (pacemaker): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Add corosync....* gnu/packages/high-availability.scm (corosync): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Add kronosnet....* gnu/packages/high-availability.scm (kronosnet): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: libqb: Update to 2.0.6....* gnu/packages/high-availability.scm (libqb): Update to 2.0.6. Run `guix style' over the package. [native-inputs]: Add autoconf, automake, libtools to fix configure and build phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher 2022-10-10gnu: Move libqb to high-availability....* gnu/packages/hardware.scm (libqb): Move to high-availability.scm. * gnu/packages/high-availability.scm: New file. * gnu/local.mk: Add high-availability.scm to GNU_SYSTEM_MODULES list. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Sharlatan Hellseher