aboutsummaryrefslogtreecommitdiff
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dhall)
  #:use-module (gnu packages)
  #:use-module (gnu packages haskell-xyz)
  #:use-module (gnu packages haskell-check)
  #:use-module (gnu packages haskell-crypto)
  #:use-module (gnu packages haskell-web)
  #:use-module (guix download)
  #:use-module (guix build-system haskell)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages))

(define-public dhall
  (package
    (name "dhall")
    (version "1.41.2")
    (source (origin
              (method url-fetch)
              (uri (hackage-uri "dhall" version))
              (sha256
               (base32
                "14m5rrvkid76qnvg0l14xw1mnqclhip3gjrz20g1lp4fd5p056ka"))))
    (build-system haskell-build-system)
    (properties '((upstream-name . "dhall")))
    (inputs (list ghc-aeson
                  ghc-aeson-pretty
                  ghc-ansi-terminal
                  ghc-atomic-write
                  ghc-base16-bytestring
                  ghc-case-insensitive
                  ghc-cborg
                  ghc-cborg-json
                  ghc-contravariant
                  ghc-data-fix
                  ghc-diff
                  ghc-dotgen
                  ghc-either
                  ghc-half
                  ghc-hashable
                  ghc-indexed-traversable
                  ghc-lens-family-core
                  ghc-megaparsec
                  ghc-mmorph
                  ghc-network-uri
                  ghc-optparse-applicative
                  ghc-parsers
                  ghc-parser-combinators
                  ghc-prettyprinter
                  ghc-prettyprinter-ansi-terminal
                  ghc-pretty-simple
                  ghc-profunctors
                  ghc-repline
                  ghc-serialise
                  ghc-scientific
                  ghc-text-manipulate
                  ghc-text-short
                  ghc-th-lift-instances
                  ghc-unordered-containers
                  ghc-uri-encode
                  ghc-vector
                  ghc-cryptohash-sha256
                  ghc-http-types
                  ghc-http-client
                  ghc-http-client-tls))
    (native-inputs (list ghc-foldl
                         ghc-generic-random
                         ghc-quickcheck
                         ghc-quickcheck-instances
                         ghc-special-values
                         ghc-spoon
                         ghc-system-filepath
                         ghc-tasty
                         ghc-tasty-expected-failure
                         ghc-tasty-hunit
                         ghc-tasty-quickcheck
                         ghc-tasty-silver
                         ghc-temporary
                         ghc-turtle
                         ghc-mockery
                         ghc-doctest))
    (arguments
     `(#:tests? #f ; Tries to access httpbin.org
       #:cabal-revision ("4"
                         "0innb3cn98ynb8bd83jdyrm64ij7wcvajg5qcwzdwbyzpr62anfx")))
    (home-page "http://hackage.haskell.org/package/dhall")
    (synopsis "Configuration language guaranteed to terminate")
    (description
     "Dhall is an explicitly typed configuration language that is not Turing
complete.  Despite being Turing incomplete, Dhall is a real programming
language with a type-checker and evaluator.

Use this library to parse, type-check, evaluate, and pretty-print the Dhall
configuration language.  This package also includes an executable which
type-checks a Dhall file and reduces the file to a fully evaluated normal
form.")
    (license license:bsd-3)))
.3. Change-Id: Ifb45a5e36aeb03f54df449c60ab58ee8f393d534 2024-01-18gnu: fcitx5-qt: Update to 5.1.4.宋文武 * gnu/packages/fcitx5.scm (fcitx5-qt): Update to 5.1.4. Change-Id: Ie2b8a3bb061d4a068602a841dae4b50a37715668 2024-01-18gnu: fcitx5-gtk: Update to 5.1.1.宋文武 * gnu/packages/fcitx5.scm (fcitx5-gtk): Update to 5.1.1. Change-Id: If4d6fcddc1a284aa02519b93fdd89664ec1915d5 2024-01-18gnu: libime: Update to 1.1.4.宋文武 * gnu/packages/fcitx5.scm (libime): Update to 1.1.4. Change-Id: Ibf60683739337e886316ea88d97e899053469ed7 2024-01-18gnu: fcitx5-lua: Update to 5.0.12.宋文武 * gnu/packages/fcitx5.scm (fcitx5-lua): Update to 5.0.12. Change-Id: Ie4b4c3496a59a0a956359a73a780de8a6c2211f7 2024-01-18gnu: fcitx5: Update to 5.1.6.宋文武 * gnu/packages/fcitx5.scm (fcitx5): Update to 5.1.6. [inputs]: Add libuv. Change-Id: I77e722c8ae76272ce76bbb42e5a3a01d81dff433 2024-01-18gnu: xcb-imdkit: Update to 1.0.6.宋文武 * gnu/packages/fcitx5.scm (xcb-imdkit): Update to 1.0.6. Change-Id: If5398cee97d20fed4e1f643fabc8950f007d6786 2023-11-22gnu: fcitx5-rime: Update to 5.1.3.宋文武 * gnu/packages/fcitx5.scm (fcitx5-rime): Update to 5.1.3. Change-Id: Ia7939616d93ec0235b9fd50f2ae2a26d551a650c 2023-11-22gnu: fcitx5-configtool: Update to 5.1.2.宋文武 * gnu/packages/fcitx5.scm (fcitx5-configtool): Update to 5.1.2. Change-Id: I534cb1943c09d5a36f171608fcbb6b09661d2bb4 2023-11-22gnu: fcitx5-chinese-addons: Update to 5.1.2.宋文武 * gnu/packages/fcitx5.scm (fcitx5-chinese-addons): Update to 5.1.2. Change-Id: Icbfa1628c23adfc5c2789480c9803a1b1c257a0f 2023-11-22gnu: fcitx5-qt: Update to 5.1.3.宋文武 * gnu/packages/fcitx5.scm (fcitx5-qt): Update to 5.1.3. Change-Id: Id0b375c7d052f2d2d8a4d10f8415b748823efe14 2023-11-22gnu: fcitx5-anthy: Update to 5.1.2.宋文武 * gnu/packages/fcitx5.scm (fcitx5-anthy): Update to 5.1.2. Change-Id: I0e6e8b3774221fdb91ee91fa2870cdda3d6e9273 2023-11-22gnu: libime: Update to 1.1.3.宋文武 * gnu/packages/fcitx5.scm (libime): Update to 1.1.3. [inputs]: Add zstd:lib. [native-inputs]: Add pkg-config and remove python. Change-Id: Ia3a580c2292b68a8f492b29c37d7219a77271d54 2023-11-22gnu: fcitx5-lua: Update to 5.0.11.宋文武 * gnu/packages/fcitx5.scm (fcitx5-lua): Update to 5.0.11. Change-Id: Iacfd1a197c888cc1a79e31723c57e5ac34a8a7f5 2023-11-22gnu: fcitx5: Update to 5.1.5.宋文武 * gnu/packages/fcitx5.scm (fcitx5): Update to 5.1.5. Change-Id: I6e3ac3c8ad77fd53d431bd1501ae6b44ad49a66a 2023-08-23gnu: fcitx5-rime: Update to 5.1.1.宋文武 * gnu/packages/fcitx5.scm (fcitx5-rime): Update to 5.1.1. 2023-08-23gnu: fcitx5-configtool: Update to 5.1.0.宋文武 * gnu/packages/fcitx5.scm (fcitx5-configtool): Update to 5.1.0. 2023-08-23gnu: fcitx5-chinese-addons: Update to 5.1.0.宋文武 * gnu/packages/fcitx5.scm (fcitx5-chinese-addons): Update to 5.1.0. 2023-08-23gnu: fcitx5-anthy: Update to 5.1.0.宋文武 * gnu/packages/fcitx5.scm (fcitx5-anthy): Update to 5.1.0. 2023-08-23gnu: fcitx5-qt: Update to 5.1.0.宋文武 * gnu/packages/fcitx5.scm (fcitx5-qt): Update to 5.1.0. 2023-08-23gnu: fcitx5-gtk: Update to 5.1.0.宋文武 * gnu/packages/fcitx5.scm (fcitx5-gtk): Update to 5.1.0. 2023-08-23gnu: libime: Update to 1.1.0.宋文武 * gnu/packages/fcitx5.scm (libime): Update to 1.1.0. 2023-08-23gnu: fcitx5: Update to 5.1.0.宋文武 * gnu/packages/fcitx5.scm (fcitx5): Update to 5.1.0. [inputs]: Remove libpthread-stubs, libx11, libxfixes, libxinerama and unicode-cldr-common. [arguments]: Pass "-DUSE_SYSTEMD=OFF" as configure-flags.