aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dc)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages tls)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ncdc
  (package
    (name "ncdc")
    (version "1.22.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
                           ".tar.gz"))
       (sha256
        (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi"))))
    (build-system gnu-build-system)
    (inputs
     (list bzip2
           glib
           gnutls
           ncurses
           sqlite
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://dev.yorhel.nl/ncdc")
    (synopsis
     "Lightweight direct connect client with a friendly ncurses interface")
    (description
     "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
using ncurses.  It is known for its smaller footprint and ease of use.")
    (license license:x11)))
fig’ typo/left-over....Tobias Geerinckx-Rice 2021-06-23services: cups: Support CUPS 2.3.3op2's LogFileGroup directive....Tobias Geerinckx-Rice 2021-03-10services: Prevent following symlinks during activation....Maxime Devos 2021-01-17services: cups: reuse lp from %base-groups....Leo Prikler 2021-01-10services: cups: Add brlaser extension by default....Tobias Geerinckx-Rice 2020-11-21services: cups: Add Splix by default....Tobias Geerinckx-Rice 2020-11-21gnu: Rename escpr to epson-inkjet-printer-escpr....Tobias Geerinckx-Rice 2020-11-18services: cups: Add some extensions by default....Danny Milosavljevic 2020-05-26services: Fix permissions of directory /var/spool/cups/tmp....Danny Milosavljevic 2019-08-31services: cups: Rename ‘retry-this-job’ to ‘retry-current-job’....Tobias Geerinckx-Rice 2019-08-30services: cups: Move SET-ENV to FILES-CONFIGURATION....Tobias Geerinckx-Rice 2019-08-30services: cups: Add BrowseDNSSDSubTypes directive....Tobias Geerinckx-Rice 2019-08-27services: cups: Update SSL-OPTIONS docstring....Tobias Geerinckx-Rice 2019-08-27services: cups: Complete SSL-OPTIONS....Tobias Geerinckx-Rice 2019-06-05services: cups: Create /var/cache on activation....Alex Griffin 2019-03-13Remove traces of "GuixSD"....Ludovic Courtès 2018-06-22services: cups: Add description....Ricardo Wurmus 2017-04-16services: Add a default value to various service types....Ludovic Courtès 2017-03-12services: Move configuration functions that shouldn't be factorized....Clément Lassieur 2017-01-25services: Fix 'mkdir-p' in activation scripts....Clément Lassieur 2016-12-01services: cups: Follow symlinks when installing extensions....Andy Patterson 2016-11-26services: Factorize configuration abstraction....Julien Lepiller 2016-10-13gnu: Add CUPS service....Andy Wingo