aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dc)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages tls)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ncdc
  (package
    (name "ncdc")
    (version "1.22.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
                           ".tar.gz"))
       (sha256
        (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi"))))
    (build-system gnu-build-system)
    (inputs
     (list bzip2
           glib
           gnutls
           ncurses
           sqlite
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://dev.yorhel.nl/ncdc")
    (synopsis
     "Lightweight direct connect client with a friendly ncurses interface")
    (description
     "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
using ncurses.  It is known for its smaller footprint and ease of use.")
    (license license:x11)))
='/guix/commit/gnu/services?id=131746885ccd050c4a440d2129aea5bfa86c29e2'>services: mpd: Log to syslog by default....Maxim Cournoyer 2023-07-26services: mpd; Refactor start slot directory initialization....Maxim Cournoyer 2023-07-26services: mpd: List log-level in decreasing verbosity order in doc....Maxim Cournoyer 2023-07-26services: guix-data-service: Unlink the two shepherd services....Christopher Baines 2023-07-25services: mpd: Rename %set-user-group to set-user-group....Maxim Cournoyer 2023-07-25services: mpd: Streamline mpd-user-sanitizer and mympd-user-sanitizer....Maxim Cournoyer 2023-07-25services: mpd: Add an 'update' action to trigger a database update....Maxim Cournoyer 2023-07-25services: mpd: Add auto-update? field to mpd-configuration....Maxim Cournoyer 2023-07-21services: wireguard: Add a 'configuration' action....Maxim Cournoyer 2023-07-21services: wireguard: Clean-up configuration file serializer....Maxim Cournoyer 2023-07-21services: wireguard: Implement a dynamic IP monitoring feature....Maxim Cournoyer 2023-07-21services: herd: Add a new 'current-service' procedure....Maxim Cournoyer 2023-07-13services: static-networking: Support netdde for the Hurd....Janneke Nieuwenhuizen 2023-07-13services: childhurd: Bump default qemu memory to 2048MB....Janneke Nieuwenhuizen 2023-07-02services: cgit: Remove ‘cgit-repo’ left-overs....Tobias Geerinckx-Rice 2023-07-07services: libvirt: Add requirement on dbus....Josselin Poiret 2023-07-07gnu: gnome: Remove gnome-boxes from default GNOME apps....Josselin Poiret 2023-07-02services: nginx: Harden php-location settings....Bruno Victal 2023-06-27services: pam-limits: Add lightdm....John Kehayias 2023-06-25services: Validate 'provision' field of <shepherd-service>....Ludovic Courtès 2023-06-24services: dicod: Use one inetd endpoint per interface....Ludovic Courtès 2023-06-18services: certbot: Fix nginx crash when certbot is used without domains....Saku Laesvuori 2023-06-16services: qemu-guest-agent: Add dependency on udev....Ludovic Courtès 2023-06-14services: static-netwoking: Wait for devices to show up....Ludovic Courtès 2023-06-04services: screen-locker-service-type: Configurable PAM and setuid....muradm 2023-05-30services: herd: "Resolve" transient services only when needed....Ludovic Courtès 2023-05-24services: guix: Depend on 'avahi-daemon' when 'discover?' is set....Ludovic Courtès 2023-05-23services: cups: Add cups PAM service....muradm 2023-05-21services: Transient inetd services inherit requirements....Ludovic Courtès 2023-05-21services: root-file-system: Remove reference to 'stop-logging'....Ludovic Courtès 2023-05-21services: agetty: 'stop' method does nothing when running is 'idle....Ludovic Courtès 2023-05-18services: rsync: Use least authority wrapper....Maxim Cournoyer 2023-05-18services: rsync: Use make-inetd-constructor....Maxim Cournoyer 2023-05-17services: ssh: Really rename openssh-challenge-response-authentication?...Maxim Cournoyer 2023-05-17services: ssh: Rename openssh-challenge-response-authentication?...Maxim Cournoyer 2023-05-17services: openssh: Export openssh-configuration accessors....Maxim Cournoyer 2023-05-13services: shepherd: Default to 0.10....Ludovic Courtès 2023-05-13services: nar-herder: Support extra environment vars....Christopher Baines 2023-05-11services: inetd: Export accessors....Bruno Victal 2023-05-11services: Add vnstat-service-type....Bruno Victal 2023-05-11services: dhcp-client-configuration: Add 'shepherd-requirement' field....Sergey Trofimov 2023-05-11services: elogind: Add elogind as a shepherd PAM requirement....Josselin Poiret 2023-05-11system: pam: Let PAM extensions add shepherd requirements....Josselin Poiret