aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dc)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages tls)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ncdc
  (package
    (name "ncdc")
    (version "1.22.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
                           ".tar.gz"))
       (sha256
        (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi"))))
    (build-system gnu-build-system)
    (inputs
     (list bzip2
           glib
           gnutls
           ncurses
           sqlite
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://dev.yorhel.nl/ncdc")
    (synopsis
     "Lightweight direct connect client with a friendly ncurses interface")
    (description
     "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
using ncurses.  It is known for its smaller footprint and ease of use.")
    (license license:x11)))
a href='/guix/commit/gnu/packages/maven.scm?id=f1ed3d4699a726cd13985afa32b9c97e72505970'>gnu: java-cglib: Update to 3.3.0....cglib now requires asm-8 at runtime, so propagate it and do not use asm-6 in dependents. * gnu/packages/java.scm (java-cglib): Update to 3.3.0. (java-plexus-component-metadata-1.7, java-easymock, java-jmock) (java-jmock-legacy, java-jmock-junit4, java-ops4j-pax-exam-core-spi) (java-guice, java-fest-assert, java-testng, java-lmax-disruptor) (java-powermock-reflect, java-powermock-modules-junit4) (java-kafka-clients, java-jline-2, java-xmlunit, java-eclipse-sisu-plexus) (java-logback-core): Remove `java-asm` from inputs or native-inputs. (java-httpcomponents-httpclient-cache) (java-httpcomponents-httpclient-osgi): Disable tests. * gnu/packages/batik.scm (java-xmlgraphics-commons): Remove `java-asm` from inputs or native inputs. * gnu/packages/maven.scm (maven-resolver-transport-file) (maven-resolver-transport-http, maven-model, maven-repository-metadata) (maven-compat): Remove `java-asm` from inputs or native-inputs. Change-Id: I92a939e7522d92b185715d7935aabed5ddb77451 Julien Lepiller