aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dc)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages tls)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ncdc
  (package
    (name "ncdc")
    (version "1.22.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
                           ".tar.gz"))
       (sha256
        (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi"))))
    (build-system gnu-build-system)
    (inputs
     (list bzip2
           glib
           gnutls
           ncurses
           sqlite
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://dev.yorhel.nl/ncdc")
    (synopsis
     "Lightweight direct connect client with a friendly ncurses interface")
    (description
     "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
using ncurses.  It is known for its smaller footprint and ease of use.")
    (license license:x11)))
l'>...Ludovic Courtès 2019-04-27vm-image: Add a font to the global profile....Ludovic Courtès 2019-04-27doc: Update bit about SSH in the VM....Ludovic Courtès 2019-04-26vm-image: Remove NetworkManager & co. and add the DHCP client....Ludovic Courtès 2019-04-26vm-image: Use the actual file name of the current file....Ludovic Courtès 2019-04-26system: Provide a new VM image configuration....Ludovic Courtès 2019-04-10doc: Adjust desktop instructions for GDM....Ludovic Courtès 2019-04-05services: xorg: Add 'set-xorg-configuration'....Ludovic Courtès 2019-04-03gnu: Add example system configuration for asus-c201....Timothy Sample 2019-03-28system: Fix typo in desktop example....Ludovic Courtès 2019-03-27services: Deprecate 'xfce-desktop-service'....Ludovic Courtès 2019-03-27services: Deprecate 'gnome-desktop-service'....Ludovic Courtès 2019-03-25accounts: Add default value for the 'home-directory' field of <user-account>....Ludovic Courtès 2019-03-13Remove traces of "GuixSD"....Ludovic Courtès 2019-01-23gnu: Replace all cons* with beginner-friendly (append (list ...))....Pierre Neidhardt 2019-01-23gnu: Fix missing EFI entry in "desktop" example....Pierre Neidhardt 2019-01-20services: Use guix-service-type....Efraim Flashner 2018-12-24doc: Example vm-image doesn't need firmware....Efraim Flashner 2018-12-03doc: Fix "desktop" OS config example....Laura Lazzati 2018-11-26services: openssh: Install OpenSSH in the system profile....Ludovic Courtès 2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès 2018-07-05doc: Improve UEFI/BIOS bootloader documentation....Ludovic Courtès 2018-05-28file-systems: Remove 'title' field and add <file-system-label>....Ludovic Courtès 2018-03-24system: Add "guix system docker-image" command....Chris Marusich 2018-03-03system: beaglebone-black: Use 'initrd-modules'....Ludovic Courtès 2018-01-21doc: No longer mention Wicd in OS examples....Ludovic Courtès 2017-12-22system: examples: Add missing initrd to beaglebone-black.tmpl....Mathieu Othacehe 2017-12-18system: examples: Add a template for BeagleBone Black....Mathieu Othacehe 2017-12-06gnu, doc, tests: Use ‘bootloader-configuration’ everywhere....Tobias Geerinckx-Rice 2017-10-11doc: Give an example with a FAT UUID....Ludovic Courtès 2017-09-12doc: Use Screen and OpenSSH in the bare-bones example....Ludovic Courtès 2017-08-23gnu: bootloader: Deprecate "device" field in favor of "target"....Andy Wingo 2017-08-20gnu: grub-efi-bootloader: Specialize grub-install invocation....Andy Wingo 2017-05-19doc: Update for UEFI systems....Marius Bakke 2017-05-17maint: The 'release' target builds a VM image....Leo Famulari 2017-04-12doc: Use OpenSSH instead of lsh in bare-bones template....Leo Famulari 2017-02-23gnu: lightweight-desktop.tmpl: Remove xmonad....Leo Famulari 2017-02-23gnu: lightweight-desktop.tmpl: Complete i3-wm....Leo Famulari 2017-02-13system: Use the normalized codeset for the locale name in the examples....Ludovic Courtès 2016-11-28doc: Suggest installing gvfs....Ricardo Wurmus 2016-11-24doc: Document encrypted root partitions....Ludovic Courtès 2016-09-08gnu: lightweight-desktop.tmpl: Fix typo....Efraim Flashner 2016-03-23doc: Add "lightweight desktop" OS config example....Ludovic Courtès