aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages dc)
  #:use-module (gnu packages)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages tls)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:))

(define-public ncdc
  (package
    (name "ncdc")
    (version "1.22.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
                           ".tar.gz"))
       (sha256
        (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi"))))
    (build-system gnu-build-system)
    (inputs
     (list bzip2
           glib
           gnutls
           ncurses
           sqlite
           zlib))
    (native-inputs
     (list pkg-config))
    (home-page "https://dev.yorhel.nl/ncdc")
    (synopsis
     "Lightweight direct connect client with a friendly ncurses interface")
    (description
     "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
using ncurses.  It is known for its smaller footprint and ease of use.")
    (license license:x11)))
d>2018-08-10gnu: sord: Update to 0.16.2....Tobias Geerinckx-Rice 2018-06-22gnu: Use HTTPS for drobilla.net URIs....Tobias Geerinckx-Rice 2018-04-12Merge branch 'master' into core-updatesMark H Weaver 2018-04-12gnu: lrdf: Update to 0.6.1....Marius Bakke 2018-04-12gnu: sord: Return #t from all phases....Mark H Weaver 2018-04-12gnu: serd: Return #t from all phases....Mark H Weaver 2018-02-08gnu: serd: Update to 0.28.0....Tobias Geerinckx-Rice 0 2017-10-03Update e-mail for Theodoros Foradis....Theodoros Foradis 2017-08-29Update e-mail for Kei Kebreau....Kei Kebreau 2017-08-13mailmap: fix entries for ng0....ng0 2017-06-16mailmap: Adjust entries for ng0....ng0 2017-06-03.mailmap: Add another alias for ng0....ng0 2017-05-23mailmap: Update entries for Adriano Peluso...Adriano Peluso 2017-05-22mailmap: Add an entry for Mathieu Othacehe....Mathieu Othacehe 2017-04-20mailmap: Update entries for ng0....ng0 2017-01-27Update .mailmap entries for ng0....ng0 2017-01-01Update .mailmap....Alex Kost 2016-12-20mailmap: Add alias for Marius Bakke....Marius Bakke 2016-11-26mailmap: Associate all commits by ng0 with ng0....ng0 2016-10-11Update e-mail address for ng0....ng0 2016-10-05Update e-mail address for ng0....ng0 2016-07-15Update e-mail address for Tobias Geerinckx-Rice....Andreas Enge 2016-07-03Update name for ng0....ng0 2016-05-19Update name for Kei Kebreau....Kei Kebreau 2016-05-04Update .mailmap....Alex Kost