aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016-2020, 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages datamash)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages gawk)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-xyz))

(define-public datamash
  (package
    (name "datamash")
    (version "1.8")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/datamash/datamash-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1zgn55gvf60w2rs5f7vx7vdp50j89ki7mmjvm81xs5pngs67xnbs"))))
    (native-inputs
     (list which ;for tests
           perl))                 ;for help2man
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/datamash/")
    (synopsis "Scriptable statistics and data calculation")
    (description
     "Perform basic numeric, textual and statistical operations on plain text
files.  Designed to work within standard pipelines without additional code.")
    (license gpl3+)))

(define-public vnlog
  (package
    (name "vnlog")
    (version "1.32")
    (home-page "https://github.com/dkogan/vnlog")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                    (url home-page)
                    (commit (string-append "v" version))))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "1g4insm6gkw3c82fq8q9swkdha3cncbz1nib15yg9b2s4yl123hm"))))
    (build-system gnu-build-system)
    (native-inputs
     (list python-numpy))               ;for tests
    (inputs
     (list mawk
           perl
           perl-ipc-run
           perl-list-moreutils
           perl-string-shellquote
           perl-text-diff
           perl-text-table
           python-wrapper))
    (arguments
     (list #:make-flags
           #~(list (string-append "CC=" #$(cc-for-target))
                   (string-append "DESTDIR=" #$output)
                   "USRLIB=lib"
                   "MANDIR=share/man"
                   (string-append "PY3_MODULE_PATH=lib/python"
                                  #$(version-major+minor
                                     (package-version
                                      (this-package-input "python-wrapper")))
                                  "/site-packages")
                   ;; Do not install the Python 2 modules.
                   "DIST_PY2_MODULES=")
           #:phases
           #~(modify-phases %standard-phases
               (add-after 'unpack 'adjust-Makefile
                 (lambda _
                   (substitute* "GNUmakefile"
                     ;; Install Perl modules to the usual location.
                     (("/usr/share/perl5")
                      (string-append "/lib/perl5/site_perl/"
                                     #$(package-version
                                        (this-package-input "perl"))))
                     ;; Do not add a '/usr' suffix to DESTDIR.
                     (("\\$\\(DESTDIR\\)/usr")
                      "$(DESTDIR)")
                     ;; Do not strip RUNPATH from the installed C library.
                     ((".*find.*chrpath.*")
                      ""))))
               (add-after 'unpack 'use-absolute-mawk
                 (lambda* (#:key inputs #:allow-other-keys)
                   (let ((mawk (search-input-file inputs "bin/mawk")))
                     (substitute* '("vnl-filter" "lib/Vnlog/Util.pm")
                       (("'mawk'")
                        (string-append "'" mawk "'"))))))
               (delete 'configure)
               (add-before 'check 'disable-python2-test
                 (lambda _
                   (delete-file "test/test_python2_parser.sh")
                   (substitute* "GNUmakefile"
                     ((".*test/test_python2_parser\\.sh\\.RUN.*")
                      ""))))
               (add-after 'install 'wrap
                 (lambda* (#:key inputs outputs #:allow-other-keys)
                   (let* ((out (assoc-ref outputs "out"))
                          (PERL5LIB (string-append
                                     out "/lib/perl5/site_perl/"
                                     #$(package-version
                                        (this-package-input "perl"))
                                     ":" (getenv "PERL5LIB"))))
                     (for-each (lambda (script)
                                 (wrap-program script
                                   `("PERL5LIB" ":" prefix (,PERL5LIB))))
                               (find-files (string-append out "/bin"))))))
               (add-after 'wrap 'check-wrapped-executables
                 (lambda* (#:key outputs #:allow-other-keys)
                   (let ((out (assoc-ref outputs "out")))
                     ;; Assert that the installed Perl scripts can find
                     ;; their dependencies even when PERL5LIB is unset.
                     (unsetenv "PERL5LIB")
                     (for-each (lambda (script)
                                 (invoke/quiet script "--help"))
                               (find-files (string-append out "/bin")
                                           "^vnl-[[:lower:]]+$"))))))))
    (synopsis "Process labelled tabular ASCII data on the command line")
    (description
     "Vnlog (pronounced @dfn{vanillog}) is a toolkit for manipulating
tabular ASCII data with labelled fields using regular command-line tools.")
    (license lgpl2.1+)))
-pcre)[native-inputs]: Add ocamlbuild. (ocaml-expect): Update 0.0.6. (ocaml4.02-fileutils): Update to 0.5.3. (ocaml-oasis): Update 0.4.11. (ocaml-js-build-tools)[native-inputs]: Add ocamlbuild. (ocaml-bin-prot): Rename to ocaml4.02-bin-prot. (ocaml-fieldslib): Rename to ocaml4.02-fieldslib. (ocaml-ppx-core): Rename to ocaml4.02-ppx-core. (ocaml-ppx-optcomp): Rename to ocaml4.02-ppx-optcomp. (ocaml-ppx-driver): Rename to ocaml4.02-ppx-driver. (ocaml-cppo): Update to 1.6.5. (ocaml-ppx-deriving): Rename to ocaml4.02-ppx-deriving. (ocaml-ppx-type-conv): Rename to ocaml4.02-ppx-type-conv. (ocaml-ppx-inline-test): Rename to ocaml4.02-ppx-inline-test. (ocaml-ppx-bench): Rename to ocaml4.02-ppx-bench. (ocaml-ppx-compare): Rename to ocaml4.02-ppx-compare. (ocaml-sexplib): Rename to ocaml4.02-sexplib. (ocaml-typerep): Rename to ocaml4.02-typerep. (ocaml-variantslib): Rename to ocaml4.02-variantslib. (ocaml-ppx-sexp-conv): Rename to ocaml4.02-ppx-sexp-conv. (ocaml-ppx-variants-conv): Rename to ocaml4.02-ppx-variants-conv. (ocaml-ppx-here): Rename to ocaml4.02-ppx-here. (ocaml-ppx-assert): Rename to ocaml4.02-ppx-assert. (ocaml-ppx-enumerate): Rename to ocaml4.02-ppx-enumerate. (ocaml-ppx-let): Rename to ocaml4.02-ppx-let. (ocaml-ppx-typerep-conv): Rename to ocaml4.02-ppx-typerep-conv. (ocaml-ppx-sexp-value): Rename to ocaml4.02-ppx-sexp-value. (ocaml-ppx-pipebang): Rename to ocaml4.02-ppx-pipebang. (ocaml-ppx-bin-prot): Rename to ocaml4.02-ppx-bin-prot. (ocaml-ppx-fail): Rename to ocaml4.02-ppx-fail. (ocaml-ppx-custom-printf): Rename to ocaml4.02-ppx-custom-printf. (ocaml-ppx-sexp-message): Rename to ocaml4.02-ppx-sexp-message. (ocaml-ppx-fields-conv): Rename to ocaml4.02-ppx-fields-conv. (ocaml-re): Update to 1.8.0. (ocaml-ppx-expect): Rename to ocaml4.02-ppx-expect. (ocaml-ppx-jane): Rename to ocaml4.02-ppx-jane. (ocaml-core-kernel): Rename to ocaml4.02-core-kernel. (ocaml-async-kernel): Rename to ocaml4.02-async-kernel. (ocaml-async-rpc-kernel): Rename to ocaml4.02-async-rpc-kernel. (ocaml-core): Rename to ocaml4.02-core. (ocaml-async-unix): Rename to ocaml4.02-async-unix. (ocaml-async-extra): Rename to ocaml4.02-async-extra. (ocaml-async): Rename to ocaml4.02-async. (ocaml-ocplib-endian)[native-inputs]: Update to 1.0. (ocaml-cstruct): Rename to ocaml4.02-cstruct. (ocaml-hex): Rename to ocaml4.02-hex. (ocaml-ezjsonm): Rename to ocaml4.02-ezjsonm. (ocaml-uri): Rename to ocaml4.02-uri. (optcomp): Use ocaml-4.02. (ocaml-piqilib): Update to 0.6.14. (ocaml-uuidm)[native-inputs]: Add ocamlbuild. (ocaml-graph): Update to 1.8.8. (ocaml-piqi): Update to 0.7.6. (bap): Update to 1.3.0. (ocaml-camomile): Update to 1.0.1. (ocaml-jbuilder): Use ocaml-4.02. (ocaml-lambda-term): Update to 1.13. (ocaml-utop): Update to 2.2.0. (ocaml-integers)[native-inputs]: Add ocamlbuild. (ocaml-ctypes): Update to 0.14.0. (ocaml-ocb-stubblr)[native-inputs]: Add ocamlbuild. (ocaml-tsdl)[native-inputs]: Add ocamlbuild. * gnu/packages/machine-learning.scm (ocaml-mcl): Use ocaml-4.02. * gnu/packages/maths.scm (cubicle): Update to 1.1.2. * gnu/packages/patches/ocaml-bisect-fix-camlp4-in-another-directory.patch: Update patch. * guix/build-system/ocaml.scm: (default-ocaml4.02, default-ocaml4.02-findlib) (package-with-ocaml4.02, strip-ocaml4.02-variant): New variables. Julien Lepiller 2018-09-20gnu: python2-scikit-learn: Fix check phase....* gnu/packages/machine-learning.scm (python2-scikit-learn)[arguments]: Override check phase to disable broken tests and pass environment variables. Ricardo Wurmus 2018-09-12gnu: python-scikit-learn: Update to 0.19.2....* gnu/packages/machine-learning.scm (python-scikit-learn): Update to 0.19.2. [source]: Fetch from git. [arguments]: Run tests before installation; replace "check" phase, add "build-ext" phase; delete "reset-gzip-timestamps" phase. [native-inputs]: Add python-pytest and python-pandas; remove python-nose. Ricardo Wurmus 2018-09-05gnu: r-kernlab: Update to 0.9-27....* gnu/packages/machine-learning.scm (r-kernlab): Update to 0.9-27. Ricardo Wurmus 2018-09-05gnu: r-adaptivesparsity: Update to 1.6....* gnu/packages/machine-learning.scm (r-adaptivesparsity): Update to 1.6. [propagated-inputs]: Add r-mass and r-matrix. Ricardo Wurmus 2018-06-27gnu: python-scikit-learn: Return #t from phases....* gnu/packages/machine-learning.scm (python-scikit-learn)[arguments]: Substitute INVOKE for SYSTEM*. Tobias Geerinckx-Rice 2018-06-27gnu: dlib: Return #t from all phases....* gnu/packages/machine-learning.scm (dlib)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases. Tobias Geerinckx-Rice 2018-06-27gnu: dlib: Fix tests....* gnu/packages/machine-learning.scm (dlib)[native-inputs]: Add libnsl. Tobias Geerinckx-Rice 2018-06-27gnu: ghmm: Return #t from all phases....* gnu/packages/machine-learning.scm (ghmm)[arguments]: Substitute INVOKE for SYSTEM*. Tobias Geerinckx-Rice 2018-06-14gnu: Add vowpal-wabbit....* gnu/packages/machine-learning.scm (vowpal-wabbit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fis Trivial 2018-06-14gnu: Add lightgbm....* gnu/packages/machine-learning.scm (lightgbm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fis Trivial 2018-05-31Merge branch 'master' into core-updatesRicardo Wurmus 2018-05-31gnu: r-kernlab: Update to 0.9-26....* gnu/packages/machine-learning.scm (r-kernlab): Update to 0.9-26. Ricardo Wurmus 2018-05-29Merge branch 'master' into core-updatesMark H Weaver 2018-05-29gnu: Update shogun to 6.1.3....* gnu/packages/machine-learning.scm (shogun): Update to 6.1.3. [source]: Update snippet to remove proprietary software. [arguments]: Rewrite list of symlinks in 'delete-broken-symlinks' phase. Rewrite file lists given to substitute* in 'change-R-target-path' and 'fix-octave-modules' phases. Adjust 'fix-octave-modules' for the update. Add 'move-rxcpp' phase. Rewrite configure-flags for the update. [inputs]: Add eigen. [native-inputs]: Add rxcpp. Kei Kebreau 2018-05-29gnu: Add rxcpp....* gnu/packages/machine-learning.scm (rxcpp): New variable. Kei Kebreau 2018-04-30Merge branch 'master' into core-updatesMark H Weaver 2018-04-28gnu: Add python-autograd...* gnu/packages/machine-learning.scm (python-autograd, python2-autograd): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fis Trivial 2018-03-16gnu: All snippets report errors using exceptions, else return #t....* gnu/packages/admin.scm, gnu/packages/algebra.scm, gnu/packages/audio.scm, gnu/packages/backup.scm, gnu/packages/base.scm, gnu/packages/bioinformatics.scm, gnu/packages/cdrom.scm, gnu/packages/chez.scm, gnu/packages/code.scm, gnu/packages/compression.scm, gnu/packages/cross-base.scm, gnu/packages/crypto.scm, gnu/packages/cups.scm, gnu/packages/databases.scm, gnu/packages/dns.scm, gnu/packages/emacs.scm, gnu/packages/emulators.scm, gnu/packages/engineering.scm, gnu/packages/enlightenment.scm, gnu/packages/fpga.scm, gnu/packages/freedesktop.scm, gnu/packages/ftp.scm, gnu/packages/games.scm, gnu/packages/gcc.scm, gnu/packages/geo.scm, gnu/packages/ghostscript.scm, gnu/packages/gl.scm, gnu/packages/glib.scm, gnu/packages/gnome.scm, gnu/packages/gnuzilla.scm, gnu/packages/graphics.scm, gnu/packages/gtk.scm, gnu/packages/guile.scm, gnu/packages/irc.scm, gnu/packages/java.scm, gnu/packages/kerberos.scm, gnu/packages/linux.scm, gnu/packages/lisp.scm, gnu/packages/lxde.scm, gnu/packages/machine-learning.scm, gnu/packages/mail.scm, gnu/packages/maths.scm, gnu/packages/messaging.scm, gnu/packages/monitoring.scm, gnu/packages/mp3.scm, gnu/packages/music.scm, gnu/packages/netpbm.scm, gnu/packages/networking.scm, gnu/packages/node.scm, gnu/packages/nvi.scm, gnu/packages/ocaml.scm, gnu/packages/pdf.scm, gnu/packages/perl.scm, gnu/packages/php.scm, gnu/packages/plotutils.scm, gnu/packages/pretty-print.scm, gnu/packages/profiling.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-crypto.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/robotics.scm, gnu/packages/sawfish.scm, gnu/packages/scanner.scm, gnu/packages/scheme.scm, gnu/packages/scribus.scm, gnu/packages/sdl.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/slang.scm, gnu/packages/smalltalk.scm, gnu/packages/ssh.scm, gnu/packages/sync.scm, gnu/packages/syncthing.scm, gnu/packages/tbb.scm, gnu/packages/terminals.scm, gnu/packages/texinfo.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/tls.scm, gnu/packages/unrtf.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vpn.scm, gnu/packages/web.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xorg.scm: In all snippets, report errors using exceptions, or else return #t. Mark H Weaver 2018-02-03Merge branch 'master' into core-updatesMark H Weaver 2018-02-02gnu: Add fann....* gnu/packages/machine-learning.scm (fann): New variable. Co-authored-by: Ben Woodcroft <donttrustben@gmail.com> Mark Meyer 2018-01-11Merge branch 'master' into core-updatesLeo Famulari 2018-01-10gnu: libsvm: Update to 3.22....* gnu/packages/machine-learning.scm (libsvm): Update to 3.22. [source]: Use upstream tarball instead of a git snapshot. Tobias Geerinckx-Rice 2017-12-31Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2017-12-24gnu, doc: Use HTTPS for cran.r-project.org home pages....* gnu/packages/bioinformatics.scm (r-sparql, r-acsnminer, r-gkmsvm) (r-maldiquant, r-gprofiler)[home-page]: Use HTTPS. * gnu/packages/cran.scm (r-colorspace, r-auc, r-calibrate, r-shape) (r-compare, r-proxy, r-sp, r-rmtstat, r-lmtest, r-inline, r-bbmle) (r-lpsolve, r-energy, r-suppdists, r-ksamples, r-cvst, r-drr, r-prodlim) (r-ddalpha, r-rcpproll, r-ipred, r-psych, r-truncnorm, r-rsolnp, r-laeken) (r-vcd, r-ica, r-scatterplot3d)[home-page]: Likewise. * gnu/packages/machine-learning.scm (r-adaptivesparsity, r-kernlab) [home-page]: Likewise. * gnu/packages/maths.scm (r-quadprog, r-pracma)[home-page]: Likewise. * gnu/packages/statistics.scm (r-boot, r-cluster, r-codetools, r-foreign) (r-kernsmooth, r-nlme, r-mgcv, r-rpart, r-dichromat, r-estimability) (r-pheatmap, r-labeling, r-magrittr, r-munsell, r-rcolorbrewer, r-sendmailr) (r-gdtools, r-acepack, r-formula, r-locfit, r-chron, r-coda, r-backports) (r-brew, r-commonmark, r-rstudioapi, r-plotrix, r-gridbase, r-bitops) (r-catools, r-xnomial, r-lambda-r, r-whoreadsthis, r-futile-options) (r-futile-logger, r-segmented, r-snow, r-iterators, r-foreach, r-doparallel) (r-domc, r-irlba, r-registry, r-e1071, r-bigmemory-sri, r-r-methodss3) (r-tidyselect, r-base64, r-runit, r-sfsmisc, r-gtools, r-gdata, r-gplots) (r-ztable, r-vipor, r-sourcetools, r-statmod, r-compquadform, r-mixtools) (r-fastica, r-diptest, r-modeltools, r-flexmix, r-deoptimr, r-pcapp) (r-rrcov, r-fit-models, r-robust, r-trimcluster, r-fpc, r-fnn) (r-modelmetrics, r-nloptr, r-lme4, r-tclust, r-lubridate)[home-page]: Likewise. * gnu/packages/web.scm (r-htmltools, r-hwriter, r-rjson, r-rook)[home-page]: Likewise. * doc/guix.texi (Invoking guix import, Invoking guix refresh): Likewise. Tobias Geerinckx-Rice 2017-12-19gnu: Remove redundant cmake libdir configure flags....* gnu/packages/bioinformatics.scm (imp)[arguments]: Remove CMAKE_INSTALL_LIBDIR flag. * gnu/packages/calendar.scm (libical): Same. * gnu/packages/engineering.scm (kicad): Same. * gnu/packages/games.scm (openrct2, mgba): Same. * gnu/packages/gl.scm (virtualgl): Same. * gnu/packages/image-processing.scm (mia): Same. * gnu/packages/linux.scm (rdma-core): Same. * gnu/packages/machine-learning.scm (dlib): Same. * gnu/packages/maths.scm (lapack, superlu, z3): Same. * gnu/packages/password-utils.scm (keepassxc): Same. * gnu/packages/photo.scm (darktable): Same. * gnu/packages/rdesktop.scm (freerdp): Same. Efraim Flashner 2017-12-14gnu: python-scikit-learn: Patch test non-determinism....* gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch: New file. * gnu/packages/machine-learning.scm (python-scikit-learn)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Ben Woodcroft 2017-12-04gnu: python-scikit-learn: Update to 0.19.1....* gnu/packages/machine-learning.scm (python-scikit-learn): Update to 0.19.1. Tobias Geerinckx-Rice