aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cyrus-sasl)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages crypto)
  #:use-module (gnu packages dbm)
  #:use-module (gnu packages kerberos)
  #:use-module (gnu packages tls)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cyrus-sasl
  (package
    (name "cyrus-sasl")
    (version "2.1.28")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://github.com/cyrusimap/cyrus-sasl"
                                  "/releases/download/cyrus-sasl-" version
                                  "/cyrus-sasl-" version ".tar.gz"))
              (sha256
               (base32
                "135kbgyfpa1mwqp5dm223yr6ddzi4vjm7cr414d7rmhys2mwdkvw"))))
    (build-system gnu-build-system)
    (inputs (list gdbm libxcrypt mit-krb5 openssl))
    (arguments
     (list
      #:configure-flags #~(list (string-append "--with-plugindir="
                                               (assoc-ref %outputs "out")
                                               "/lib/sasl2")
                                ;; When cross-compiling the build system is
                                ;; unable to determine whether SPNEGO is
                                ;; supported; Kerberos does, so enable it.
                                #$@(if (%current-target-system)
                                       '("ac_cv_gssapi_supports_spnego=yes")
                                       '()))

      ;; The 'plugins' directory has shared source files, such as
      ;; 'plugin_common.c'.  When building the shared libraries there, libtool
      ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
      ;; fail with EEXIST when building things in parallel.
      #:parallel-build? #f))
    (synopsis "Simple Authentication Security Layer implementation")
    (description
     "SASL (Simple Authentication Security Layer) is an Internet
standards-track method for remote computers to authenticate.  The Cyrus SASL
library makes supporting various SASL mechanisms easy for both client and
server writers.")
    (license (license:non-copyleft "file://COPYING"
                                   "See COPYING in the distribution."))
    (home-page "https://cyrusimap.org/sasl/")))
an>Mathieu Othacehe 2021-05-13gnu: zfs-auto-snapshot: Wrap long lines....* gnu/packages/file-systems.scm (zfs-auto-snapshot)[synopsis, description]: Wrap long lines. Mathieu Othacehe 2021-05-13gnu: Add zfs-auto-snapshot....* gnu/packages/file-systems.scm (zfs-auto-snapshot): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> raid5atemyhomework 2021-05-13gnu: xfstests: Fix typo....Syntax-highlighted monospace is overrated. Nothing like glancing at Webmail to spot obvious bugs. * gnu/packages/file-systems.scm (xfstests)[arguments]: Omit /usr from /bin/time. Tobias Geerinckx-Rice 2021-05-13gnu: Add xfstests....* gnu/packages/file-systems.scm (xfstests): New public variable. Tobias Geerinckx-Rice 2021-05-07gnu: bcachefs-tools: Update to 0.1-7.7942d5c....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-7.7942d5c. Tobias Geerinckx-Rice 2021-05-04gnu: bcachefs-tools: Prepare for cross-compilation....* gnu/packages/file-systems.scm (bcachefs-tools)[arguments]: Use CC-FOR-TARGET and PKG-CONFIG-FOR-TARGET. Tobias Geerinckx-Rice 2021-05-04gnu: bcachefs-tools: Update to 0.1-6.a14d39d....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-6.a14d39d. Tobias Geerinckx-Rice 2021-04-22gnu: exfatprogs: Update to 1.1.1....* gnu/packages/file-systems.scm (exfatprogs): Update to 1.1.1. Tobias Geerinckx-Rice 2021-04-21gnu: bcachefs-tools: Update to 0.1-5.ce906d6....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-5.ce906d6. Tobias Geerinckx-Rice 2021-04-10gnu: bindfs: Fix typo in description....* gnu/packages/file-systems.scm (bindfs)[description]: Fix typo. Tobias Geerinckx-Rice 2021-04-10gnu: tmsu: Fix typo in synopsis & description....* gnu/packages/file-systems.scm (tmsu)[synopsis, description]: Fix typo. Tobias Geerinckx-Rice 2021-04-10gnu: davfs2: Fix typo in description....* gnu/packages/file-systems.scm (davfs2)[description]: Fix typo. Tobias Geerinckx-Rice 2021-03-29gnu: python-dropbox: Update to 11.5.0....* gnu/packages/file-systems.scm (python-dropbox): Update to 11.5.0. Efraim Flashner 2021-03-29gnu: bcachefs-tools: Update to 0.1-4.bb6eccc....* gnu/packages/file-systems.scm (bcachefs-tools): Update to 0.1-4.bb6eccc. Tobias Geerinckx-Rice 2021-03-28gnu: autofs: Update to 5.1.7....* gnu/packages/file-systems.scm (autofs): Update to 5.1.7. [arguments]: Add a new 'fix-rpath phase. Tobias Geerinckx-Rice 2021-03-16gnu: tmsu: Improve installation....* gnu/packages/file-systems.scm (tmsu)[arguments]: Don't install go source files. Install binary as tmsu instead of TMSU. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Stefan Reichör 2021-03-13gnu: mergerfs: Update to 2.32.4....* gnu/packages/file-systems.scm (mergerfs): Update to 2.32.4. Lars-Dominik Braun 2021-03-11gnu: Update zfs to 2.0.4....Mostly FreeBSD fixes, some documentation changes and corrections, and a few small bugfixes. Tested with `guix build` only, no in-depth testing done. From 6037ac6f797f37abb579278a0d30cd16e6876ec6 Mon Sep 17 00:00:00 2001 From: raid5atemyhomework <raid5atemyhomework@protonmail.com> Date: Thu, 11 Mar 2021 12:43:58 +0000 Subject: [PATCH] gnu: Update zfs to 2.0.4. * gnu/packages/file-systems.scm (zfs): Update to 2.0.4, rename to OpenZFS. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> raid5atemyhomework via Guix-patches via 2021-03-11gnu: bindfs: Update to 1.15.1....* gnu/packages/file-systems.scm (bindfs): Update to 1.15.1. Tobias Geerinckx-Rice 2021-03-06gnu: fsarchiver: Update to 0.8.6....* gnu/packages/file-systems.scm (fsarchiver): Update to 0.8.6. Tobias Geerinckx-Rice 2021-02-24gnu: Add tmsu....* gnu/packages/file-systems.scm (tmsu): New variable. Ricardo Wurmus 2021-02-24gnu: Add go-github-com-hanwen-fuse....* gnu/packages/file-systems.scm (go-github-com-hanwen-fuse): New variable. Ricardo Wurmus 2021-02-15gnu: exfatprogs: Update to 1.1.0....* gnu/packages/file-systems.scm (exfatprogs): Update to 1.1.0. Tobias Geerinckx-Rice 2021-02-15gnu: Fix copyright notice....* gnu/packages/file-systems.scm: Fix copyright notice for raid5atemyhomework. Tobias Geerinckx-Rice