aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cyrus-sasl)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages crypto)
  #:use-module (gnu packages dbm)
  #:use-module (gnu packages kerberos)
  #:use-module (gnu packages tls)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cyrus-sasl
  (package
    (name "cyrus-sasl")
    (version "2.1.28")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://github.com/cyrusimap/cyrus-sasl"
                                  "/releases/download/cyrus-sasl-" version
                                  "/cyrus-sasl-" version ".tar.gz"))
              (sha256
               (base32
                "135kbgyfpa1mwqp5dm223yr6ddzi4vjm7cr414d7rmhys2mwdkvw"))))
    (build-system gnu-build-system)
    (inputs (list gdbm libxcrypt mit-krb5 openssl))
    (arguments
     (list
      #:configure-flags #~(list (string-append "--with-plugindir="
                                               (assoc-ref %outputs "out")
                                               "/lib/sasl2")
                                ;; When cross-compiling the build system is
                                ;; unable to determine whether SPNEGO is
                                ;; supported; Kerberos does, so enable it.
                                #$@(if (%current-target-system)
                                       '("ac_cv_gssapi_supports_spnego=yes")
                                       '()))

      ;; The 'plugins' directory has shared source files, such as
      ;; 'plugin_common.c'.  When building the shared libraries there, libtool
      ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
      ;; fail with EEXIST when building things in parallel.
      #:parallel-build? #f))
    (synopsis "Simple Authentication Security Layer implementation")
    (description
     "SASL (Simple Authentication Security Layer) is an Internet
standards-track method for remote computers to authenticate.  The Cyrus SASL
library makes supporting various SASL mechanisms easy for both client and
server writers.")
    (license (license:non-copyleft "file://COPYING"
                                   "See COPYING in the distribution."))
    (home-page "https://cyrusimap.org/sasl/")))
ackages/certs.scm (nss-certs): Update to 3.55. Marius Bakke 2020-07-25gnu: nspr: Update to 4.27....* gnu/packages/nss.scm (nspr): Update to 4.27. Marius Bakke 2020-06-06gnu: Remove nss/fixed....The merge preceding this commit ignored the nss replacement added in commit 7bc396bf353c5550c49b3f8791b34072ba417d90. This commit removes the remaining bits, because the fix is already present in nss@3.52.1. * gnu/packages/patches/nss-CVE-2020-12399.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss/fixed): Remove variable. Marius Bakke 2020-06-06Merge branch 'master' into stagingMarius Bakke 2020-06-02gnu: nss: Fix CVE-2020-12399 via graft....* gnu/packages/patches/nss-CVE-2020-12399.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/nss.scm (nss/fixed): New variable. (nss)[replacement]: Add field. Mark H Weaver 2020-05-26gnu: NSS: Update to 3.52.1 [fixes CVE-2020-12399]....* gnu/packages/nss.scm (nss): Update to 3.52.1. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2020-05-26gnu: NSS: Update to 3.52....* gnu/packages/nss.scm (nss): Update to 3.52. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2020-03-14Merge branch 'master' into core-updatesMarius Bakke 2020-02-15gnu: nss: Add comment about deleted libraries....* gnu/packages/nss.scm (source)[snippet]: Add comment. While at it, add missing copyright information for Marius Bakke. Marius Bakke 2020-02-14gnu: nss: Delete bundled SQLite and Zlib....* gnu/packages/nss.scm (nss)[source](modules, snippet): New fields. Marius Bakke 2020-02-14gnu: nss, nss-certs: Update to 3.50....* gnu/packages/nss.scm (nss): Update to 3.50. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2020-02-14gnu: nspr: Update to 4.25....* gnu/packages/nss.scm (nspr): Update to 4.25. Marius Bakke 2020-02-14gnu: nspr: Do not build the static library....* gnu/packages/nss.scm (nspr)[arguments]: Add "--disable-static" in #:configure-flags. Marius Bakke 2020-02-14gnu: nss: Remove obsolete patch....* gnu/packages/patches/nss-freebl-stubs.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss)[source](patches): Remove 'nss-freebl-stubs.patch'. Marius Bakke 2020-01-21Merge branch 'staging' into core-updatesMarius Bakke 2020-01-19gnu: nss, nss-certs: Update to 3.49.1....* gnu/packages/certs.scm (nss-certs): Update to 3.49.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2020-01-12gnu: nss, nss-certs: Update to 3.49....* gnu/packages/certs.scm (nss-certs): Update to 3.49. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2020-01-11Merge branch 'master' into core-updatesMarius Bakke 2019-12-12gnu: nss: Ungraft....* gnu/packages/nss.scm (nss)[replacement]: Remove field. [source]: Add patch. (nss/fixed): Remove variable. Efraim Flashner 2019-12-11gnu: nss: Remove replacement package....The merge preceding this commit ignored the 'replacement' added to nss in commit 04b33ce205f38813b4dbd04b6ad3c7aa0be0b6f6, because the security fix is already present in NSS 3.48. This commit removes the remaining bits. * gnu/packages/patches/nss-CVE-2019-11745.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss/fixed): Remove variable. Marius Bakke 2019-12-11Merge branch 'master' into stagingMarius Bakke 2019-12-11gnu: nss: Fix CVE-2019-11745 via graft....* gnu/packages/patches/nss-CVE-2019-11745.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/nss.scm (nss/fixed): New variable. (nss)[replacement]: Add field. Mark H Weaver 2019-12-11gnu: nss: Update to 3.48....* gnu/packages/nss.scm (nss): Update to 3.48. Marius Bakke 2019-12-11gnu: nspr: Update to 4.24....* gnu/packages/nss.scm (nspr): Update to 4.24. Marius Bakke 2019-10-08gnu: nss, nss-certs: Update to 3.46.1....* gnu/packages/nss.scm (nss): Update to 3.46.1. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-10-08gnu: nspr: Update to 4.22....* gnu/packages/nss.scm (nspr): Update to 4.22. Marius Bakke 2019-08-06gnu: nss: Fix build failure on armhf-linux....Fixes <https://bugs.gnu.org/36930>. * gnu/packages/patches/nss-freebl-stubs.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss)[source](patches): Add it. Marius Bakke 2019-08-04gnu: nss, nss-certs: Update to 3.45....* gnu/packages/certs.scm (nss-certs): Update to 3.45. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-06-29gnu: nss, nss-certs: Update to 3.44.1....* gnu/packages/certs.scm (nss-certs): Update to 3.44.1. * gnu/packages/nss.scm (nss): Likewise. Marius Bakke 2019-05-24gnu: nss, nss-certs: Update to 3.44....* gnu/packages/nss.scm (nss): Update to 3.44. * gnu/packages/certs.scm (nss-certs): Likewise. Marius Bakke 2019-04-08Merge branch 'master' into stagingMarius Bakke 2019-04-04gnu: Move nss & co. to nss.scm....* gnu/packages/gnuzilla.scm (nspr, nss): Move to... * gnu/packages/nss.scm: ... here. New file. * gnu/packages/chromium.scm, gnu/packages/disk.scm, gnu/packages/freedesktop.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/java.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/mate.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/password-utils.scm, gnu/packages/polkit.scm, gnu/packages/qt.scm, gnu/packages/sssd.scm, gnu/packages/storage.scm, gnu/packages/vpn.scm, gnu/packages/web.scm, gnu/packages/xml.scm: Adjust accordingly. * gnu/local.mk (GNU_SYSTEM_MODULES): Add nss.scm. Ludovic Courtès