aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cyrus-sasl)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages crypto)
  #:use-module (gnu packages dbm)
  #:use-module (gnu packages kerberos)
  #:use-module (gnu packages tls)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cyrus-sasl
  (package
    (name "cyrus-sasl")
    (version "2.1.28")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://github.com/cyrusimap/cyrus-sasl"
                                  "/releases/download/cyrus-sasl-" version
                                  "/cyrus-sasl-" version ".tar.gz"))
              (sha256
               (base32
                "135kbgyfpa1mwqp5dm223yr6ddzi4vjm7cr414d7rmhys2mwdkvw"))))
    (build-system gnu-build-system)
    (inputs (list gdbm libxcrypt mit-krb5 openssl))
    (arguments
     (list
      #:configure-flags #~(list (string-append "--with-plugindir="
                                               (assoc-ref %outputs "out")
                                               "/lib/sasl2")
                                ;; When cross-compiling the build system is
                                ;; unable to determine whether SPNEGO is
                                ;; supported; Kerberos does, so enable it.
                                #$@(if (%current-target-system)
                                       '("ac_cv_gssapi_supports_spnego=yes")
                                       '()))

      ;; The 'plugins' directory has shared source files, such as
      ;; 'plugin_common.c'.  When building the shared libraries there, libtool
      ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
      ;; fail with EEXIST when building things in parallel.
      #:parallel-build? #f))
    (synopsis "Simple Authentication Security Layer implementation")
    (description
     "SASL (Simple Authentication Security Layer) is an Internet
standards-track method for remote computers to authenticate.  The Cyrus SASL
library makes supporting various SASL mechanisms easy for both client and
server writers.")
    (license (license:non-copyleft "file://COPYING"
                                   "See COPYING in the distribution."))
    (home-page "https://cyrusimap.org/sasl/")))
38ee3d616d02b278fafc9459ac771a25ffb139b0'>gnu: borgmatic: Use G-expressions....Tobias Geerinckx-Rice 2022-01-06gnu: borgmatic: Update to 1.5.22....Tobias Geerinckx-Rice 2021-12-29gnu: dirvish: Fix trailing whitespace in description....Vagrant Cascadian 2021-12-22gnu: disarchive: Update to 0.4.0....Timothy Sample 2021-12-13gnu: Simplify package inputs....Ludovic Courtès 2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus 2021-11-27gnu: borgmatic: Update to 1.5.21....Tobias Geerinckx-Rice 2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-15gnu: borgmatic: Fix typo in description....Nicolas Goaziou 2021-11-14gnu: Add borgmatic....Arun Isaac 2021-11-13gnu: duplicity: Update to 0.8.21....Tobias Geerinckx-Rice 2021-11-11gnu: Remove references to a removed patch....Mathieu Othacehe 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-24gnu: disarchive: Update to 0.3.0....Timothy Sample 2021-10-23gnu: Use 'search-input-file' some more....Ludovic Courtès 2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-10-17gnu: duplicity: Update home-page....Efraim Flashner 2021-10-17gnu: duplicity: Depend on dbus....Vivien Kraus 2021-10-17gnu: duplicity: Depend on python-pygobject....Vivien Kraus 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-03gnu: snapraid: Update to 11.6....Tobias Geerinckx-Rice 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-08-30gnu: libchop: Don't append to CPATH unconditionally....Efraim Flashner 2021-08-12Merge branch 'master' into core-updates-frozen...Marius Bakke 2021-07-27gnu: Duplicity: Depend on python-paramiko....Leo Famulari 2021-07-27gnu: Borg: Use bundled msgpack....Leo Famulari 2021-08-15Update copyright/name notices for Christine Lemmer-Webber....Christopher Lemmer Webber 2021-08-05gnu: restic: Have the custom check phase honor TESTS?....Maxim Cournoyer 2021-08-05gnu: restic: Patch tests for go-1.16....Sarah Morgensen 2021-07-24gnu: Use 'search-input-directory' when looking for tzdata....Ludovic Courtès 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-17gnu: rsnapshot: Remove modifications to tests....Brice Waegeneire 2021-07-17gnu: rsnapshot: Fix tests....Tobias Geerinckx-Rice 2021-07-15gnu: Add snapraid....Tobias Geerinckx-Rice 2021-07-13gnu: Borg: Update to 1.1.17....Leo Famulari 2021-06-30gnu: duplicity: Update to 0.8.20....Tobias Geerinckx-Rice 2021-06-23Merge branch 'master' into core-updates...Tobias Geerinckx-Rice 2021-06-20gnu: rsnapshot: Update to 1.4.4....Tobias Geerinckx-Rice