aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cvassistant)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages compression))

(define-public cvassistant
  (package
    (name "cvassistant")
    (version "3.1.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/cvassistant/"
                                  "cvassistant-" version "-src.tar.bz2"))
              (sha256
               (base32
                "1y2680bazyiwm50gdhdd4982ckbjscrkbw2mngyk7yw708iadvr7"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'remove-donation-banner
           ;; Remove dialog box with a donation link, as suggested by
           ;; the INSTALL file.
           (lambda _
             (substitute* "controllers/mainwindow.cpp"
               (("//(#define NO_DONATION_PROMPT)" _ line) line))
             #t))
         (add-after 'unpack 'fix-quazip-directory
           (lambda _
             (substitute* "models/resumedocument.h"
               (("quazip(/quazipfile\\.h)" _ suffix)
                (string-append "quazip5" suffix)))
             #t))
         (add-after 'fix-quazip-directory 'fix-quazip-link
           (lambda _
             (substitute* "CVAssistant.pro"
               (("lquazip-qt5")
                "lquazip5"))
             #t))
         (add-after 'fix-quazip-directory 'fix-install-root
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (substitute* "CVAssistant.pro"
                 (("/usr/(bin|share/)" _ suffix)
                  (string-append out "/" suffix)))
               #t)))
         (replace 'configure
           (lambda _ (invoke "qmake"))))))
    (inputs
     (list qtbase-5 quazip-0 zlib))
    (home-page "https://cvassistant.sourceforge.io/")
    (synopsis "Job application organizer")
    (description "Whether you're looking for a job or trying to help
  a friend to find one, CVAssistant is a tool for you.  It helps you by
  preparing resumes and cover letters and organizing your job
  application process.  It:
  @itemize
  @item Stores all your skills and experiences.
  @item Creates resumes tailored for each job you apply.
  @item Creates cover letters summarized to match each job
  advertisement.
  @item Keeps a history of job applications so you are ready when you
  receive a phone call.
  @item Writes resumes in your language.  All languages are supported!
  @end itemize")
    (license license:gpl3+)))
ls.scm, gnu/packages/time.scm, gnu/packages/tls.scm, gnu/packages/tor.scm, gnu/packages/tryton.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/virtualization.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wicd.scm, gnu/packages/xdisorg.scm, gnu/packages/xorg.scm: Update module references. Ricardo Wurmus 2019-01-07gnu: Remove unnecessary build-side module imports....* gnu/packages/batik.scm, gnu/packages/boost.scm, gnu/packages/calendar.scm, gnu/packages/gl.scm, gnu/packages/lua.scm, gnu/packages/qt.scm, gnu/packages/simulation.scm, gnu/packages/terminals.scm: Remove unnecessary import of (guix build utils). * gnu/packages/emacs.scm: Remove unnecessary imports of (guix ...). * gnu/packages/libcanberra.scm: Use (srfi srfi-1) instead of (guix build utils) for 'alist-delete'. * gnu/packages/wxwidgets.scm: Likewise. Ludovic Courtès 2019-01-06gnu: Add kitty....* gnu/packages/terminals.scm (kitty): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Gabriel Hondet 2018-12-03Merge branch 'core-updates'Ludovic Courtès 2018-11-29gnu: tmate: Fetch sources from git....* gnu/packages/terminals.scm (tmate)[source]: Fetch from git. Ricardo Wurmus 2018-11-29gnu: picocom: Fetch sources from git....* gnu/packages/terminals.scm (picocom)[source]: Fetch from git. Ricardo Wurmus 2018-11-29gnu: tilda: Fetch sources from git....* gnu/packages/terminals.scm (tilda)[source]: Fetch from git. Ricardo Wurmus 2018-11-29gnu: unilibium: Fetch sources from git....* gnu/packages/terminals.scm (unilibium)[source]: Fetch from git. Ricardo Wurmus 2018-11-29gnu: kmscon: Don't invoke './configure' during bootstrap....* gnu/packages/terminals.scm (kmscon)[arguments]: Change 'autogen.sh' phase to replace 'bootstrap' and set the $NOCONFIGURE environment variable. Marius Bakke 2018-11-21gnu: termite: Update to 14....* gnu/packages/terminals.scm (termite): Update to 14. Marius Bakke 2018-11-07gnu: terminals: Change libtsm and kmscon repositories....Those two packages (from the same author) are no longer maintained and do not even compile. Switch to a fork that is maintained even if it does not have any release yet. * gnu/packages/terminals.scm (libtsm)[origin]: Use "https://github.com/Aetf/libtsm" as new origin and switch to git-fetch method. (kmscon)[origin]: Use "https://github.com/Aetf/kmscon" as new origin and switch to git-fetch method. Mathieu Othacehe 2018-06-14gnu: Add tmate....* gnu/packages/terminals.scm (tmate): New variable. Arun Isaac 2018-06-05gnu: tilda: Replace bootstrap phase....* gnu/packages/terminals.scm (tilda)[arguments]: Remove custom 'bootstrap phase and use it to replace default bootstrap phase. Efraim Flashner 2018-05-31Merge branch 'master' into core-updatesMark H Weaver 2018-05-31gnu: sakura: Update to 3.6.0....* gnu/packages/terminals.scm (sakura): Update to 3.6.0. Tobias Geerinckx-Rice 2018-04-21Merge branch 'master' into core-updatesMark H Weaver 2018-04-12gnu: cool-retro-term: Update to 1.0.1....* gnu/packages/terminals.scm (cool-retro-term): Update to 1.0.1. [source]: Programmatically remove fonts. [arguments]: Simplify 'configure phase and use 'invoke'. Add 'install-man phase. 'let*' -> 'let' where possible. * gnu/packages/patches/cool-retro-term-remove-non-free-fonts.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove it. Eric Bavier