aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cppi)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses))

(define-public cppi
  (package
    (name "cppi")
    (version "1.18")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/cppi/cppi-"
                                 version ".tar.xz"))
             (sha256
              (base32
               "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/cppi/")
    (synopsis "Indent C preprocessor directives to reflect nesting and more")
    (description
     "GNU Cppi processes C source code files to properly indent the
preprocessor directives to reflect their nesting.  It also performs other
standardizations, such as correcting the number of spaces between directives
and the text following them.")
    (license gpl3+)))
d>gnu: Fix hunspell-dict-en-* dictionary installation....Kei Kebreau 2017-10-27gnu: Add Catalan dictionary for Aspell....Ludovic Courtès 2017-10-27gnu: Add hunspell-dict-en*....Ludovic Courtès 2017-10-03Update e-mail for Theodoros Foradis....Theodoros Foradis 2017-08-08gnu: aspell-dict-en: Update to 2017.01.22-0....Tobias Geerinckx-Rice retrying SQLite transactions into a higher-order function....Eelco Dolstra 2016-06-26daemon: Rename 'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'....David Craven 2016-05-31daemon: Substitute queries return immediately when substitutes are disabled....Ludovic Courtès 2016-05-31daemon: Fix typo....Ludovic Courtès 2016-05-31daemon: Remove unused XML output code....Ludovic Courtès 2016-05-31daemon: rounds: Keep the differing output if -K is given....Eelco Dolstra 2016-05-31daemon: Canonicalize gids to 0....Eelco Dolstra 2016-05-31daemon: check: Keep the differing output if -K is given....Eelco Dolstra 2016-05-31daemon: check: Fix "failed to produce output path"....Eelco Dolstra 2016-05-31daemon: check: Fix assertion failure when some outputs are missing....Eelco Dolstra 2016-05-31daemon: When repairing, rebuild if there is no substituter.Eelco Dolstra 2016-05-31daemon: Fix --repair failure on multiple-output derivations....Eelco Dolstra 2016-05-31daemon: ~PathLocks(): Handle exceptions....Eelco Dolstra 2016-05-31daemon: Handle /tmp being a symlink....Eelco Dolstra 2016-05-24build: Use "%D%" in Makefile fragments....Mathieu Lirzin 2016-04-21build: Move 'Makefile' fragments to subdirectories....Mathieu Lirzin 2016-03-16build: Default to "https://mirror.hydra.gnu.org/" for substitutes....Ludovic Courtès