aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cppi)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix licenses))

(define-public cppi
  (package
    (name "cppi")
    (version "1.18")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/cppi/cppi-"
                                 version ".tar.xz"))
             (sha256
              (base32
               "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/cppi/")
    (synopsis "Indent C preprocessor directives to reflect nesting and more")
    (description
     "GNU Cppi processes C source code files to properly indent the
preprocessor directives to reflect their nesting.  It also performs other
standardizations, such as correcting the number of spaces between directives
and the text following them.")
    (license gpl3+)))
, maven-compat): Install from pom file. Julien Lepiller 2020-07-17gnu: java-plexus-archiver: Update to 4.2.2....* gnu/packages/java.scm (java-plexus-archiver): Update to 4.2.2. (java-plexus-container-default, java-commons-compress) (java-geronimo-xbean-reflect): Install from pom file. (java-guava): Install from pom [source]: Use git source instead of generated source jar. * gnu/packages/java-compression.scm (java-xz, java-iq80-snappy): Install from pom. Julien Lepiller 2020-05-17gnu: java-xz: Remove duplicate definition....* gnu/packages/java.scm (java-xz): Remove duplicate variable. (java-plexus-archiver)[inputs]: Use java-xz. * gnu/packages/java-compression.scm (java-tukaani-xz): Rename to java-xz. Julien Lepiller 2020-03-13gnu: java-iq80-snappy: Don't use unstable tarball....* gnu/packages/java-compression.scm (java-iq80-snappy)[source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2020-03-13gnu: java-snappy@1.0: Don't use unstable tarball....* gnu/packages/java-compression.scm (java-snappy-1)[name]: Restate. [source]: Use GIT-FETCH and GIT-FILE-NAME. Tobias Geerinckx-Rice 2020-03-12gnu: java-snappy: Don't use unstable tarball....* gnu/packages/java-compression.scm (java-snappy)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Add ‘make-git-checkout-writable’ phase. Tobias Geerinckx-Rice 2020-03-12gnu: java-snappy: Update to 1.1.7.3....* gnu/packages/java-compression.scm (java-snappy): Update to 1.1.7.3. Tobias Geerinckx-Rice ckages/lego.scm, gnu/packages/less.scm, gnu/packages/libusb.scm, gnu/packages/linux.scm, gnu/packages/lirc.scm, gnu/packages/lisp-xyz.scm, gnu/packages/llvm.scm, gnu/packages/logging.scm, gnu/packages/lolcode.scm, gnu/packages/lua.scm, gnu/packages/lxde.scm, gnu/packages/lxqt.scm, gnu/packages/machine-learning.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/maths.scm, gnu/packages/maven.scm, gnu/packages/mes.scm, gnu/packages/messaging.scm, gnu/packages/monitoring.scm, gnu/packages/mpd.scm, gnu/packages/music.scm, gnu/packages/networking.scm, gnu/packages/node-xyz.scm, gnu/packages/ocaml.scm, gnu/packages/ocr.scm, gnu/packages/onc-rpc.scm, gnu/packages/opencl.scm, gnu/packages/opencog.scm, gnu/packages/pantheon.scm, gnu/packages/password-utils.scm, gnu/packages/patchutils.scm, gnu/packages/pdf.scm, gnu/packages/perl6.scm, gnu/packages/phabricator.scm, gnu/packages/popt.scm, gnu/packages/printers.scm, gnu/packages/prolog.scm, gnu/packages/protobuf.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/qt.scm, gnu/packages/radio.scm, gnu/packages/rails.scm, gnu/packages/rdf.scm, gnu/packages/rednotebook.scm, gnu/packages/rpc.scm, gnu/packages/rsync.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/security-token.scm, gnu/packages/selinux.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/shellutils.scm, gnu/packages/simh.scm, gnu/packages/sml.scm, gnu/packages/ssh.scm, gnu/packages/statistics.scm, gnu/packages/stenography.scm, gnu/packages/sync.scm, gnu/packages/syncthing.scm, gnu/packages/synergy.scm, gnu/packages/telephony.scm, gnu/packages/terminals.scm, gnu/packages/tex.scm, gnu/packages/texinfo.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tmux.scm, gnu/packages/tor.scm, gnu/packages/toys.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. Ludovic Courtès 2020-04-02gnu: proof-general: Update home-page....* gnu/packages/coq.scm (proof-general):[home-page] update to proofgeneral.github.io Signed-off-by: Marius Bakke <mbakke@fastmail.com> John Soo 2020-04-02gnu: proof-general: Update to 4.4....* gnu/packages/coq.scm (proof-general): Update to 4.4. [source]: Change to GIT-FETCH. [arguments]: Remove obsolete substitutions. Signed-off-by: Marius Bakke <mbakke@fastmail.com> John Soo 2020-03-05gnu: coq-mathcomp: Update home page URI....* gnu/packages/coq.scm (coq-mathcomp)[home-page]: Update URI. Björn Höfling 2020-01-07gnu: coq-stdpp: Reword comment....* gnu/packages/coq.scm (coq-stdpp)[arguments]: Reword comment about tests being executed during build phase, to read more fluently. Brett Gilio 2020-01-07gnu: coq-stdpp: Update to 1.2.1....* gnu/packages/coq.scm (coq-stdpp): Update to 1.2.1. [arguments]: Remove redundant COQLIB variable. Brett Gilio 2020-01-07gnu: coq-bignums: Fix comment spacing....* gnu/packages/coq.scm (coq-bignums)[arguments]: Fix comment spacing after disabling test phase. Brett Gilio 2020-01-07gnu: coq-bignums: Update to 8.10.0....* gnu/packages/coq.scm (coq-bignums): Update to 8.10.0. Brett Gilio 2020-01-06gnu: coq-equations: Update to 1.2.1....* gnu/packages/coq.scm (coq-equations): Update to 1.2.1. [arguments]: Replace configure phase to run configure shell script. Remove redundant COQLIB. Brett Gilio 2020-01-06gnu: coq-interval: Update to 3.4.1....* gnu/packages/coq.scm (coq-interval): Update to 3.4.1. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake. Brett Gilio 2020-01-06gnu: coq-coquelicot: Truncate home-page....* gnu/packages/coq.scm (coq-coquelicot)[home-page]: Truncate home-page. Brett Gilio 2020-01-06gnu: coq-coquelicot: Update to 3.0.3....* gnu/packages/coq.scm (coq-coquelicot): Update to 3.0.3. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake. Brett Gilio 2020-01-06gnu: coq-gappa: Use HTTPS home page URI....* gnu/packages/coq.scm (coq-gappa)[home-page]: Use HTTPS URI. Brett Gilio 2020-01-06gnu: coq-gappa: Update to 1.4.2....* gnu/packages/coq.scm (coq-gappa): Update to 1.4.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake, as well as campl5 for parsing. [propagated-inputs]: coq-gabba now depends on coq-flocq. [arguments]: Temporarily disable check chase until error resolution is identified. Brett Gilio 2020-01-06gnu: coq-flocq: Use HTTPS home page URI....* gnu/packages/coq.scm (coq-flocq)[home-page]: Use HTTPS URI. Brett Gilio 2020-01-06gnu: coq-flocq: Update to 3.2.0....* gnu/packages/coq.scm (coq-flocq): Update to 3.2.0. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake for remake. [arguments]: Add remove-failing-examples phase to work around union error. Brett Gilio 2020-01-06gnu: coq: Reword several comments....* gnu/packages/coq.scm (coq): Reword several comments to improve readability. Brett Gilio 2020-01-06gnu: coq: Update to 8.10.2....* gnu/packages/coq.scm (coq): Update to 8.10.2. [inputs]: Replace lablgtk with lablgtk3. [arguments]: Remove remove-lablgtk-references phase, as it no longer appears to be necessary. Brett Gilio 2020-01-05gnu: coq-mathcomp: Update to 1.10.0....* gnu/packages/coq.scm (coq-mathcomp): Update to 1.10.0. [arguments]: Modify comment about tests. Remove redundant setting of COQLIB environment variable. Brett Gilio 2019-12-12gnu: coq: Split coqide....* gnu/packages/coq.scm (coq)[outputs]: Add "ide" output. Julien Lepiller 2019-11-25gnu: coq-bignums: Don't use unstable tarball....* gnu/pacakges/coq.scm (coq-bignums)[source]: Download using git-fetch. Efraim Flashner