aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cpio)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cpio
  (package
    (name "cpio")
    (version "2.15")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/cpio/cpio-"
                                 version ".tar.bz2"))
             (sha256
              (base32
               "1nvmj2mc3nagpig75sgzvkqgzg1p01wgnlw54v4ix6ijgjwi0xlk"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 ;; Remove superfluous declaration that trips GCC 10.
                 (substitute* "src/global.c"
                   (("char \\*program_name;")
                    ""))))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/cpio/")
    (synopsis "Manage cpio and tar file archives")
    (description
     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
many formats are supported, including legacy formats.  The format is
determined automatically by the program and is handled appropriately.
Furthermore, the location of the archive is not important.  It can be another
file on the drive, a tape, or data on a pipe.")
    (license gpl3+)))
lip): Update to 1.8.2. Marius Bakke 2021-12-26gnu: gammastep: Update to 2.0.8....* gnu/packages/xdisorg.scm (gammastep): Update to 2.0.8. [inputs, native-inputs]: Remove labels. Nicolas Goaziou 2021-12-18gnu: rofi: Remove input labels....* gnu/packages/xdisorg.scm (rofi)[native-inputs, inputs]: Remove input labels. Tobias Geerinckx-Rice 2021-12-18gnu: rofi: Update to 1.7.2....* gnu/packages/xdisorg.scm (rofi): Update to 1.7.2. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-12-17gnu: bemenu: Update to 0.6.4....* gnu/packages/xdisorg.scm (bemenu): Update to 0.6.4. Tobias Geerinckx-Rice 2021-12-13gnu: Further simplify package inputs....This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.) Ludovic Courtès 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus 2021-11-30gnu: rxvt-unicode: Update to 9.30....* gnu/packages/xdisorg.scm (rxvt-unicode): Update to 9.30. Tobias Geerinckx-Rice 2021-11-27gnu: rxvt-unicode: Update to 9.29....* gnu/packages/xdisorg.scm (rxvt-unicode): Update to 9.29. [arguments]: Don't explicitly return #t from phases. [inputs]: Add libptytty. Tobias Geerinckx-Rice 2021-11-23Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-19gnu: jgmenu: Update to 4.4.0....* gnu/packages/xdisorg.scm (jgmenu): Update to 4.4.0. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> jgart 2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-15gnu: scrot: Update to 1.7....* gnu/packages/xdisorg.scm (scrot): Update to 1.7. [inputs]: Add libbsd. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Tanguy Le Carrour