aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cpio)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cpio
  (package
    (name "cpio")
    (version "2.15")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/cpio/cpio-"
                                 version ".tar.bz2"))
             (sha256
              (base32
               "1nvmj2mc3nagpig75sgzvkqgzg1p01wgnlw54v4ix6ijgjwi0xlk"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 ;; Remove superfluous declaration that trips GCC 10.
                 (substitute* "src/global.c"
                   (("char \\*program_name;")
                    ""))))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/cpio/")
    (synopsis "Manage cpio and tar file archives")
    (description
     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
many formats are supported, including legacy formats.  The format is
determined automatically by the program and is handled appropriately.
Furthermore, the location of the archive is not important.  It can be another
file on the drive, a tape, or data on a pipe.")
    (license gpl3+)))
4-04-09gnu: nyxt: Update to 3.11.6....Andre A. Gomes 2024-04-05gnu: Add edbrowse....B. Wilson 2024-03-20Merge remote-tracking branch 'savannah/master' into gnome-team...Christopher Baines 2024-03-20gnu: nyxt: Update to 3.11.5....Andre A. Gomes 2024-03-17gnu: lagrange: Update to 1.17.6....Nicolas Goaziou 2024-03-16Merge remote-tracking branch 'savannah/master' into gnome-team...Christopher Baines 2024-03-14gnu: tinmop: Update to 0.9.9.141421356....cage 2024-03-11gnu: nyxt: Update to 3.11.4....Andre A. Gomes 2024-02-25Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-02-21gnu: nyxt: Update to 3.11.3....Andre A. Gomes 2024-02-13Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-02-05gnu: nyxt: Update to 3.11.2....Andre A. Gomes 2024-02-03Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-01-24gnu: nyxt: Update to 3.11.1....Andre A. Gomes 2024-01-14gnu: qutebrowser: Update to 3.1.0....Herman Rimm 2024-01-14Merge branch 'master' into gnome-teamLiliana Marie Prikler 2024-01-10gnu: nyxt: Update to 3.11.0....Andre A. Gomes 2024-01-01Merge branch 'master' into gnome-teamLiliana Marie Prikler 2023-12-25gnu: Adjust to removing ed.scm and nano.scm...Efraim Flashner 2023-12-20Merge branch 'master' into gnome-teamLiliana Marie Prikler 2023-12-18Merge branch 'master' into wip-webkitLiliana Marie Prikler 2023-12-08gnu: Make webkitgtk-next the new webkitgtk....Liliana Marie Prikler 2023-12-03Merge branch 'master' into HEAD...Liliana Marie Prikler 2023-11-19Merge branch 'master' into gnome-team...Liliana Marie Prikler 2023-11-15gnu: nyxt: Update to 3.9.2....Andre A. Gomes 2023-11-04Merge branch 'master' into gnome-team...Liliana Marie Prikler