aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cpio)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cpio
  (package
    (name "cpio")
    (version "2.15")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/cpio/cpio-"
                                 version ".tar.bz2"))
             (sha256
              (base32
               "1nvmj2mc3nagpig75sgzvkqgzg1p01wgnlw54v4ix6ijgjwi0xlk"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 ;; Remove superfluous declaration that trips GCC 10.
                 (substitute* "src/global.c"
                   (("char \\*program_name;")
                    ""))))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/cpio/")
    (synopsis "Manage cpio and tar file archives")
    (description
     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
many formats are supported, including legacy formats.  The format is
determined automatically by the program and is handled appropriately.
Furthermore, the location of the archive is not important.  It can be another
file on the drive, a tape, or data on a pipe.")
    (license gpl3+)))
3-23gnu: bitcoin-core: Add 0.21.0....* gnu/packages/finance.scm (bitcoin-core): Rename to … (bitcoin-core-0.21): … this, and update to 0.21. (bitcoin-core-0.20): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> ZmnSCPxj 2021-03-22gnu: python-duniterpy: Update to 0.62.0....* gnu/packages/finance.scm (python-duniterpy): Update to 0.62.0. Nicolas Goaziou 2021-03-10gnu: electron-cash: Update to 4.2.4....* gnu/packages/finance.scm (electron-cash): Update to 4.2.4. Tobias Geerinckx-Rice 2021-02-11gnu: python-duniterpy: Update to 0.61.0....* gnu/packages/finance.scm (python-duniterpy): Update to 0.61.0. Nicolas Goaziou 2021-01-27gnu: python-xyz: Move a few modules to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-pep517): Inherit from python-pep517-bootstrap. Remove the inherited common fields. (python-poetry-core, python-wheel) (python-toml): Move to ... * gnu/packages/python-build.scm: ... here, a new module. (python-pep517-bootstrap): New package. * gnu/local.mk (GNU_SYSTEM_MODULES): Register the new module. Maxim Cournoyer 2021-01-14gnu: opensp: Move package to (gnu packages xml)....* gnu/packages/finance.scm (opensp): Move to... * gnu/packages/xml.scm (opensp): ... here. Maxim Cournoyer 2021-01-08gnu: monero-gui: Update to 0.17.1.9....* gnu/packages/finance.scm (monero-gui): Update to 0.17.1.9. [source]: Fetch submodules. Add snippet to remove embedded monero sources. Guillaume Le Vaillant 2021-01-08gnu: monero: Update to 0.17.1.9....* gnu/packages/finance.scm (monero): Update to 0.17.1.9. Guillaume Le Vaillant 2020-12-31gnu: bitcoin-unlimited: Fix time specific test failure....* gnu/packages/finance.scm (bitcoin-unlimited)[arguments]: Patch test to fix time specific failure. Christopher Baines 2020-12-31gnu: monero-gui: Update to 0.17.1.8....* gnu/packages/finance.scm (monero-gui): Update to 0.17.1.8. Guillaume Le Vaillant 2020-12-31gnu: monero: Update to 0.17.1.8....* gnu/packages/finance.scm (monero): Update to 0.17.1.8. Guillaume Le Vaillant 2020-12-28gnu: electrum: Update to 4.0.9....* gnu/packages/finance.scm (electrum): Update to 4.0.9. [inputs]: Remove python-pyaes, python-pysocks, python-sip, python-pbkdf2, python-requests, python-jsonrpclib-pelix and python-ecdsa, python-dnspython-1.16. Add python-dnspython, python-bitstring, python-attrs, python-cryptography, python-qdarkstyle and libsecp256k1. [arguments]: Copy 'use-libsecp256k1-input phase from (electron-cash) to #:phases to fix runtime lookup of libsecp256k1 library. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> John Doe 2020-12-23gnu: electron-cash: Update to 4.2.3....* gnu/packages/finance.scm (electron-cash): Update to 4.2.3. Tobias Geerinckx-Rice 2020-12-14gnu: python-dnspython: Update to 2.0.0....* gnu/packages/python-xyz.scm (python-dnspython): Update to 2.0.0. [source]: Download from pypi. [native-inputs]: Add unzip. [home-page]: Prefer https. (python-dnspython-1.16): (python2-dnspython-1.16): New variables. * gnu/packages/ebook.scm (calibre): * gnu/packages/web.scm (linkchecker): Use python2-dnspython-1.16. * gnu/packages/finance.scm (electrum): Use python-dnspython-1.16. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Kyle Meyer 2020-12-13gnu: monero-gui: Update to 0.17.1.7....* gnu/packages/finance.scm (monero-gui): Update to 0.17.1.7. Guillaume Le Vaillant 2020-12-13gnu: monero: Update to 0.17.1.7....* gnu/packages/finance.scm (monero): Update to 0.17.1.7. Guillaume Le Vaillant 2020-12-09gnu: monero-gui: Update to 0.17.1.6....* gnu/packages/finance.scm (monero-gui): Update to 0.17.1.6. Guillaume Le Vaillant 2020-12-09gnu: monero: Update to 0.17.1.6....* gnu/packages/finance.scm (monero): Update to 0.17.1.6. Guillaume Le Vaillant 2020-12-08gnu: trezord: Update to 2.0.30....* gnu/packages/finance.scm (trezord): Update to 2.0.30. Signed-off-by: Christopher Baines <mail@cbaines.net> Martin Becze 2020-12-06gnu: Add hledger-web....* gnu/packages/finance.scm (hledger-web): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi 2020-11-26gnu: electron-cash: Update to 4.2.2....* gnu/packages/finance.scm (electron-cash): Update to 4.2.2. [arguments]: Update 'use-libsecp256k1-input' phase. Guillaume Le Vaillant 2020-11-26gnu: monero-gui: Update to 0.17.1.5....* gnu/packages/finance.scm (monero-gui): Update to 0.17.1.5. [arguments]: Remove CMAKE_PREFIX_PATH from 'configure-flags'. Guillaume Le Vaillant 2020-11-26gnu: monero: Update to 0.17.1.5....* gnu/packages/finance.scm (monero): Update to 0.17.1.5. Tobias Geerinckx-Rice 2020-11-25gnu: hledger: Downgrade to 1.14.2....* gnu/packages/finance.scm (hledger): Downgrade to 0.14.2. [inputs, native-inputs]: Replace with what is generated by guix import. Signed-off-by: Leo Famulari <leo@famulari.name> Carlo Holl 2020-11-18gnu: bitcoin-core: Update to 0.20.1....* gnu/packages/finance.scm (bitcoin-core): Update to 0.20.1. [source]: Remove obsolete patch. [native-inputs]: Add autoconf, automake and libtool. [inputs]: Remove protobuf. [arguments]: Add "set-no-git-flag" phase to indicate the build is not taking place within a git repository. * gnu/packages/patches/bitcoin-core-python-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Christopher Baines <mail@cbaines.net> Simon South 2020-11-14gnu: python-duniterpy: Update to 0.60.1....* gnu/packages/finance.scm (python-duniterpy): Update to 0.60.1. Tobias Geerinckx-Rice 2020-11-11gnu: monero-gui: Update to 0.17.1.4....* gnu/packages/finance.scm (monero-gui): Update to 0.17.1.4. [inputs]: Remove qtlocation and qtmultimedia. [arguments]: Remove custom CMAKE_BUILD_TYPE, and set CMAKE_PREFIX_PATH to empty string in 'configure-flags' to fix a "file name too long" error during build. Remove patching of "monero/src/version.cpp.in" in 'fix-build' phase. Guillaume Le Vaillant 2020-11-09gnu: monero: Update to 0.17.1.3....* gnu/packages/finance.scm (monero): Update to 0.17.1.3. Tobias Geerinckx-Rice