aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cpio)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cpio
  (package
    (name "cpio")
    (version "2.15")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/cpio/cpio-"
                                 version ".tar.bz2"))
             (sha256
              (base32
               "1nvmj2mc3nagpig75sgzvkqgzg1p01wgnlw54v4ix6ijgjwi0xlk"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 ;; Remove superfluous declaration that trips GCC 10.
                 (substitute* "src/global.c"
                   (("char \\*program_name;")
                    ""))))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/cpio/")
    (synopsis "Manage cpio and tar file archives")
    (description
     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
many formats are supported, including legacy formats.  The format is
determined automatically by the program and is handled appropriately.
Furthermore, the location of the archive is not important.  It can be another
file on the drive, a tape, or data on a pipe.")
    (license gpl3+)))
:16:59 +0100'>2017-01-16gnu: zathura-cb: Update to 0.1.6....Marius Bakke 2017-01-16gnu: zathura: Update to 0.3.7....Marius Bakke 2017-01-15gnu: mupdf: Fix CVE-2016-{10132,10133} in bundled mujs....Marius Bakke 2017-01-13Merge branch 'master' into python-testsLeo Famulari 2017-01-11gnu: poppler: Update to 0.50.0....Efraim Flashner 2016-12-15gnu: python-reportlab: Fix tests....Marius Bakke 2016-12-04gnu: mupdf: Update to 1.10a....Marius Bakke 2016-11-30gnu: cairo: Eliminate graft....Marius Bakke 2016-11-29Merge branch 'master' into python-build-systemHartmut Goebel 2016-11-29gnu: cairo: Fix CVE-2016-9082....Efraim Flashner 2016-11-25Merge branch 'master' into python-build-systemLeo Famulari 2016-11-21gnu: Remove redundancy where mkdir-p <dir> is followed by install-file <file>......Petter