aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cpio)
  #:use-module (guix licenses)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public cpio
  (package
    (name "cpio")
    (version "2.15")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/cpio/cpio-"
                                 version ".tar.bz2"))
             (sha256
              (base32
               "1nvmj2mc3nagpig75sgzvkqgzg1p01wgnlw54v4ix6ijgjwi0xlk"))
             (modules '((guix build utils)))
             (snippet
              '(begin
                 ;; Remove superfluous declaration that trips GCC 10.
                 (substitute* "src/global.c"
                   (("char \\*program_name;")
                    ""))))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/cpio/")
    (synopsis "Manage cpio and tar file archives")
    (description
     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
many formats are supported, including legacy formats.  The format is
determined automatically by the program and is handled appropriately.
Furthermore, the location of the archive is not important.  It can be another
file on the drive, a tape, or data on a pipe.")
    (license gpl3+)))
0.14.0....Tobias Geerinckx-Rice 2018-09-21gnu: filezilla: Update to 3.37.1....Tobias Geerinckx-Rice 2018-09-21gnu: libfilezilla: Update to 0.13.2....Tobias Geerinckx-Rice 2018-09-12gnu: libfilezilla: Update to 0.13.1....Tobias Geerinckx-Rice 2018-08-09gnu: lftp: Update to 4.8.4....Marius Bakke 2018-07-03gnu: Add vsftpd....Danny Milosavljevic 2018-06-11gnu: libfilezilla: Update to 0.12.3....Tobias Geerinckx-Rice 2018-05-17Merge branch 'master' into core-updatesMark H Weaver 2018-05-15gnu: filezilla: Update to 0.12.2....Tobias Geerinckx-Rice 19:47:38 +0200'>2018-04-30gnu: meson: Update to 0.46.0....Marius Bakke 2018-04-25Merge branch 'master' into stagingMarius Bakke 2018-04-21gnu: Add osc....Tomáš Čech 2018-04-16Merge branch 'master' into stagingMarius Bakke 2018-04-08gnu: Add bear....Fis Trivial 2018-03-22gnu: meson: Update to 0.45.1....Marius Bakke 2018-03-18Merge branch 'master' into stagingMarius Bakke 2018-03-17gnu: Fix common unquote typos....Tobias Geerinckx-Rice 2018-03-12gnu: meson: Update to 0.45.0....Marius Bakke 2018-03-12gnu: meson-for-build: Update to 0.44.0....Marius Bakke 2018-03-12gnu: meson: Don't wrap the meson executable....Marius Bakke 2018-03-07gnu: meson: Mark up description....Tobias Geerinckx-Rice 2017-12-12gnu: meson: Update to 0.44.0....Tobias Geerinckx-Rice