aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages cook)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (gnu packages bison)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages groff)
  #:use-module (gnu packages text-editors)
  #:use-module (guix build-system gnu))

(define-public cook
  (package
    (name "cook")
    (version "2.34")
    (source
     (origin
       (method url-fetch)
       (uri "http://fossies.org/linux/misc/old/cook-2.34.tar.gz")
       (sha256
        (base32
         "104saqnqql1l7zr2pm3f718fdky3ds8j07c6xvwrs1rfkhrw58yw"))))
    (build-system gnu-build-system)
    (arguments
     `(#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
       #:phases
       (modify-phases %standard-phases
         (add-before 'configure 'pre-conf
           (lambda _
             (substitute* (append '("common/env.c")
                                  (find-files "test" "\\.sh"))
               (("/bin/sh") (which "sh")))

             ;; Guix's binutils (because it wants bit-reproducable builds) is
             ;; is configured with the  --enable-deterministic-archives flag.
             ;; This means the timestamp of files appended to an ar archive
             ;; are automatically and silently mutated to 00:00 1 Jan 1970
             ;; which plays havoc with this test, for which correct timestamps
             ;; are very important. Adding the U flag undoes the effect of
             ;; --enable-deterministic-archives and allows this test to work
             ;; again.
             (substitute* "test/00/t0077a.sh"
               (("ar qc") "ar qcU"))

             ;; Guix builds have LC_ALL set to "en_US.utf8", which causes
             ;; `date` to use a 12-hour clock instead of 24h, which in turn
             ;; makes t0217a.sh fail because of unexpected date output.
             (substitute* "test/02/t0217a.sh"
               (("export TZ")
                "export TZ\nLC_ALL=POSIX\nexport LC_ALL"))

             (setenv "SH" (which "sh"))
             #t)))))
    (native-inputs (list bison-3.0
                         ;; For building the documentation:
                         groff
                         ;; For the tests:
                         sharutils
                         ;; One test wants rsh.  However there is no rsh server
                         ;; running in the build environment and so far as I'm
                         ;; aware, it cannot be started without root.
                         ;; This test is therefore just skipped.
                         ;; ("inetutils" ,inetutils)
                         ed))
    (home-page (string-append "https://web.archive.org/web/20140727122520/"
                              "http://miller.emu.id.au/pmiller/software/cook/"))
    (synopsis "Tool for constructing files")
    (description "Cook is a tool for constructing files.  It is given a set of
files to create, and recipes of how to create them.  In any non-trivial program
there will be prerequisites to performing the actions necessary to creating
any file, such as include files.  Cook provides a mechanism to define these.")
    (license gpl3+)))
cm?id=cc2e13baec21d561fb9f5a3c3edc4aeb0b1a0b8d'>gnu: hurd: Fix building libdde_linux26....* gnu/packages/hurd.scm (hurd)[arguments]: In phases `build-libdde-linux' and `install-goodies', also set ARCH=x86. Change-Id: I2e7f14afda03c9e21ba9c3b24e195a00ae141701 Janneke Nieuwenhuizen 2024-08-31Revert "gnu: hurd: Add gnumach-headers as native input."...gnumach-headers[-cross] are contained in the toolchain; it was only the `include/mach/machine' symlink that was missing. This reverts commit 2dd16f46766997c0b3e4ee973ce6e792a4d84fcb. Janneke Nieuwenhuizen 2024-08-31gnu: hurd: Add gnumach-headers as native input....This provides the include/mach/machine/mach_i386.h. * gnu/packages/hurd.scm (hurd)[native-inputs]: Add gnumach-headers, or gnumach-headers-cross when cross-building. [arguments]: Remove #t from phases. Change-Id: Id57e0cf184c7793be52192bdc5587c6e6ef2a312 Janneke Nieuwenhuizen 2024-08-31gnu: gnumach-headers: Also build and install new `machine' symlink....This is a follow-up to commit fe83aaf28369dd0548be6ced8a1f007eede01ded gnu: glibc/hurd: Update to 2.38. and fixes No rule to make target 'mach/machine/mach_i386.h', needed by 'trivfs_server.o'. Stop. * gnu/packages/hurd.scm (gnumach-headers)[arguments]: In phase `install' also build `install-data-hook'. Change-Id: I1985a17fa4a3fb789fe75791c2f9f4c8fd225d9a Janneke Nieuwenhuizen 2024-08-31gnu: dde-sources: Update to 066797b576....This fixes the build with reinforced build options: condvar.c: In function ‘ddekit_condvar_init’: condvar.c:16:19: error: old-style function definition [-Werror=old-style-definition] 16 | ddekit_condvar_t *ddekit_condvar_init() { | ^~~~~~~~~~~~~~~~~~~ * gnu/packages/hurd.scm (dde-sources): Update to 066797b576ebf8364ad157f50bef2a655597deeb. Change-Id: Icf6f97897852e21dfcf9b77629fde4ce6a7d1469 Janneke Nieuwenhuizen 2024-08-31gnu: hurd: Prettify origin file names....* gnu/packages/hurd.scm (hurd-headers): Drop “v” from ‘version’ string. (dde-sources): Strip COMMIT in ‘file-name’ field. (rumpkernel)[source]: Pass VERSION rather than COMMIT to ‘git-file-name’. Change-Id: I403048d5ba79ef410383c567157aca416843a529 Ludovic Courtès 2024-08-31gnu: hurd-headers: Update to v0.9.git20231217....* gnu/packages/hurd.scm (hurd-headers): Update to v0.9.git20231217. Change-Id: I1d9739ba912e425e66accfcb56a91ac8efc4fe7c Janneke Nieuwenhuizen 2024-08-31gnu: gnumach-headers: Update to v1.8+git20230410....* gnu/packages/hurd.scm (gnumach-headers): Update to v1.8+git20230410. Change-Id: I2ca1efb8610bbd2fa85b44c60ae065f0323b552c Janneke Nieuwenhuizen