;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages convmv)
  #:use-module (gnu packages)
  #:use-module (gnu packages perl)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public convmv
  (package
    (name "convmv")
    (version "2.05")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://www.j3e.de/linux/convmv/convmv-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "19hwv197p7c23f43vvav5bs19z9b72jzca2npkjsxgprwj5ardjk"))))
    (build-system gnu-build-system)
    (arguments
     `(#:test-target "test"
       #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
       #:phases
       (modify-phases %standard-phases
         (delete 'bootstrap)
         (delete 'configure)
         (add-before 'check 'unpack-testsuite
           (lambda _
             (invoke "tar" "xf" "testsuite.tar")
             (patch-shebang "suite/dotests.sh")
             (patch-shebang "suite/parsable_tester.pl")
             #t)))))
    (inputs
     (list perl))
    (synopsis "Convert filenames between character sets")
    (description
     "convmv is a file renamer, that converts between different encodings,
e.g. from ISO-8859-1 to UTF-8.  It is particularly usefuls for files with
names, that display incorrectly.")
    (license (list gpl2 gpl3))
    (home-page "https://www.j3e.de/")))
AV server") (description "Radicale is a CalDAV and CardDAV server for UNIX-like platforms. Calendars and address books are available for both local and remote access, possibly limited through authentication policies. They can be viewed and edited by calendar and contact clients on mobile phones or computers. Radicale intentionally does not fully comply with the CalDAV and CardDAV RFCs. Instead, it supports the CalDAV and CardDAV implementations of popular clients.") (home-page "https://radicale.org/") (license gpl3+))) (define-public xandikos (package (name "xandikos") (version "0.2.8") (source (origin (method url-fetch) (uri (pypi-uri "xandikos" version)) (sha256 (base32 "00ghmzcc37b17pp0r6d9v5vpxmz500kzxqj1k9ppcjhbbpvp9w8n")))) (build-system python-build-system) (propagated-inputs (list python-aiohttp python-defusedxml python-dulwich python-icalendar python-jinja2 python-multidict)) (home-page "https://www.xandikos.org/") (synopsis "Lightweight CalDAV/CardDAV server") (description "Xandikos is a lightweight yet complete CardDAV/CalDAV server that backs onto a Git repository. Features: @itemize @item Easy to set up @item Share calendars (events, todo items, journal entries) via CalDAV and contacts (vCard) via CardDAV @item Automatically keep history and back up changes in Git @item Supports synchronization extensions for CalDAV/CardDAV for quick and efficient syncing @item Automatically keep history and back up @item Works with all tested CalDAV and CardDAV clients @end itemize") (license gpl3+))) (define-public vdirsyncer (package (name "vdirsyncer") (version "0.19.2") (source (origin (method url-fetch) (uri (pypi-uri name version)) (sha256 (base32 "1fl21m10ghrpmkqa12g0qri99cxk9879pkb60jd4b4w2mgp8q1gx")))) (build-system pyproject-build-system) (arguments (list #:test-flags '(list "-k" "not test_request_ssl") #:phases #~(modify-phases %standard-phases (add-after 'unpack 'patch-version-call (lambda _ (substitute* "docs/conf.py" (("^release.*") (string-append "release = '" #$version "'\n")))))))) (native-inputs (list python-setuptools python-setuptools-scm python-sphinx python-wheel ;; Required for testing python-aioresponses python-hypothesis python-trustme python-pytest python-pytest-asyncio python-pytest-cov python-pytest-httpserver radicale)) (inputs (list python-aiohttp python-aiostream python-atomicwrites python-click python-click-log python-requests python-requests-toolbelt)) (synopsis "Synchronize calendars and contacts") (description "Vdirsyncer synchronizes your calendars and addressbooks between two storage locations. The most popular purpose is to synchronize a CalDAV or CardDAV server with a local folder or file. The local data can then be accessed via a variety of programs, none of which have to know or worry about syncing to a server.") (home-page "https://github.com/pimutils/vdirsyncer") (license bsd-3)))