aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2023 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages conky)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages image)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages lua)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages pulseaudio)
  #:use-module (gnu packages xorg))

(define-public conky
  (package
    (name "conky")
    (home-page "https://github.com/brndnmtthws/conky")
    (version "1.19.8")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url home-page)
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1g712cw2nzd2qvgdmyvazyda0znyqzg6yckg98ss203fggwp93vj"))))
    (build-system cmake-build-system)
    (arguments
     `(#:configure-flags
       (list "-DRELEASE=true"
             "-DBUILD_PULSEAUDIO=ON"
             "-DBUILD_WLAN=ON"
             "-DBUILD_TESTS=ON")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'add-freetype-to-search-path
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "cmake/ConkyPlatformChecks.cmake"
               (("set\\(INCLUDE_SEARCH_PATH")
                (string-append
                 "set(INCLUDE_SEARCH_PATH "
                 (assoc-ref inputs "freetype") "/include/freetype2 ")))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin")))
               (install-file "src/conky" bin))
             #t)))))
    (inputs
     (list freetype
           imlib2
           libx11
           libxdamage
           libxext
           libxft
           libxi
           libxinerama
           pulseaudio
           lua
           ncurses
           curl
           wireless-tools))
    (native-inputs
     (list pkg-config))
    (synopsis "Lightweight system monitor for X")
    (description
     "Conky is a lightweight system monitor for X that displays operating
system statistics (CPU, disk, and memory usage, etc.) and more on the
desktop.")
    (license license:gpl3+)))
ges/tex.scm guix/build-system/asdf.scm guix/build/emacs-build-system.scm guix/profiles.scm Marius Bakke 2021-05-04gnu: sequoia: Update to 1.1.0....* gnu/packages/sequoia.scm (sequoia): Update to 1.1.0. [arguments]: Remove phase "package", add phases "fix-rand-dependency" and "fix-permissions". Hartmut Goebel 2021-03-24Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2021-03-22gnu: sequoia4pEp: Adjust inputs....* gnu/packages/sequoia.scm (sequoia4pEp)[arguments]: Override inherited cargo-inputs, cargo-development-inputs. Replace inherited 'unpin-deps phase. Efraim Flashner 2021-03-22gnu: sequoia4pEp: Move to sequoia.scm....Don't have cross module package inheritance. * gnu/packages/pep.scm (sequoia4pEp): Move to ... * gnu/packages/sequoia.scm (sequoia4pEp): ... here. Hide package. Efraim Flashner 2021-02-11gnu: sequoia: Use latest rust....* gnu/packages/sequoia.scm (sequoia)[arguments]: Use the latest (and only) rust. Maxim Cournoyer 2021-01-30gnu: rust-dirs-2: Drop minor version from name....* gnu/packages/crates-io.scm (rust-dirs-2): Drop minor version from name. (rust-dirs-1.0): (rust-term-0.6): * gnu/packages/rust-apps.scm (fd): * gnu/packages/sequoia.scm (sequoia): * gnu/packages/web.scm (castor): Apply renaming. Nicolas Goaziou 2021-01-08gnu: sequoia: Update to 1.0.0....* gnu/packages/sequoia.scm (sequoia): Update to 1.0.0. [arguments]{cargo-inputs}: Add rust-eax, rust-futures-util, rust-sha1collisiondetection, rust-socket2. Update rust-capnp, rust-capnp-rpc, rust-capnpc, rust-futures, rust-http,rust-hyper rust-hyper-tls, rust-tokio, rust-win-crypto-ng. Hartmut Goebel 2021-01-03gnu: rust-anyhow-1: Drop minor version from name....* gnu/packages/crates-io.scm (rust-anyhow-1): Drop minor version from name. (rust-codespan-reporting-0.9) (rust-swc-1) (rust-syn-1) (rust-thiserror-1) (rust-wasm-bindgen-webidl-0.2) (rust-svd-parser-0.9): Adjust accordingly. * gnu/packages/crates-gtk.scm (rust-glib-macros-0.10): Same. * gnu/packages/rust-apps.scm (fd): Same. * gnu/packages/sequoia.scm (sequoia): Same. Efraim Flashner 2020-12-02gnu: sequoia: Update to 0.20.0....* gnu/packages/sequoia.scm (sequoia): Update to 0.20.0. [cargo-inputs, cargo-development-inputs] Update dependencies. [phases]{unpin-deps}: Adjust path of file to substitute. {adjust-prefix} Rename to {fix-environment} and set another envormnet variable. {keep-SOURCE_DATE_EPOCH}: New phase. Hartmut Goebel 2020-10-12gnu: rust-flate2-1.0: Remove minor version from variable name....* gnu/packages/crates-io.scm (rust-flate2-1.0): Rename to rust-flate2-1. Arun Isaac 2020-10-12gnu: rust-percent-encoding-2.1: Remove minor version from variable name....* gnu/packages/crates-io.scm (rust-percent-encoding-2.1): Rename to rust-percent-encoding-2. Arun Isaac 2020-10-12gnu: rust-url-2.1: Remove minor version from variable name....* gnu/packages/crates-io.scm (rust-url-2.1): Rename to rust-url-2. Arun Isaac 2020-10-12gnu: rust-thiserror-1.0: Remove minor version from variable name....* gnu/packages/crates-io.scm (rust-thiserror-1.0): Rename to rust-thiserror-1. Arun Isaac