aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2023 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages conky)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages image)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages lua)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages pulseaudio)
  #:use-module (gnu packages xorg))

(define-public conky
  (package
    (name "conky")
    (home-page "https://github.com/brndnmtthws/conky")
    (version "1.19.8")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url home-page)
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1g712cw2nzd2qvgdmyvazyda0znyqzg6yckg98ss203fggwp93vj"))))
    (build-system cmake-build-system)
    (arguments
     `(#:configure-flags
       (list "-DRELEASE=true"
             "-DBUILD_PULSEAUDIO=ON"
             "-DBUILD_WLAN=ON"
             "-DBUILD_TESTS=ON")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'add-freetype-to-search-path
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "cmake/ConkyPlatformChecks.cmake"
               (("set\\(INCLUDE_SEARCH_PATH")
                (string-append
                 "set(INCLUDE_SEARCH_PATH "
                 (assoc-ref inputs "freetype") "/include/freetype2 ")))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin")))
               (install-file "src/conky" bin))
             #t)))))
    (inputs
     (list freetype
           imlib2
           libx11
           libxdamage
           libxext
           libxft
           libxi
           libxinerama
           pulseaudio
           lua
           ncurses
           curl
           wireless-tools))
    (native-inputs
     (list pkg-config))
    (synopsis "Lightweight system monitor for X")
    (description
     "Conky is a lightweight system monitor for X that displays operating
system statistics (CPU, disk, and memory usage, etc.) and more on the
desktop.")
    (license license:gpl3+)))
title='2020-04-12 13:34:59 -0700'>2020-04-12gnu: ocaml-qcheck: Fix grammar of "allows to check" to "checks"....* gnu/packages/ocaml (ocaml-qcheck): Fix grammar. Vagrant Cascadian 2020-04-04gnu: ocaml-menhir: Update to 20190626....* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20190626. Julien Lepiller 2020-03-21gnu: ocaml-sedlex: Use HTTPS home page....* gnu/packages/ocaml.scm (ocaml-sedlex)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-03-21gnu: ocaml-tsdl: Update to 0.9.7....* gnu/packages/ocaml.scm (ocaml-tsdl): Update to 0.9.7. [native-inputs]: Remove ocaml-ocb-stubblr. [inputs]: Remove ocaml-result. Tobias Geerinckx-Rice 2020-03-21gnu: ocaml-tsdl: Use HTTPS home page....* gnu/packages/ocaml.scm (ocaml-tsdl)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-03-19gnu: camlp5: Update home page....* gnu/packages/ocaml.scm (camlp5)[home-page]: Update. Tobias Geerinckx-Rice 2020-03-19gnu: camlzip: Update home page....* gnu/packages/ocaml.scm (camlzip)[home-page]: Update. Tobias Geerinckx-Rice 2020-03-19gnu: lablgtk: Update to 2.18.10....* gnu/packages/ocaml.scm (lablgtk): Update to 2.18.10. Tobias Geerinckx-Rice 2020-02-29gnu: ocaml-mccs: Use HTTPS home page....* gnu/packages/ocaml.scm (ocaml-mccs)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-02-23gnu: hevea: Update to 2.33....* gnu/packages/ocaml.scm (hevea): Update to 2.33. Tobias Geerinckx-Rice 2020-02-16gnu: camlp5: Update to 7.11....* gnu/packages/ocaml.scm (camlp5): Update to 7.11. Tobias Geerinckx-Rice 2020-01-28gnu: ocaml-ctypes: Don't use unstable tarball....* gnu/packages/ocaml.scm (ocaml-ctypes)[source]: Download using git-fetch. [arguments]: Add phase to make files writable. Efraim Flashner 2020-01-28gnu: ocaml-ocplib-endian: Don't use unstable tarball....* gnu/packages/ocaml.scm (ocaml-ocplib-endian)[source]: Download using git-fetch. Efraim Flashner 2020-01-28gnu: ocaml-lwt: Don't use unstable tarball....* gnu/packages/ocaml.scm (ocaml-lwt)[source]: Download using git-fetch. Efraim Flashner 2020-01-27gnu: ocaml: Switch to ocaml 4.09 by default....Bap and earley cannot be updated as they do not support 4.09 yet. Bap requires the janestreet packages, which cannot be upgraded as no version supports 4.09 and 4.07 at the same time. Moreover, newer versions of the janestreet packages have a different dependency graph, which will require a whole new set of packages. We cannot simply use package-with-ocaml4.07 on them. * gnu/packages/ocaml.scm (ocaml-sqlite3, ocaml-ppx-tools, ocaml-gen) (ocaml-sedlex, ocaml-pcre, ocaml-expect, ocaml-ezjsonm, ocaml-uri) (ocaml-piqilib, ocaml-piqi, ocaml-charinfo-width, ocaml-zed) (ocaml-lambda-term, ocaml-utop, ocaml-ppx-inline-test, ocaml-earley) (ocaml-merlin, ocaml-gsl, ocaml-gsl-1, ocaml-sexplib0, ocaml-parsexp) (ocaml-sexplib, ocaml-base, ocaml-stdio, ocaml-ppxlib, ocaml-ppx-compare) (ocaml-fieldslib, ocaml-variantslib, ocaml-ppx-fields-conv) (ocaml-ppx-sexp-conv, ocaml-ppx-variants-conv, ocaml-ppx-custom-printf) (ocaml-bin-prot, ocaml-ppx-hash, ocaml-ppx-enumerate, ocaml-ppx-bench) (ocaml-ppx-here, ocaml-ppx-typerep, ocaml-ppx-sexp-value) (ocaml-ppx-sexp-message, ocaml-ppx-pipebang, ocaml-ppx-optional) (ocaml-ppx-optcomp, ocaml-ppx-fail, ocaml-ppx-let, ocaml-ppx-assert) (ocaml-ppx-expect, ocaml-ppx-js-style, ocaml-ppx-typerep-conv) (ocaml-ppx-base, ocaml-ppx-bin-prot, ocaml-ppx-jane) (ocaml-splittable-random, ocaml-configurator, ocaml-spawn, ocaml-core) (ocaml-core-kernel, ocaml-odoc, ocaml-fftw3, ocaml-lacaml): Rename to ... (ocaml4.07-sqlite3, ocaml4.07-ppx-tools, ocaml4.07-gen, ocaml4.07-sedlex) (ocaml4.07-pcre, ocaml4.07-expect, ocaml4.07-ezjsonm, ocaml4.07-uri) (ocaml4.07-piqilib, ocaml4.07-piqi, ocaml4.07-charinfo-width) (ocaml4.07-zed, ocaml4.07-lambda-term, ocaml4.07-utop) (ocaml4.07-ppx-inline-test, ocaml4.07-earley, ocaml4.07-merlin) (ocaml4.07-gsl, ocaml4.07-gsl-1, ocaml4.07-sexplib0, ocaml4.07-parsexp) (ocaml4.07-sexplib, ocaml4.07-base, ocaml4.07-stdio, ocaml4.07-ppxlib) (ocaml4.07-ppx-compare, ocaml4.07-fieldslib, ocaml4.07-variantslib) (ocaml4.07-ppx-fields-conv, ocaml4.07-ppx-sexp-conv) (ocaml4.07-ppx-variants-conv, ocaml4.07-ppx-custom-printf) (ocaml4.07-bin-prot, ocaml4.07-ppx-hash, ocaml4.07-ppx-enumerate) (ocaml4.07-ppx-bench, ocaml4.07-ppx-here, ocaml4.07-ppx-typerep) (ocaml4.07-ppx-sexp-value, ocaml4.07-ppx-sexp-message) (ocaml4.07-ppx-pipebang, ocaml4.07-ppx-optional, ocaml4.07-ppx-optcomp) (ocaml4.07-ppx-fail, ocaml4.07-ppx-let, ocaml4.07-ppx-assert) (ocaml4.07-ppx-expect, ocaml4.07-ppx-js-style) (ocaml4.07-ppx-typerep-conv, ocaml4.07-ppx-base, ocaml4.07-ppx-bin-prot) (ocaml4.07-ppx-jane, ocaml4.07-splittable-random) (ocaml4.07-configurator, ocaml4.07-spawn, ocaml4.07-core) (ocaml4.07-core-kernel, ocaml4.07-odoc, ocaml4.07-fftw3) (ocaml4.07-lacaml): ... to this and use ocaml 4.07. (bap, unison): Use ocaml-4.07. * gnu/packages/bioinformatics.scm (pplacer): Use ocaml-4.07. Julien Lepiller 2020-01-27gnu: Add ocaml4.07-dune....* gnu/packages/ocaml.scm (ocaml4.07-dune): New variable. Julien Lepiller 2020-01-27gnu: Add ocaml4.07-lablgtk....* gnu/packages/ocaml.scm (ocaml4.07-lablgtk): New variable. (lablgtk)[properties]: Add variant. Julien Lepiller 2020-01-27gnu: ocambuild: Update to 0.14.0....* gnu/packages/ocaml.scm (ocamlbuild): Update to 0.14.0. [build-system]: Use ocaml-build-system. Julien Lepiller 2020-01-24gnu: ocaml-mmap: Fix spelling of "function"....* gnu/packages/ocaml (ocaml-mmap)[description]: Fix typo. Vagrant Cascadian 2020-01-23gnu: ocaml4.07-findlib: Fix building with ocaml 4.07....* gnu/packages/ocaml.scm (ocaml4.07-findlib): rename inputs to native-inputs. Julien Lepiller 2020-01-22gnu: ocaml-mmap: Use a source file-name....* gnu/packages/ocaml.scm (ocaml-mmap)[source]: Add file-name field. Efraim Flashner 2020-01-22gnu: Add ocaml4.07-findlib....* gnu/packages/ocaml.scm (ocaml4.07-findlib): New variable. Julien Lepiller 2020-01-22gnu: ocaml-lambda-term: Add missing dependencies....* gnu/packages/ocaml.scm (ocaml-lambda-term)[propagated-inputs]: Add ocaml-lwt-react. [inputs]: Add libev. Julien Lepiller 2020-01-22nu: Add ocaml-lwt-react....* gnu/packages/ocaml.scm (ocaml-lwt-react): New variable. Julien Lepiller 2020-01-21gnu: ocaml-markup: Update to 0.8.2....gnu/packages/ocaml.scm (ocaml-markup): Update to 0.8.2. Julien Lepiller 2020-01-21gnu: ocaml-lwt: Update to 5.1.1....* gnu/packages/ocaml.scm (ocaml-lwt): update to 5.1.1. Julien Lepiller 2020-01-21gnu: Add ocaml-mmap....* gnu/packages/ocaml.scm (ocaml-mmap): New variable. Julien Lepiller 2020-01-21gnu: ocaml-bisect-ppx: Update to 1.4.2....* gnu/packages/ocaml.scm (ocaml-bisect-ppx): Update to 1.4.2. Julien Lepiller 2020-01-21gnu: ocaml-qtest. Update to 2.10.1....* gnu/packages/ocaml.scm (ocaml-qtest): Update to 2.10.1. Julien Lepiller 2020-01-21gnu: ocaml-qcheck: Update to 0.12....* gnu/packages/ocaml.scm (ocaml-qcheck): Update to 0.12. Julien Lepiller 2020-01-21gnu: camlp5: Update to 7.10....* gnu/packages/ocaml.scm (camlp5): Upadte to 7.10. Julien Lepiller 2020-01-21gnu: opam: Update to 2.0.6....* gnu/pckages/ocaml.scm (opam): Update to 2.0.6. Julien Lepiller 2020-01-17gnu: Add ocaml-4.09....* gnu/packages/ocaml.scm (ocaml-4.09): New variable. [argument]: Remove the no longer needed configure phase. Julien Lepiller 2020-01-06gnu: Add lablgtk3....* gnu/packages/ocaml.scm (lablgtk3): New variable. Co-authored-by: Julien Lepiller <julien@lepiller.eu>. Brett Gilio 2020-01-06gnu: Add ocaml-cairo2....* gnu/packages/ocaml.scm (ocaml-cairo2): New variable. Co-authored-by: Julien Lepiller <julien@lepiller.eu>. Brett Gilio 2020-01-03gnu: Add ocaml-fftw3....* gnu/packages/ocaml.scm (ocaml-fftw3): New variable. Brett Gilio 2020-01-03gnu: Add ocaml-lacaml....* gnu/packages/ocaml.scm (ocaml-lacaml): New variable. Brett Gilio 2020-01-03gnu: ocaml-utop: Modify home-page....* gnu/packages/ocaml.scm (ocaml-utop)[home-page]: Change home-page to reflect permanent redirection. Brett Gilio 2020-01-03gnu: ocaml-utop: Update to 2.4.3....* gnu/packages/ocaml.scm (ocaml-utop): Update to 2.4.3. Brett Gilio