aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2023 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages conky)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages image)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages lua)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages pulseaudio)
  #:use-module (gnu packages xorg))

(define-public conky
  (package
    (name "conky")
    (home-page "https://github.com/brndnmtthws/conky")
    (version "1.19.8")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url home-page)
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1g712cw2nzd2qvgdmyvazyda0znyqzg6yckg98ss203fggwp93vj"))))
    (build-system cmake-build-system)
    (arguments
     `(#:configure-flags
       (list "-DRELEASE=true"
             "-DBUILD_PULSEAUDIO=ON"
             "-DBUILD_WLAN=ON"
             "-DBUILD_TESTS=ON")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'add-freetype-to-search-path
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "cmake/ConkyPlatformChecks.cmake"
               (("set\\(INCLUDE_SEARCH_PATH")
                (string-append
                 "set(INCLUDE_SEARCH_PATH "
                 (assoc-ref inputs "freetype") "/include/freetype2 ")))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin")))
               (install-file "src/conky" bin))
             #t)))))
    (inputs
     (list freetype
           imlib2
           libx11
           libxdamage
           libxext
           libxft
           libxi
           libxinerama
           pulseaudio
           lua
           ncurses
           curl
           wireless-tools))
    (native-inputs
     (list pkg-config))
    (synopsis "Lightweight system monitor for X")
    (description
     "Conky is a lightweight system monitor for X that displays operating
system statistics (CPU, disk, and memory usage, etc.) and more on the
desktop.")
    (license license:gpl3+)))
x/commit/gnu/packages/kde-pim.scm?id=86633b2218ea8a1eb3573cea5b76b49f71667eba'>gnu: Add kaddressbook....* gnu/packages/kde-pim.scm (kaddressbook): New variable. Hartmut Goebel 2020-03-19gnu: Add kdepim-runtime....* gnu/packages/kde-pim.scm (kdepim-runtime): New variable. * gnu/packages/patches/kdepim-runtime-Fix-missing-link-libraries.patch: New file. * gnu/local.mk: Add it. Hartmut Goebel 2020-03-19gnu: Add kdav....This is in kde-pim.scm since it explicitly offers the "KPimKDAV". * gnu/package/kde-pim.scm (kdav): New variable. Hartmut Goebel 2020-03-19gnu: Add kblog....* gnu/packages/kde-pim.scm (kblog): New variable. Hartmut Goebel 2020-03-19gnu: Add kmailcommon....* gnu/packages/kde-pim.scm (kmailcommon): New variable. Hartmut Goebel 2020-03-19gnu: Add kmessagelib....* gnu/packages/kde-pim.scm (kmessagelib): New variable. Hartmut Goebel 2020-03-19gnu: Add libksieve....* gnu/packages/kde-pim.scm (libksieve): New variable. * gnu/packages/patches/libksieve-Fix-missing-link-libraries.patch: New file. * gnu/local.mk: Add it. Hartmut Goebel 2020-03-08gnu: Reword and extend descriptions for some KDE packages....* gnu/packages/kde-multimedia.scm (libkcompatdisc)[description]: Extend. * gnu/packages/kde-pim.scm (akonadi-search, kalarmcal, kdemailimporter, kdepim-apps-libs, kidentitymanagement, kldap, kmailtransport, kmbox, kmime, kontactinterface, kpimtextedit)[description]: Reword and extend. (ktnef, kpimcommon, libkdepim)[synopsis, description]: Reword and extend. (kmailtransport)[synopsis]: Fix space. * gnu/packages/kde-systemtools.scm (khelpcenter)[description]: Extend. Hartmut Goebel 2020-03-06gnu: akonadi: Rename patch to fix guix lint warning about patch filename size....* gnu/packages/patches/akonadi-Revert-Make-installation-properly-relocatabl.patch: Rename to ... * gnu/packages/patches/akonadi-Revert-Make-installation-properly-relo.patch: ... this. * gnu/packages/kde-pim (akonadi) Update accordingly. * gnu/local.mk: Update accordingly. Vagrant Cascadian 2020-02-03gnu: Add kdepim-apps-libs....* gnu/packages/kde-pim.scm (kdepim-apps-libs): New variable. Hartmut Goebel 2020-02-03gnu: Add kpimcommon....* gnu/packages/kde-pim.scm (kpimcommon): New variable. Hartmut Goebel 2020-02-03gnu: Add kmailimporter....* gnu/packages/kde-pim.scm (kmailimporter): New variable. Hartmut Goebel 2020-02-03gnu: Add libkdepim....* gnu/packages/kde-pim.scm (libkdepim): New variable. Hartmut Goebel 2020-02-03gnu: Add kgpg....* gnu/packages/kde-utils.scm (kgpg): New variable. Hartmut Goebel 2020-02-03gnu: Add kleopatra....* gnu/packages/kde-utils.scm (kleopatra): New variable. Hartmut Goebel 2020-02-03gnu: Add libkleo....* gnu/packages/kde-pim.scm (libkleo): New variable. Hartmut Goebel 2020-02-03gnu: Add akonadi-calendar....* gnu/packages/kde-pim.scm (akonadi-calendar): New variable. Hartmut Goebel 2020-02-03gnu: Add kmailtransport....* gnu/packages/kde-pim.scm (kmailtransport): New variable. Hartmut Goebel 2020-02-03gnu: Add libkgapi....* gnu/packages/kde-pim.scm (libkgapi): New variable. Hartmut Goebel 2020-02-03gnu: Add kontactinterface....* gnu/packages/kde-pim.scm (kontactinterface): New variable. Hartmut Goebel 2020-02-03gnu: Add ksmtp....* gnu/packages/kde-pim.scm (ksmtp): New variable. Hartmut Goebel 2020-02-03gnu: Add akonadi-contacts....* gnu/packages/kde-pim.scm (akonadi-contacts): New variable. Hartmut Goebel 2020-02-03gnu: Add akonadi-search....* gnu/packages/kde-pim.scm (akonadi-search): New variable. Hartmut Goebel 2020-02-03gnu: Add akonadi-notes....* gnu/packages/kde-pim.scm (akonadi-notes): New variable. Hartmut Goebel 2020-02-03gnu: Add akonadi-mime....* gnu/packages/kde-pim.scm (akonadi-mime): New variable. Hartmut Goebel 2020-02-03gnu: Add kalarmcal....* gnu/packages/kde-pim.scm (kalarmcal): New variable. Hartmut Goebel 2020-02-03gnu: Add ktnef....* gnu/packages/kde-pim.scm (ktnef): New variable. Hartmut Goebel 2020-02-03gnu: Add kldap....* gnu/packages/kde-pim.scm (kldap): New variable. Hartmut Goebel 2020-02-03gnu: Add kimap....* gnu/packages/kde-pim.scm (kimap): New variable. Hartmut Goebel 2020-02-03gnu: Add kidentitymanagement....* gnu/packages/kde-pim.scm (kidentitymanagement): New variable. Hartmut Goebel 2020-02-03gnu: Add kpimtextedit....* gnu/packages/kde-pim.scm (kpimtextedit): New variable. Hartmut Goebel 2020-02-03gnu: Add kcalutils....* gnu/packages/kde-pim.scm (kcalutils): New variable. Hartmut Goebel 2020-02-03gnu: Add kmbox....* gnu/packages/kde-pim.scm (kmbox): New variable. Hartmut Goebel 2020-02-03gnu: Add kmime....* gnu/packages/kde-pim.scm (kmime): New variable. Hartmut Goebel 2020-02-03gnu: Add akonadi....* gnu/packages/kde-pim.scm, gnu/packages/patches/akonadi-paths.patch, gnu/packages/patches/akonadi-Revert-Make-installation-properly-relocatabl.patch gnu/packages/patches/akonadi-timestamps.patch: New files. * gnu/local.mk (MODULES): Add kde-pim.scm. (dist_patch): Add the patches. Hartmut Goebel