aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2023 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages conky)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages curl)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages image)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages lua)
  #:use-module (gnu packages ncurses)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages pulseaudio)
  #:use-module (gnu packages xorg))

(define-public conky
  (package
    (name "conky")
    (home-page "https://github.com/brndnmtthws/conky")
    (version "1.19.8")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url home-page)
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1g712cw2nzd2qvgdmyvazyda0znyqzg6yckg98ss203fggwp93vj"))))
    (build-system cmake-build-system)
    (arguments
     `(#:configure-flags
       (list "-DRELEASE=true"
             "-DBUILD_PULSEAUDIO=ON"
             "-DBUILD_WLAN=ON"
             "-DBUILD_TESTS=ON")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'add-freetype-to-search-path
           (lambda* (#:key inputs #:allow-other-keys)
             (substitute* "cmake/ConkyPlatformChecks.cmake"
               (("set\\(INCLUDE_SEARCH_PATH")
                (string-append
                 "set(INCLUDE_SEARCH_PATH "
                 (assoc-ref inputs "freetype") "/include/freetype2 ")))
             #t))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
                    (bin (string-append out "/bin")))
               (install-file "src/conky" bin))
             #t)))))
    (inputs
     (list freetype
           imlib2
           libx11
           libxdamage
           libxext
           libxft
           libxi
           libxinerama
           pulseaudio
           lua
           ncurses
           curl
           wireless-tools))
    (native-inputs
     (list pkg-config))
    (synopsis "Lightweight system monitor for X")
    (description
     "Conky is a lightweight system monitor for X that displays operating
system statistics (CPU, disk, and memory usage, etc.) and more on the
desktop.")
    (license license:gpl3+)))
es/pdf.scm (mupdf)[replacement]: Remove field. [source]: Add 'mupdf-mujs-CVE-2016-10132.patch' and 'mupdf-mujs-CVE-2016-10133.patch'. (mupdf/fixed): Remove variable. * gnu/packages/cups.scm (cups-filters)[replacement]: Remove field. (mupdf/fixed-instead-of-mupdf),(cups-filters/fixed): Remove variables. Leo Famulari 2017-01-17gnu: cups-filters: Disable mutool integration....* gnu/packages/cups.scm (cups-filters)[arguments]: Add ‘--disable-mutool’ to #:configure-flags. [inputs]: Remove mupdf. Tobias Geerinckx-Rice 2017-01-17Revert "gnu: cups-filters: Disable mutool integration."...This change would cause 594 packages to be rebuilt, so it was moved to the staging branch. This reverts commit 58a7bbc5fe52f20910fb0fe7fddb9012f2049034. Leo Famulari 2017-01-17gnu: cups-filters: Disable mutool integration....* gnu/packages/cups.scm (cups-filters)[arguments]: Add ‘--disable-mutool’ to #:configure-flags. [inputs]: Remove mupdf. Tobias Geerinckx-Rice 2017-01-15gnu: cups-filters: Fix CVE-2016-{10132,10133} in statically linked mupdf....The vulnerabilities are in the MuJS that is bundled with MuPDF. * gnu/packages/cups.scm (cups-filters)[replacement]: New field. (mupdf/fixed-instead-of-mupdf), (cups-filters/fixed): New variables. Leo Famulari 2017-01-11gnu: cups-filters: Update to 1.13.1....* gnu/packages/cups.scm (cups-filters): Update to 1.13.1. [inputs]: Switch libjpeg-8 to libjpeg. [arguments]: Disable driverless printing, set location for bash shell. Efraim Flashner 2016-12-17gnu: Add and use sane-backends-minimal....* gnu/packages/scanner.scm (sane-backends): Rename to... (sane-backends-minimal): this. Adjust name, source, synopsis and description accordingly. * gnu/packages/cups.scm (hplip): Use 'sane-backends-minimal' instead of 'sane-backends'. * gnu/packages/gnome.scm (colord, simple-scan): Likewise. * gnu/packages/libreoffice.scm (libreoffice): Likewise. * gnu/packages/wine.scm (wine): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andy Patterson 2016-11-25gnu: hplip: Update to 3.16.11....* gnu/packages/cups.scm (hplip): Update to 3.16.11. Tobias Geerinckx-Rice 2016-10-31gnu: cups-minimal: Update to 2.2.1....* gnu/packages/cups.scm (cups-minimal): Update to 2.2.1. [source]: Use new https://github.com download URL. Tobias Geerinckx-Rice 2016-10-29Merge branch 'master' into core-updatesLeo Famulari 2016-10-30gnu: cups-filters: Remove duplicate ‘--with-gs-path=’ flag....* gnu/packages/cups.scm (cups-filters)[arguments]: Remove redundant ‘--with-gs-path=’ from #:configure-flags, left over from a botched merge. Tobias Geerinckx-Rice 2016-10-30gnu: cups-filters: Update to 1.11.5....* gnu/packages/cups.scm (cups-filters): Update to 1.11.5. [arguments]: Add ‘--with-gs-path=’ to #:configure-flags. [inputs]: Add mupdf. Tobias Geerinckx-Rice 2016-10-30gnu: hplip: Update to 3.16.10....* gnu/packages/cups.scm (hplip): Update to 3.16.10. Tobias Geerinckx-Rice 2016-10-10gnu: cups-filters: Look for test page in own output dir....* gnu/packages/cups.scm (cups-filters): Update to look for the test page template in the cups-filter output dir, as cups and cups-filter do not share an output dir. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Andy Wingo 2016-10-08gnu: cups-filters: Use ghostscript with CUPS driver....* gnu/packages/cups.scm (ghostscript/cups): New variable. (cups-filters): Use ghostscript/cups. Capture path to "gs" at compilation time. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Andy Wingo 2016-08-30gnu: cups-filters: Update to 1.10.2....* gnu/packages/cups.scm (cups-filters): Update to 1.10.2. Efraim Flashner 2016-08-30gnu: cups-filters: Add missing avahi input....* gnu/packages/cups.scm (cups-filters)[inputs]: Add avahi. This is a follow-up to commit 6c4742530a4b4b9f25f9e63dc14fe3f88c51d19d. Efraim Flashner 2016-08-29Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2016-08-29gnu: hplip: Update to 3.16.8....* gnu/packages/cups.scm (hplip): Update 3.16.8. Tobias Geerinckx-Rice 2016-08-16gnu: cups-filters: Update to 1.10.0....* gnu/packages/cups.scm (cups-filters): Update to 1.10.0. [home-page]: Update it. Efraim Flashner 2016-08-16gnu: cups: Update to 2.1.4....* gnu/packages/cups.scm (cups): Update to 2.1.4. [source]: Add Github fallback location. [home-page]: Use https. Efraim Flashner 2016-08-16gnu: cups: Use 'modify-phases'....* gnu/packages/cups.scm (cups)[arguments]: Use 'modify-phases'. Efraim Flashner 2016-07-25Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2016-07-24gnu: hplip: Update to 3.16.7....* gnu/packages/cups.scm (hplip): Update to 3.16.7. Efraim Flashner 2016-07-22Merge branch 'master' into core-updates...Resolved conflicts: * gnu/packages/scheme.scm: Conflict in import of (guix licenses). On master, "#:hide (openssl)" was used. On core-updates, "#:select (some licenses)" was used. The latter won the conflict. * gnu/packages/version-control.scm (git)[arguments]: Whitespace conflict in 'install-shell-completion. Leo Famulari 2016-07-21gnu: Update URLs for sourceforge.net....* gnu/packages/admin.scm: Update URLs pointing to sourceforge.net. * gnu/packages/audacity.scm: Likewise. * gnu/packages/audio.scm: Likewise. * gnu/packages/bioinformatics.scm: Likewise. * gnu/packages/boost.scm: Likewise. * gnu/packages/cdrom.scm: Likewise. * gnu/packages/code.scm: Likewise. * gnu/packages/compression.scm: Likewise. * gnu/packages/cups.scm: Likewise. * gnu/packages/djvu.scm: Likewise. * gnu/packages/docbook.scm: Likewise. * gnu/packages/documentation.scm: Likewise. * gnu/packages/flashing-tools.scm: Likewise. * gnu/packages/fonts.scm: Likewise. * gnu/packages/fontutils.scm: Likewise. * gnu/packages/games.scm: Likewise. * gnu/packages/ghostscript.scm: Likewise. * gnu/packages/gl.scm: Likewise. * gnu/packages/gnucash.scm: Likewise. * gnu/packages/graphviz.scm: Likewise. * gnu/packages/image.scm: Likewise. * gnu/packages/libreoffice.scm: Likewise. * gnu/packages/libusb.scm: Likewise. * gnu/packages/linux.scm: Likewise. * gnu/packages/lirc.scm: Likewise. * gnu/packages/maths.scm: Likewise. * gnu/packages/mcrypt.scm: Likewise. * gnu/packages/mp3.scm: Likewise. * gnu/packages/music.scm: Likewise. * gnu/packages/networking.scm: Likewise. * gnu/packages/onc-rpc.scm: Likewise. * gnu/packages/password-utils.scm: Likewise. * gnu/packages/pdf.scm: Likewise. * gnu/packages/perl.scm: Likewise. * gnu/packages/photo.scm: Likewise. * gnu/packages/popt.scm: Likewise. * gnu/packages/python.scm: Likewise. * gnu/packages/rdesktop.scm: Likewise. * gnu/packages/screen.scm: Likewise. * gnu/packages/swig.scm: Likewise. * gnu/packages/tcl.scm: Likewise. * gnu/packages/version-control.scm: Likewise. * gnu/packages/video.scm: Likewise. * gnu/packages/w3m.scm: Likewise. * gnu/packages/web.scm: Likewise. * gnu/packages/wm.scm: Likewise. * gnu/packages/xdisorg.scm: Likewise. * gnu/packages/xml.scm: Likewise. Leo Famulari 2016-05-09gnu: cups-minimal: Use 'modify-phases'....* gnu/packages/cups.scm (cups-minimal)[arguments]: Use 'modify-phases'. Ludovic Courtès 2016-04-29gnu: Add hplip....* gnu/packages/cups.scm (hplip): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Danny Milosavljevic 2015-12-26gnu: cups-filters: Update to 1.4.0. (fixes CVE-2015-8560)...* gnu/packages/cups.scm (cups-filters): Update to 1.4.0. Efraim Flashner 2015-09-15gnu: cups-filters: Add glib:bin as a native input....* gnu/packages/cups.scm (cups-filters)[native-inputs]: Add the bin output of the glib package. Andreas Enge 2015-09-13gnu: cups: Update to 2.1.0....* gnu/packages/cups.scm (cups, cups-minimal): Update to 2.1.0. 宋文武 2015-09-13gnu: cups-filters: Update to 1.0.75....* gnu/packages/cups.scm (cups-filters): Update to 1.0.75. 宋文武 2015-07-07gnu: cups-filters: Update to 1.0.71....* gnu/packages/cups.scm (cups-filters): Update to 1.0.71. Mark H Weaver 2015-07-05gnu: Rename module gnutls to tls....* gnu/packages/gnutls.scm: Rename to... * gnu/packages/tls.scm: ... this. Change module name accordingly. * gnu/packages/{admin.scm, cups.scm, curl.scm, dc.scm, dns.scm, emacs.scm, ftp.scm, gnome.scm, gnunet.scm, gnupg.scm, gsasl.scm, lynx.scm, mail.scm, messaging.scm, package-management.scm, shishi.scm, task-management.scm, version-control.scm, video.scm, vpn.scm, webkit.scm, weechat.scm, wget.scm, wine.scm, xml.scm}: Adapt module import to new name. * gnu-system.am (GNU_SYSTEM_MODULES): Rename gnutls module to tls. Andreas Enge 2015-07-03gnu: cups-filter: Install backends and filters under lib/cups....This ensures that they are stripped during the 'strip' phase, thereby removing references to GCC and linux-libre-headers that would otherwise be found in debugging symbols. * gnu/packages/cups.scm (cups-filters)[source]: Change pkgbackenddir and pkgfilterdir to $(PREFIX)/lib/cups/{filter,backend}. (cups)[arguments]: Adjust accordingly. Ludovic Courtès 2015-06-10gnu: cups: Update to 2.0.3....* gnu/packages/cups.scm (cups): Update to 2.0.3. Mark H Weaver 2015-04-22gnu: cups-filters: Update to 1.0.68....* gnu/packages/cups.scm (cups-filters): Update to 1.0.68. 宋文武