aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2023, 2024 Rodion Goritskov <rodion.goritskov@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages clifm)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages acl)
  #:use-module (gnu packages linux))

(define-public clifm
  (package
    (name "clifm")
    (version "1.20")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/leo-arch/clifm")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1hmky0rdrdp5zs1pgayrcgrf0ylvl2xh135r2c0g8k4ibwv3392c"))))
    (build-system gnu-build-system)
    (arguments
     `(#:make-flags (list (string-append "CC="
                                         ,(cc-for-target))
                          (string-append "PREFIX="
                                         (assoc-ref %outputs "out")))
       #:phases (modify-phases %standard-phases
                  (delete 'configure)
                  (delete 'build)
                  (delete 'check))))
    (inputs (list readline acl libcap))
    (home-page "https://github.com/leo-arch/clifm")
    (synopsis "Command-line file manager")
    (description
     "Clifm is a shell-like, text-based terminal file manager
that sits on the command line.

It is built with command line principles in mind: instead of navigating
through a big menu of files, it lets you type, exactly as you do in your
regular shell, but easier and faster.")
    (license license:gpl2+)))
> 2023-12-13gnu: xorg-server: Update to 21.1.10 [security fixes]....John Kehayias 2023-12-10Merge remote-tracking branch 'origin/master' into rust-team...Efraim Flashner 2023-11-28gnu: libxscrnsaver: Fix cross-compiling....Efraim Flashner 2023-11-28gnu: xorg-server: Update to 21.1.9 [security fixes]....Kaelyn Takata 2023-11-26Merge branch 'master' into mesa-updates...John Kehayias 2023-11-25gnu: xcompmgr: Fix cross-compilation....Zheng Junjie 2023-11-05gnu: libxpm: Ungraft....John Kehayias 2023-11-05gnu: libx11: Ungraft....John Kehayias 2023-12-03gnu: xpra: Update to 5.0.4....Andy Tai 2023-10-15gnu: iceauth: Fix source....Tobias Geerinckx-Rice 2023-10-15gnu: xcb-util-errors: Fix cross-compiling....Efraim Flashner 2023-10-15gnu: xorg-server-xwayland: Fix cross-compiling....Efraim Flashner 2023-10-15gnu: egl-wayland: Fix cross-compiling....Efraim Flashner 2023-10-14gnu: xpra: Update to 5.0.3...Andy Tai 2023-10-04gnu: libxpm: Graft with 3.5.17 [security fixes]....John Kehayias 2023-10-04gnu: libx11: Update replacement to 1.8.7 [security fixes]....John Kehayias 2023-09-28gnu: xpra: Update to 5.0.2...Andy Tai 2023-09-19gnu: xterm: Update to 384....Efraim Flashner 2023-09-02gnu: libx11: Graft with 1.8.6 [security fixes]....Kaelyn Takata 2023-08-28gnu: Add fonttosfnt....宋文武