aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2023, 2024 Rodion Goritskov <rodion.goritskov@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages clifm)
  #:use-module (guix packages)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (guix git-download)
  #:use-module (guix build-system gnu)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages acl)
  #:use-module (gnu packages file)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages readline))

(define-public clifm
  (package
    (name "clifm")
    (version "1.22")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/leo-arch/clifm")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1iwlijdm4mr5bp5rilxr11f04q2q4ak49m8askzbw0shyi8i1sli"))))
    (build-system gnu-build-system)
    (arguments
     `(#:make-flags (list (string-append "CC="
                                         ,(cc-for-target))
                          (string-append "PREFIX="
                                         (assoc-ref %outputs "out")))
       #:phases (modify-phases %standard-phases
                  (delete 'configure)
                  (delete 'build)
                  (delete 'check)
                  (add-after 'unpack 'fix-bash-completion-directory
                    (lambda _
                      (substitute* "Makefile"
                        (("\\$\\(DATADIR\\)/bash-completion/completions")
                         "$(PREFIX)/etc/bash_completion.d")))))))
    (inputs (list acl file libcap readline))
    (home-page "https://github.com/leo-arch/clifm")
    (synopsis "Command-line file manager")
    (description
     "Clifm is a shell-like, text-based terminal file manager
that sits on the command line.

It is built with command line principles in mind: instead of navigating
through a big menu of files, it lets you type, exactly as you do in your
regular shell, but easier and faster.")
    (license license:gpl2+)))
0200'>2021-04-21gnu: Add libcxxabi-6....* gnu/packages/llvm.scm (libcxxabi-6): New variable. Ricardo Wurmus 2021-04-16Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: gnu/local.mk gnu/packages/boost.scm gnu/packages/chez.scm gnu/packages/compression.scm gnu/packages/crates-io.scm gnu/packages/docbook.scm gnu/packages/engineering.scm gnu/packages/gcc.scm gnu/packages/gl.scm gnu/packages/gtk.scm gnu/packages/nettle.scm gnu/packages/python-check.scm gnu/packages/python-xyz.scm gnu/packages/radio.scm gnu/packages/rust.scm gnu/packages/sqlite.scm guix/build-system/node.scm Efraim Flashner 2021-04-10gnu: Remove clang-runtime-3.6 and clang-3.6....* gnu/packages/llvm.scm (clang-runtime-3.6, clang-3.6): Remove variables. Signed-off-by: Leo Famulari <leo@famulari.name> zimoun 2021-03-24Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2021-03-17gnu: Use PACKAGE/INHERIT in more places....* gnu/packages/algebra.scm (fftwf, fftw-openmpi), gnu/packages/audio.scm (ztoolkit-rsvg), gnu/packages/bioinformatics.scm (python2-dendropy), gnu/packages/boost.scm (boost-with-python2), gnu/packages/check.scm (python2-mock, python2-pytest-mock), gnu/packages/cups.scm (hplip-minimal), gnu/packages/freedesktop.scm (libinput-minimal), gnu/packages/gettext.scm (gnu-gettext), gnu/packages/glib.scm (python2-pygobject), gnu/packages/gnome.scm (gdl-minimal, libsoup-minimal, python2-pyatspi), gnu/packages/groff.scm (groff-minimal), gnu/packages/jami.scm (ffmpeg-jami), gnu/packages/libcanberra.scm (libcanberra/gtk+-2), gnu/packages/lirc.scm (python2-lirc), gnu/packages/llvm.scm (clang-runtime-3.5), gnu/packages/mpi.scm (java-openmpi, openmpi-thread-multiple), gnu/packages/node.scm (libnode), gnu/packages/onc-rpc.scm (libtirpc/hurd), gnu/packages/python-compression.scm (bitshuffle-for-snappy), gnu/packages/python-crypto.scm (python2-pycrypto, python2-cryptography) (python2-cryptography, python2-m2crypto), gnu/packages/python-web.scm (python2-html2text, python2-tornado) (python2-terminado, python2-ndg-httpsclient, python2-websocket-client) (python2-rauth, python2-url, python2-s3transfer), gnu/packages/python-xyz.scm (python2-psutil, python2-serpent) (python2-humanfriendly, python2-empy, python2-parse-type, python2-polib) (python2-jsonschema, python2-pystache, python2-cython, python2-numpydoc) (python2-ipyparallel, python2-traitlets, python2-dbus) (python2-beautifulsoup4, python2-pep517, python2-flake8, python2-llfuse) (python2-tlsh, python-file, python2-notebook, python-jupyter-console-minimal) (python2-contextlib2, python2-promise, python2-anyjson, python2-amqp) (python2-kombu, python2-billiard, python2-celery, python2-whoosh) (python2-jellyfish, python-rope, ptpython-2, python2-binaryornot) (python2-setproctitle, python2-argcomplete, python2-xopen, python2-isort) (python2-radon, python2-rfc6555, python2-activepapers, python2-send2trash) (python2-cloudpickle, python2-reparser), gnu/packages/python.scm (python2-called-python), gnu/packages/qt.scm (python2-sip, python-pyqt-without-qtwebkit, python2-pyqt) (python-qscintilla, python-pyqt+qscintilla), gnu/packages/scanner.scm (sane-backends), gnu/packages/sdl.scm (guile3.0-sdl2), gnu/packages/selinux.scm (checkpolicy, libselinux, libsemanage, secilc) (python-sepolgen, policycoreutils), gnu/packages/serialization.scm (lua5.1-libmpack, lua5.2-libmpack), gnu/packages/simulation.scm (fenics), gnu/packages/statistics.scm (python2-statsmodels), gnu/packages/texinfo.scm (info-reader), gnu/packages/wxwidgets.scm (wxwidgets-gtk2, wxwidgets-gtk2-3.1), gnu/packages/xml.scm (xmlsec-nss), gnu/packages/xorg.scm (uim-gtk, uim-qt), guix/build-system/python.scm (package-with-explicit-python) (strip-python2-variant): Use PACKAGE/INHERIT. Mark H Weaver 2021-03-06Merge branch 'master' into core-updatesChristopher Baines 2021-03-02gnu: ocaml-llvm: Move to (gnu packages llvm)....Commit 8f710cc598fb675d267f49a82cffc197f03ad52c introduced a circular dependency between ocaml.scm and llvm.scm by referring to 'llvm' from the top level of ocaml.scm. This fixes it. * gnu/packages/ocaml.scm (make-ocaml-llvm, ocaml-llvm) (ocaml-llvm-9, ocaml-llvm-10, ocaml-llvm-11): Move to... * gnu/packages/llvm.scm: ... here. Ludovic Courtès 2021-01-16Revert "gnu: llvm: Update to 11.0.1."...This reverts commit 9b415c0b36c885e7899c45617a8c4e64118a6379, which reportedly breaks[0] rust@1.47.0, rust-1.48.0 and rust-1.49.0. [0]: http://issues.guix.gnu.org/45909 Tobias Geerinckx-Rice 2021-01-13Merge branch 'staging' into 'core-updates'....Conflicts: gnu/local.mk gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/guile.scm gnu/packages/node.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/python-xyz.scm gnu/packages/python.scm gnu/packages/tls.scm gnu/packages/vpn.scm gnu/packages/xorg.scm Maxim Cournoyer 2021-01-10gnu: llvm: Update to 11.0.1....* gnu/packages/llvm.scm (llvm): Update to 11.0.1. (clang-runtime-11, clang-11): Update corresponding source hashes. Tobias Geerinckx-Rice 2020-12-19gnu: llvm: Update download URI....New and old releases are now only available on GitHub. * gnu/packages/llvm.scm (llvm-uri): Remove "releases.llvm.org". Marius Bakke 2020-12-19gnu: LLVM: Build with Python 3....* gnu/packages/llvm.scm (llvm-11)[native-inputs]: Change from PYTHON-2 to PYTHON-WRAPPER. Marius Bakke 2020-12-19gnu: LLVM@10: Re-apply 10.0.1 update....This is a fixup for the merge in 5e2140511c1ad9ccd731438b74d61b62111da1e6 as well as the previous fixup in e37c575723b38a4e64df798fc8a922e26c849a3f which partially reverted the LLVM@10 update from 66e3812e2fb152f9a98e85f7d74a92753a2873b8. * gnu/packages/llvm.scm (llvm-10): Update to 10.0.1. Marius Bakke 2020-12-17gnu: Remove duplicate LLVM variables....These were accidentally added in commit 5e2140511c1ad9ccd731438b74d61b62111da1e6. * gnu/packages/llvm.scm (llvm-10, llvm, clang-runtime, clang, clang-toolchain, lld): Remove duplicate definitions. Marius Bakke 2020-11-29Merge remote-tracking branch 'origin/master' into core-updatesChristopher Baines 2020-11-14gnu: python-llvmlite: Update to 0.34.0....This is in preparation of updating the broken python-numba package. * gnu/packages/llvm.scm (python-llvmlite): Update to 0.34.0. [arguments]: Enable tests. [phases]{patch-reference-to-llvmlite, skip-failing-tests} {set-compiler/linker-flags}: New phases. [inputs]: Update custom LLVM input and associated patches. [home-page]: Use HTTPS. Maxim Cournoyer 2020-11-14gnu: llvm-9: Standardize patch level....Having a non-standard (different than 1) patch level requirement means the patches cannot be composed easily from different origins. The following command was used to remove one level from the llvm-9 patches: sed -e 's|^--- a/|--- |' -e 's|^+++ b/|+++ |' \ gnu/packages/patches/llvm-9* -i * gnu/packages/llvm.scm (llvm-9)[source]: Drop the patch-flags field. Re-indent list of patches. * gnu/packages/patches/llvm-9-fix-bitcast-miscompilation.patch: Strip one level. * gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch: Likewise. * gnu/packages/patches/llvm-9-fix-scev-miscompilation.patch: Likewise. Maxim Cournoyer 2020-10-22gnu: Add LLDB....* gnu/packages/llvm.scm (lldb): New public variable. Marius Bakke 2020-10-22gnu: clang@10, clang@11: Fix CMake files....* gnu/packages/llvm.scm (clang-from-llvm): Add phase adjust-cmake-file when building Clang 10 or later. Marius Bakke 2020-10-19Merge branch 'staging'...Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/gdb.scm gnu/packages/llvm.scm gnu/packages/package-management.scm gnu/packages/tls.scm Maxim Cournoyer 2020-10-19gnu: lld: Update to 11.0.0....* gnu/packages/llvm.scm (lld): Update to 11.0.0. [inputs]: Change from LLVM-10 to LLVM-11. Marius Bakke 2020-10-19gnu: LLVM, Clang: Add 11.0.0....* gnu/packages/patches/clang-11.0-libc-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (llvm-11, clang-runtime-11, clang-11, clang-toolchain-11): New variables. Marius Bakke 2020-10-19gnu: llvm.scm: Reorder variables....Keep all LLVM and Clang packages in order, define default versions last. Marius Bakke 2020-10-19gnu: extempore: Inline custom package variants....Except novel ones without suitable replacements in Guix. * gnu/packages/music.scm (portmidi-for-extempore): Remove variable, and move to ... (extempore)[inputs]: ... here. * gnu/packages/llvm.scm (llvm-for-extempore): Likewise. * gnu/packages/image.scm (stb-image-for-extempore): Likewise. Marius Bakke 2020-10-12gnu: clang-toolchain: Create 'cc' and 'c++' symlinks....* gnu/packages/llvm.scm (make-clang-toolchain)[arguments]: Create 'cc' and 'c++' symlinks. Ludovic Courtès 2020-10-12gnu: clang-toolchain: Add 'GUIX_LOCPATH' to the search paths....* gnu/packages/llvm.scm (make-clang-toolchain)[native-search-paths]: Add 'GUIX_LOCPATH'. Ludovic Courtès 2020-10-10gnu: Rename 'llvm-download-uri' to 'llvm-uri'....* gnu/packages/llvm.scm (llvm-download-uri): Rename to ... (llvm-uri): ... this. Adjust callers accordingly. Marius Bakke 2020-09-18gnu: llvm: Update to 10.0.1....* gnu/packages/llvm.scm (llvm, clang, clang-runtime, clang-toolchain, lld): Update to 10.0.1. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Greg Hogan