aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ccache)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:select (gpl3+))
  #:use-module (guix download)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages ruby))

(define-public ccache
  (package
    (name "ccache")
    (version "4.8.3")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://github.com/ccache/ccache/releases/download/v"
                           version "/ccache-" version ".tar.xz"))
       (sha256
        (base32 "049b3xhp464w5m1bqi4ripbgyqy7qy31vvk56v5cyj5j23478wz4"))))
    (build-system cmake-build-system)
    (arguments
     (list #:configure-flags
           ;; The backend must be explicitly disabled to build without Redis.
           #~(list "-DREDIS_STORAGE_BACKEND=OFF")
           #:phases
           #~(modify-phases %standard-phases
               (add-before 'configure 'fix-shell
                 ;; Run early whilst we're still in the source directory.
                 (lambda _
                   (substitute* (list "test/run"
                                      "test/suites/base.bash"
                                      "unittest/test_hashutil.cpp")
                     (("compgen -e") "env | cut -d= -f1")
                     (("#!/bin/sh") (string-append "#!" (which "sh"))))))
               (add-before 'check 'set-home
                 ;; Tests require a writable HOME.
                 (lambda _
                   (setenv "HOME" (getenv "TMPDIR")))))))
    (native-inputs
     (append (list perl which)
             (if (supported-package? ruby-asciidoctor)
               (list ruby-asciidoctor)
               '())))
    (inputs (list zlib `(,zstd "lib")))
    (home-page "https://ccache.dev/")
    (synopsis "Compiler cache")
    (description
     "Ccache is a compiler cache.  It speeds up recompilation by caching
previous compilations and detecting when the same compilation is being done
again.  Supported languages are C, C++, Objective-C and Objective-C++.")
    (license gpl3+)))
ui): Update to 2.1.0-beta1. [inputs]: Replace proj.4 with proj and wxwidgets-2 with wxwidgets. Add curl, giflib, librasterlite2, librttopo, libwebp, libxlsxwriter, lz4, minizip, openjpeg, postgresql, virtualpg, zstd. Remove libgaiagraphics and zlib. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber 2021-03-29gnu: Add librasterlite2....* gnu/packages/geo.scm (librasterlite2): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber 2021-03-29gnu: libspatialite: Update dependencies....* gnu/packages/geo.scm (libspatialite, spatialite-tools): Update dependencies. [inputs]: Replace proj.4 with proj and remove zlib which is not used anymore since libspatialite started using minizip. (libspatialite)[arguments]: Fix regex to not disable more tests than necessary. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber 2021-03-27gnu: Use 'gtk-doc/stable' in native-inputs of selected packages....* gnu/packages/calendar.scm (libical), gnu/packages/check.scm (umockdev), gnu/packages/fontutils.scm (libraqm), gnu/packages/freedesktop.scm (appstream, farstream, libglib-testing) (udisks, libfprint, libportal), gnu/packages/geo.scm (memphis, osm-gps-map), gnu/packages/glib.scm (template-glib), gnu/packages/gnome.scm (gupnp-igd, libcloudproviders, libgrss, seed) (gtx, dee, zeitgeist, phodav, gssdp, gupnp, gupnp-dlna, gupnp-av, rygel) (libnma, gdl, libnotify, vte-ng, dconf, libxklavier, libsoup, colord) (geoclue, geocode-glib, amtk, grilo, gvfs, gusb, network-manager) (network-manager-applet, gfbgraph, libunique, cheese, libhandy) (gnome-latex, libgda), gnu/packages/gstreamer.scm (orc), gnu/packages/gtk.scm (at-spi2-core, goocanvas), gnu/packages/language.scm (nimf), gnu/packages/networking.scm (libnice), gnu/packages/video.scm (schroedinger), gnu/packages/virtualization.scm (libosinfo), gnu/packages/webkit.scm (wpewebkit, webkitgtk), gnu/packages/xml.scm (libxmlb)[native-inputs]: Replace 'gtk-doc' with 'gtk-doc/stable'. Mark H Weaver 2021-03-09gnu: xygrib: Fix compiling with newer qt....* gnu/packages/geo.scm (xygrib)[source]: Adjust snippet to add missing include header. Efraim Flashner 2021-03-05gnu: virtualpg: Update to 2.0.1....* gnu/packages/geo.scm (virtualpg): Update to 2.0.1. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber 2021-02-27gnu: libspatialite: Update to 5.0.1....* gnu/packages/geo.scm (libspatialite, spatialite-tools): Update to 5.0.1. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Felix Gruber 2021-02-09gnu: postgis: Update to 3.1.1....* gnu/packages/geo.scm (postgis): Update to 3.1.1. [inputs]: Add protobuf-c. Guillaume Le Vaillant 2021-02-08gnu: qgis: Update to 3.16.3....* gnu/packages/geo.scm (qgis): Update to 3.16.3. [inputs]: Add protobuf. [arguments]: Update 'configure-pyqt5-sip-path' and 'check' phases. Guillaume Le Vaillant 2021-02-08gnu: qgis: Disable SAGA....QGIS support for SAGA is currently not working. * gnu/packages/geo.scm (qgis)[inputs]: Remove saga. [arguments]: Remove PATH wrapping for saga. Guillaume Le Vaillant 2021-02-03gnu: qmapshack: Update to 1.15.2....* gnu/packages/geo.scm (qmapshack): Update to 1.15.2. Guillaume Le Vaillant 2021-01-27gnu: Add shapelib...* gnu/packages/geo.scm (shapelib): New variable Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Sharlatan Hellseher 2021-01-02gnu: routino: Update to 3.3.3....* gnu/packages/geo.scm (routino): Update to 3.3.3. Tobias Geerinckx-Rice 2020-12-29gnu: readosm: Update source hash....Looks like the tarball was changed by upstream, lots of timestamps changed from 2020-08-02 to 2020-08-23, and there were some minor changes to file contents. * gnu/packages/geo.scm (source): Update hash. Christopher Baines 2020-12-29gnu: gnome-maps: Patch DBUS service....* gnu/packages/geo.scm (gnome-maps): [arguments]<#:phases>: Add patch-dbus-service. Leo Prikler 2020-12-23gnu: grass: Update to 7.8.5....* gnu/packages/geo.scm (grass): Update to 7.8.5. Tobias Geerinckx-Rice 2020-12-13gnu: josm: Update to 17329....* gnu/packages/geo.scm (josm): Update to 17329. Julien Lepiller 2020-12-01gnu: libspatialite: Update to 5.0.0....* gnu/packages/geo.scm (libspatialite, spatialite-tools): Update to 5.0.0. [inputs]: Add new required dependencies minizip and librttopo. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber 2020-12-01gnu: Add librttopo....* gnu/packages/geo.scm (librttopo): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Felix Gruber 2020-11-24gnu: postgis: Update to 3.0.3....* gnu/packages/geo.scm (postgis): Update to 3.0.3. Tobias Geerinckx-Rice 2020-11-19gnu: Don't append '.git' to GitHub uris....* gnu/packages/admin.scm (nmrpflash)[source]: Remove '.git' from URI. * gnu/packages/aidc.scm (zxing-cpp), * gnu/packages/assembly.scm (mbuild), * gnu/packages/audio.scm (opensles, wildmidi, tinyalsa), * gnu/packages/browser-extensions.scm (ublock-origin-chromium), * gnu/packages/check.scm (mutest), * gnu/packages/compression.scm (unshield), * gnu/packages/coq.scm (subset), * gnu/packages/dictionaries.scm (translate-shell), * gnu/packages/disk.scm (memkind), * gnu/packages/documentation.scm (latex2html), * gnu/packages/emacs-xyz.scm (emacs-chronometrist, emacs-flycheck-ledger, emacs-counsel-notmuch, emacs-spaceline, emacs-org-generate), * gnu/packages/embedded.scm (ebusd, ebusd-configuration), * gnu/packages/enchant.scm (nuspell), * gnu/packages/fontutils.scm (woff2), * gnu/packages/geo.scm (memphis), * gnu/packages/gimp.scm (mrg), * gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator), * gnu/packages/gnome.scm (parlatype), * gnu/packages/golang.scm (go-github-com-tv42-httpunix, go-github-com-ayufan-golang-kardianos-service), * gnu/packages/graphics.scm (eglexternalplatform, egl-wayland, mmm, directfb, flux), * gnu/packages/gstreamer.scm (openni2, ccextractor, libvisual, graphene), * gnu/packages/guile-xyz.scm (guile-srfi-180, guile-torrent), * gnu/packages/image.scm (openjpeg-data), * gnu/packages/java.scm (javacc), * gnu/packages/language.scm (liblouis, liblouisutdml), * gnu/packages/linux.scm (pamela, ttyebus), * gnu/packages/lxqt.scm (lxqt-connman-applet), * gnu/packages/mail.scm (libetpan), * gnu/packages/man.scm (ronn), * gnu/packages/music.scm (tascam-gtk, artyfx), * gnu/packages/networking.scm (srt, lksctp-tools, nng, nanomsg), * gnu/packages/python-crypto.scm (pure-python-otr), * gnu/packages/qt.scm (qtspell), * gnu/packages/raspberry-pi.scm (raspi-gpio, raspi-open-firmware), * gnu/packages/rdp.scm (freerdp), * gnu/packages/ruby.scm (ruby-prawn-templates, ruby-treetop, ruby-gimme, ruby-standard, ruby-rubocop-ast, ruby-rexml, ruby-range-compressor, ruby-regexp-property-values, ruby-regexp-parser, ruby-rubocop, ruby-pdf-reader, ruby-pdf-inspector, ruby-prawn), * gnu/packages/syncthing.scm (syncthing-gtk), * gnu/packages/video.scm (svt-hevc, mediasdk, libvideogfx, libde265, tslib), * gnu/packages/xml.scm (libxmlb, libxmlplusplus)[source]: Same. Efraim Flashner 2020-10-26gnu: qgis: Fix many plugins....Fixes <https://issues.guix.gnu.org/42941>. This fixes the installation of many plugins. * gnu/packages/geo.scm (qgis)[inputs]: Add python-future. Signed-off-by: Christopher Baines <mail@cbaines.net> Jonathan Brielmaier 2020-10-22gnu: josm: Update to 17084....* gnu/packages/geo.scm (josm): Update to 17084. Julien Lepiller 2020-10-16gnu: grass: Fix start-up without python@3 in profile....* gnu/packages/geo.scm (grass)[arguments]: Rename ‘wrap-python’ phase to ‘python:wrap’. Add ‘wrap-with-python-interpreter’ phase. Tobias Geerinckx-Rice 2020-10-16gnu: grass: Update to 7.8.4....* gnu/packages/geo.scm (grass): Update to 7.8.4. Tobias Geerinckx-Rice