aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ccache)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:select (gpl3+))
  #:use-module (guix download)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages ruby))

(define-public ccache
  (package
    (name "ccache")
    (version "4.8.3")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://github.com/ccache/ccache/releases/download/v"
                           version "/ccache-" version ".tar.xz"))
       (sha256
        (base32 "049b3xhp464w5m1bqi4ripbgyqy7qy31vvk56v5cyj5j23478wz4"))))
    (build-system cmake-build-system)
    (arguments
     (list #:configure-flags
           ;; The backend must be explicitly disabled to build without Redis.
           #~(list "-DREDIS_STORAGE_BACKEND=OFF")
           #:phases
           #~(modify-phases %standard-phases
               (add-before 'configure 'fix-shell
                 ;; Run early whilst we're still in the source directory.
                 (lambda _
                   (substitute* (list "test/run"
                                      "test/suites/base.bash"
                                      "unittest/test_hashutil.cpp")
                     (("compgen -e") "env | cut -d= -f1")
                     (("#!/bin/sh") (string-append "#!" (which "sh"))))))
               (add-before 'check 'set-home
                 ;; Tests require a writable HOME.
                 (lambda _
                   (setenv "HOME" (getenv "TMPDIR")))))))
    (native-inputs
     (append (list perl which)
             (if (supported-package? ruby-asciidoctor)
               (list ruby-asciidoctor)
               '())))
    (inputs (list zlib `(,zstd "lib")))
    (home-page "https://ccache.dev/")
    (synopsis "Compiler cache")
    (description
     "Ccache is a compiler cache.  It speeds up recompilation by caching
previous compilations and detecting when the same compilation is being done
again.  Supported languages are C, C++, Objective-C and Objective-C++.")
    (license gpl3+)))
olas Goaziou 2019-07-17Merge branch 'master' into core-updatesLudovic Courtès 2019-07-16gnu: snap: Update to 5.0.4....* gnu/packages/education.scm (snap): Update to 5.0.4. Nicolas Goaziou 2019-07-15gnu: Adjust CPATH overrides to work with GCC 7 search paths....* gnu/packages/education.scm (gcompris)[arguments]: Preserve original CPATH, if any. * gnu/packages/games.scm (ltris, prboom-plus, abbaye, red-eclipse, btanks, 4dtris, edgar)[arguments]: Likewise. Marius Bakke 2019-07-09gnu: snap: Update to 5.0.1....* gnu/packages/education.scm (snap): Update to 5.0.1. Nicolas Goaziou 2019-06-28gnu: snap: Update to 5....* gnu/packages/education.scm (snap): Update to 5. Nicolas Goaziou 2019-05-29gnu: Add childsplay....* gnu/packages/education.scm (childsplay): New variable. Nicolas Goaziou 2019-05-19gnu: toutenclic: Update to 7.00....* gnu/packages/education.scm (toutenclic): Update to 7.00. [arguments]: Rename executable from "toutenclic.py" to "toutenclic". Nicolas Goaziou 2019-03-18gnu: toutenclic: Update to 6.13....* gnu/packages/education.scm (toutenclic): Update to 6.13. Tobias Geerinckx-Rice 2019-03-16gnu: Add toutenclic....* gnu/packages/education.scm (toutenclic): New variable. Nicolas Goaziou 2019-03-12gnu: gcompris-qt: Update to 0.96....* gnu/packages/education.scm (gcompris-qt): Update to 0.96. [inputs]: Add openssl. Tobias Geerinckx-Rice 2019-01-16gnu: Move sqlite to separate module....* gnu/packages/databases.scm (sqlite, sqlite-3.26.0, sqlite-with-fts5, sqlite-with-column-metadata): Move variables from here... * gnu/packages/sqlite.scm: ...to this new module. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/apl.scm, gnu/packages/bittorrent.scm, gnu/packages/calendar.scm, gnu/packages/code.scm, gnu/packages/crypto.scm, gnu/packages/databases.scm, gnu/packages/dc.scm, gnu/packages/disk.scm, gnu/packages/ebook.scm, gnu/packages/education.scm, gnu/packages/emacs.scm, gnu/packages/emulators.scm, gnu/packages/file-systems.scm, gnu/packages/freedesktop.scm, gnu/packages/ftp.scm, gnu/packages/games.scm, gnu/packages/geo.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnuzilla.scm, gnu/packages/gps.scm, gnu/packages/guile.scm, gnu/packages/ibus.scm, gnu/packages/kerberos.scm, gnu/packages/kodi.scm, gnu/packages/lisp.scm, gnu/packages/mail.scm, gnu/packages/messaging.scm, gnu/packages/mpd.scm, gnu/packages/music.scm, gnu/packages/networking.scm, gnu/packages/nfs.scm, gnu/packages/ocaml.scm, gnu/packages/package-management.scm, gnu/packages/pdf.scm, gnu/packages/photo.scm, gnu/packages/php.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/ruby.scm, gnu/packages/scheme.scm, gnu/packages/sync.scm, gnu/packages/syndication.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/web-browsers.scm, gnu/packages/webkit.scm: Adjust module references. Ricardo Wurmus 2018-12-24gnu: gcompris-qt: Enable tests....* gnu/packages/education.scm (gcompris-qt)[arguments]: Add custom phase to start X server before tests. Add configure flag to build tests. Enable tests. [native-inputs]: Add xorg-server. Efraim Flashner 2018-12-24gnu: gcompris-qt: Update to 0.95....* gnu/packages/education.scm (gcompris-qt): Update to 0.95. [arguments]: Remove custom phase to patch for qt@5.11. Efraim Flashner 2018-12-14gnu: snap: Update to 4.2.2.9....* gnu/packages/education.scm (snap): Update to 4.2.2.9. Nicolas Goaziou 2018-10-22gnu: snap: Update to 4.2.2.2....* gnu/packages/education.scm (snap): Update to 4.2.2.2. Update source URL. Nicolas Goaziou 2018-09-21gnu: snap: Update to 4.2.1.4....* gnu/packages/education.scm (snap): Update to 4.2.1.4. Nicolas Goaziou 2018-08-10gnu: snap: Update to 4.2.1.3....* gnu/packages/education.scm (snap): Update to 4.2.1.3. Nicolas Goaziou 2018-06-03gnu: gcompris-qt: Update to 0.91....* gnu/packages/education.scm (gcompris-qt): Update to 0.91. [arguments]: Add custom phase to fix building with Qt 5.11. Efraim Flashner 2018-05-31gnu: tipp10: Use INVOKE....* gnu/packages/education.scm (tipp10)[arguments]: Substitute INVOKE for SYSTEM*. Tobias Geerinckx-Rice 2018-05-11gnu: Add snap....* gnu/packages/education.scm (snap): New variable. Nicolas Goaziou 2018-04-22gnu: gcompris-qt: Update to 0.90....* gnu/packages/education.scm (gcompris-qt): Update to 0.90. [source, home-page]: Use https. [arguments]: Add 'wrap-executable phase to declare the QT_PLUGIN_PATH and QML2_IMPORT_PATH without needing propagated inputs. [native-inputs]: Add qttools. [inputs]: Remove qt, add qtbase, qtdeclarative, qtgraphicaleffects, qtmultimedia, qtquickcontrols, qtsensors, qtsvg, qtxmlpatterns. Efraim Flashner 2017-07-05gnu: gcompris: Update to 17.05....* gnu/packages/education.scm (gcompris): Update to 17.05. Efraim Flashner 2017-04-26gnu: Add gcompris-qt....* gnu/packages/education.scm (gcompris-qt): New variable. Efraim Flashner