aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ccache)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module ((guix licenses) #:select (gpl3+))
  #:use-module (guix download)
  #:use-module (guix build-system cmake)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages ruby))

(define-public ccache
  (package
    (name "ccache")
    (version "4.8.3")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://github.com/ccache/ccache/releases/download/v"
                           version "/ccache-" version ".tar.xz"))
       (sha256
        (base32 "049b3xhp464w5m1bqi4ripbgyqy7qy31vvk56v5cyj5j23478wz4"))))
    (build-system cmake-build-system)
    (arguments
     (list #:configure-flags
           ;; The backend must be explicitly disabled to build without Redis.
           #~(list "-DREDIS_STORAGE_BACKEND=OFF")
           #:phases
           #~(modify-phases %standard-phases
               (add-before 'configure 'fix-shell
                 ;; Run early whilst we're still in the source directory.
                 (lambda _
                   (substitute* (list "test/run"
                                      "test/suites/base.bash"
                                      "unittest/test_hashutil.cpp")
                     (("compgen -e") "env | cut -d= -f1")
                     (("#!/bin/sh") (string-append "#!" (which "sh"))))))
               (add-before 'check 'set-home
                 ;; Tests require a writable HOME.
                 (lambda _
                   (setenv "HOME" (getenv "TMPDIR")))))))
    (native-inputs
     (append (list perl which)
             (if (supported-package? ruby-asciidoctor)
               (list ruby-asciidoctor)
               '())))
    (inputs (list zlib `(,zstd "lib")))
    (home-page "https://ccache.dev/")
    (synopsis "Compiler cache")
    (description
     "Ccache is a compiler cache.  It speeds up recompilation by caching
previous compilations and detecting when the same compilation is being done
again.  Supported languages are C, C++, Objective-C and Objective-C++.")
    (license gpl3+)))
2021-06-23Merge branch 'master' into core-updates...Conflicts: gnu/packages/cups.scm gnu/packages/python-web.scm gnu/packages/web.scm guix/build/maven/pom.scm Tobias Geerinckx-Rice 2021-06-20gnu: openvpn: Update to 2.5.3....* gnu/packages/vpn.scm (openvpn): Update to 2.5.3. Signed-off-by: Brice Waegeneire <brice@waegenei.re> Solene Rapenne 2021-06-19Merge branch 'master' into core-updates...Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm Marius Bakke 2021-06-19gnu: Add missing imports to (gnu packages vpn)....This follows up on c85ed0e758d7fa230c08dba6b95c65ceac098d50. * gnu/packages/vpn.scm: Import (gnu packages curl), (gnu packages gnome), and (gnu packages multiprecision). * gnu/packages/networking.scm: Remove unused (gnu packages multiprecision) import. f Tobias Geerinckx-Rice 2021-06-19gnu: Move strongswan to (gnu packages vpn)....See <https://logs.guix.gnu.org/guix/2021-06-19.log#015517>. * gnu/packages/networking.scm (strongswan): Move from here… * gnu/packages/vpn.scm (strongswan): …to here. Tobias Geerinckx-Rice 2021-06-04gnu: wireguard-tools: Set #:sh argument of 'wrap-program'....* gnu/packages/vpn.scm (wireguard-tools)[arguments]<#:phases>{wrap-wg-quick}: Set #:sh argument of ‘wrap-program’. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-06-04gnu: protonvpn-cli: Set #:sh argument of 'wrap-program'....* gnu/packages/vpn.scm (protonvpn-cli)[arguments]<#:phases>{wrap-wrapper}: Set #:sh argument of ‘wrap-program’. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-06-04gnu: openconnect-sso: Set #:sh argument of 'wrap-program'....* gnu/packages/vpn.scm (openconnect-sso)[arguments]<#:phases>{wrap-qt-process-path} Set #:sh argument of ‘wrap-program’. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-06-04gnu: vpnc-scripts: Set #:guile argument of 'wrap-script'....* gnu/packages/vpn.scm (vpnc-scripts)[arguments]<#:phases>{wrap-scripts}: Set #:guile argument of ‘wrap-script’. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-04-27gnu: wireguard-tools: Update to 1.0.20210424....* gnu/packages/vpn.scm (wireguard-tools): Update to 1.0.20210424. Tobias Geerinckx-Rice 2021-04-22gnu: openvpn: Update to 2.5.2....* gnu/packages/vpn.scm (openvpn): Update to 2.5.2. Tobias Geerinckx-Rice 2021-04-22gnu: openconnect-sso: Update to 0.7.3....* gnu/packages/vpn.scm (openconnect-sso): Update to 0.7.3. Tobias Geerinckx-Rice 2021-04-13gnu: openconnect-sso: Update to 0.7.2....* gnu/packages/vpn.scm (openconnect-sso): Update to 0.7.2. [arguments]: Remove 'adjust-package-version-requirements phase. Efraim Flashner 2021-03-29gnu: wireguard-tools: Update to 1.0.20210315....* gnu/packages/vpn.scm (wireguard-tools): Update to 1.0.20210315. Tobias Geerinckx-Rice 2021-03-13gnu: wireguard-tools: Update to 1.0.20210223....* gnu/packages/vpn.scm (wireguard-tools): Update to 1.0.20210223. Tobias Geerinckx-Rice 2021-03-11gnu: openvpn: Update to 2.5.1 [security fixes]....Non-exhaustively, fixes CVE-2020-7224. * gnu/packages/vpn.scm (openvpn): Update to 2.5.1. Léo Le Bouter